Subject: [Gen-art] Gen-ART Last Call review of draft-ietf-nfsv4-rpcrdma-bidirection-06

From: Meral Shirazipour <[email-masked]>
Date: Tue, 7 Feb 2017 19:45:28 +0000

I am the assigned Gen-ART reviewer for this draft. The General Area Review Team (Gen-ART) reviews all IETF documents being processed by the IESG for the IETF Chair.  Please treat these comments just like any other last call comments.
For more information, please see the FAQ at <http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>.

Document: draft-ietf-nfsv4-rpcrdma-bidirection-06
Reviewer: Meral Shirazipour
Review Date: 2017-02-07
IETF LC End Date:   2017-02-07
IESG Telechat date: -

Summary:
This draft is ready to be published as Standards Track RFC but I have comments.

Major issues:
Minor issues:
Nits/editorial comments:
-General: please consider spelling out acronyms at first use and use the acronym consistently thereafter.
-[Page 6], "(ie. a "---->"(i.e., a"

Best Regards,
Meral
---
Meral Shirazipour
Ericsson Research
www.ericsson.com

---

From: Chuck Lever <[email-masked]>
Date: Tue, 7 Feb 2017 15:26:19 -0500

> On Feb 7, 2017, at 2:45 PM, Meral Shirazipour <[email-masked]> wrote:
> 

To address this comment (and Jouni's related LC comment)
I've introduced the following forward definitions:

- RPC = Remote Procedure Call

- RDMA = Remote Direct Memory Access

- RPC-over-RDMA - defined by citation

- NFS = Network File System

- XDR - removed all usage

- XID = RPC transaction ID, and capitalized consistently

- NULL probe - replaced with "RPC NULL procedure"

- ULP - replaced with "RPC Program"

- Chunks - defined before use, and added citation

Please let me know if there are other unfamiliar terms I've
missed, or if there is a particular inconsistent usage that
should be corrected.

> -[Page 6], "(ie. a "---->"(i.e., a"

Fixed.

--
Chuck Lever

---

From: Meral Shirazipour <[email-masked]>
Date: Tue, 7 Feb 2017 21:31:36 +0000

Hi,
  Thank you.

Best,
Meral

> -----Original Message-----
> From: Chuck Lever [mailto:[email-masked]]
> Sent: Tuesday, February 07, 2017 12:26 PM
> To: Meral Shirazipour <[email-masked]>
> Cc: [email-masked]; [email-masked]
> Subject: Re: Gen-ART Last Call review of draft-ietf-nfsv4-rpcrdma-bidirection-06
> 
> 
> > I am the assigned Gen-ART reviewer for this draft. The General Area Review
> Team (Gen-ART) reviews all IETF documents being processed by the IESG for the
> IETF Chair.  Please treat these comments just like any other last call comments.
> > For more information, please see the FAQ at
> <http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>.
> >
> >
> To address this comment (and Jouni's related LC comment) I've introduced the
> following forward definitions:
> 
> Please let me know if there are other unfamiliar terms I've missed, or if there is a
> particular inconsistent usage that should be corrected.
> 
>