Subject: [Gen-art] Gen-ART Last Call review of draft-ietf-core-coap-tcp-tls-07

From: Meral Shirazipour <[email-masked]>
Date: Mon, 10 Apr 2017 06:45:37 +0000

I am the assigned Gen-ART reviewer for this draft. The General Area Review Team (Gen-ART) reviews all IETF documents being processed by the IESG for the IETF Chair.  Please treat these comments just like any other last call comments. For more information, please see the FAQ at <https://trac.ietf.org/trac/gen/wiki/GenArtfaq>.

Document: draft-ietf-core-coap-tcp-tls-07
Reviewer: Meral Shirazipour
Review Date: 2017-04-09
IETF LC End Date: 2017-04-09
IESG Telechat date: NA

Summary: This draft is ready to be published as Standards Track RFC but I saw some issues.
Major issues:

Minor issues:
-I am not a CoAP expert, but list comments from Mark Nottingham are of concern (to [core] Mon, 10 April 2017 04:07 UTC).

Nits/editorial comments:
-Please spell out acronyms at first use.
-Not sure if other documents address this, but does this document assume fixed CoAP devices as end point (not moving and connectivity is assumed 'the same' during the TCP session?)

Best Regards,
Meral
---
Meral Shirazipour
Ericsson
Research
www.ericsson.com

---

From: Brian Raymor <[email-masked]>
Date: Thu, 20 Apr 2017 18:14:35 +0000

Thanks for your feedback.

> -Please spell out acronyms at first use.

I will correct the BERT case and also review https://www.rfc-editor.org/materials/abbrev.expansion.txt for other potential cases.

Tracked in https://github.com/core-wg/coap-tcp-tls/issues/132

> -Not sure if other documents address this, but does this document assume fixed CoAP devices

> as end point (not > moving and connectivity is assumed 'the same' during the TCP session?)

It assumes fixed CoAP devices.

...Brian

---

From: Meral Shirazipour <[email-masked]>
Date: Thu, 20 Apr 2017 21:43:26 +0000

Hi,
  Thank you.

Best,
Meral

From: Brian Raymor [mailto:[email-masked]]
Sent: Thursday, April 20, 2017 11:15 AM
To: Meral Shirazipour <[email-masked]>; [email-masked]; [email-masked]
Subject: RE: Gen-ART Last Call review of draft-ietf-core-coap-tcp-tls-07

...Brian