Subject: [Gen-art] draft-ietf-v6ops-unique-ipv6-prefix-per-host

From: Ron Bonica <[email-masked]>
Date: Thu, 4 May 2017 19:57:28 +0000

Folks,

The following is status for draft-ietf-v6ops-unique-ipv6-prefix-per-host:

- WG last call complete
- OPSDIR, GENART and INTDIR reviews complete
- write-up complete

The following issue was raised in the GENART Review:

" The proposed status seems questionable.  We as a community are not recommending that operators assign unique prefixes to hosts.  This document is saying "if you want to do that, here is a way, using existing tools, to make that work."  The document also recommends specific setting of other flags (the O flag in the RA, for example) that are not closely coupled to the particular topic.  This looks like an ordinary Informational RFC.  I would have no concern with this being published with that label."

Could the authors please address this issues. As soon as they have done so, we can send it to the IESG for publication.

                                                                                      Ron

---

From: "Van De Velde, Gunter (Nokia - BE/Antwerp)" <[email-masked]>
Date: Fri, 5 May 2017 06:46:40 +0000

Hi Ron, Gen-art directorate,

I’m checking with John on the most optimal way forward. While I am not that keen on the BCP status of the document, it was part of a motivation to split up the original draft on the subject discussing community wifi networks from the address related aspects. John and I will have a discussion on the subject and propose a path to resolution of the issue mentioned by gen-art.

G/

On 04/05/2017, 21:57, "Ron Bonica" <[email-masked]> wrote:

    Folks,

    - WG last call complete

    
    
                                                                                          Ron

---

From: "Brzozowski, John" <[email-masked]>
Date: Fri, 5 May 2017 14:22:40 +0000

As Gunter mentions we intentionally split this work up to ensure the document could be used a BCP when deploying networks of this nature.  Our goal was (and is) NOT to recommend that a unique IPv6 prefix be assigned per host.  What we are saying is that if you choose to do this then the documented practice is one that has been verified as operationally sound and viable, in other words a best practice.  Further the documented approach while citing Wi-Fi can be used in many other deployment scenarios, as such it has broad applicability.

I would like to understand better what the concern is, specifically, about this document being a BCP.  Please site details about the document content.

John
+1-484-962-0060

-----Original Message-----
From: Gunter Van de Velde <[email-masked]>
Date: Friday, May 5, 2017 at 02:46
To: Ronald Bonica <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: draft-ietf-v6ops-unique-ipv6-prefix-per-host
Resent-From: <[email-masked]>
Resent-To: <[email-masked]>, Gunter Van de Velde <[email-masked]>, Ronald Bonica <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>, Ronald Bonica <[email-masked]>
Resent-Date: Friday, May 5, 2017 at 02:46

    
    G/

        Folks,

        - WG last call complete

        
        
                                                                                              Ron

---

From: Ron Bonica <[email-masked]>
Date: Fri, 5 May 2017 14:58:56 +0000

Gunter,

Thanks much. A brief chat with Joel may clear this up.

                               Ron

> From: Van De Velde, Gunter (Nokia - BE/Antwerp)
> [mailto:[email-masked]]
> Sent: Friday, May 5, 2017 2:47 AM
> To: Ron Bonica <[email-masked]>; draft-ietf-v6ops-unique-ipv6-prefix-
> [email-masked]; [email-masked]
> I’m checking with John on the most optimal way forward. While I am not that
> keen on the BCP status of the document, it was part of a motivation to split
> up the original draft on the subject discussing community wifi networks from
> the address related aspects. John and I will have a discussion on the subject
> and propose a path to resolution of the issue mentioned by gen-art.
> 
> G/
> 
>     " The proposed status seems questionable.  We as a community are not
> recommending that operators assign unique prefixes to hosts.  This
> document is saying "if you want to do that, here is a way, using existing tools,
> to make that work."  The document also recommends specific setting of
> other flags (the O flag in the RA, for example) that are not closely coupled to
> the particular topic.  This looks like an ordinary Informational RFC.  I would
> have no concern with this being published with that label."
> 
>     Could the authors please address this issues. As soon as they have done
> so, we can send it to the IESG for publication.
> 
>                                                                                           Ron
> 
>

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 6 May 2017 08:05:34 +1200

s/The Best Current Practice documented in this note is/The optional Best Current Practice documented in this note is/

Regards
   Brian

On 06/05/2017 02:58, Ron Bonica wrote:
> _______________________________________________
> Gen-art mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/gen-art
>

---

From: Ron Bonica <[email-masked]>
Date: Sun, 7 May 2017 00:36:20 +0000

Wfm

Joel, are you ok with this?

                      Ron

> From: Brian E Carpenter [mailto:[email-masked]]
> Sent: Friday, May 5, 2017 4:06 PM
> To: Ron Bonica <[email-masked]>; Van De Velde, Gunter (Nokia -
> BE/Antwerp) <[email-masked]>; draft-ietf-v6ops-unique-
> [email-masked]; [email-masked]
> Subject: Re: [Gen-art] draft-ietf-v6ops-unique-ipv6-prefix-per-host
> 
> s/The Best Current Practice documented in this note is/The optional Best
> Current Practice documented in this note is/
> 
> Regards
>    Brian
> 
> >> I’m checking with John on the most optimal way forward. While I am
> >> not that keen on the BCP status of the document, it was part of a
> >> motivation to split up the original draft on the subject discussing
> >> community wifi networks from the address related aspects. John and I
> >> will have a discussion on the subject and propose a path to resolution of
> the issue mentioned by gen-art.
> >>
> >> G/
> >>
> >>     " The proposed status seems questionable.  We as a community are
> >> not recommending that operators assign unique prefixes to hosts.
> >> This document is saying "if you want to do that, here is a way, using
> >> existing tools, to make that work."  The document also recommends
> >> specific setting of other flags (the O flag in the RA, for example)
> >> that are not closely coupled to the particular topic.  This looks
> >> like an ordinary Informational RFC.  I would have no concern with this
> being published with that label."
> >>
> >>     Could the authors please address this issues. As soon as they
> >> have done so, we can send it to the IESG for publication.
> >>
> >>
> >> Ron
> >>
> >>
> >

---

From: Ron Bonica <[email-masked]>
Date: Mon, 8 May 2017 14:28:29 +0000

Joel,

Are you OK with the change that Brian recommends, below? 

                                                      Ron

> From: Ron Bonica
> Sent: Saturday, May 6, 2017 8:36 PM
> To: 'Brian E Carpenter' <[email-masked]>; Van De Velde,
> Gunter (Nokia - BE/Antwerp) <[email-masked]>; draft-
> [email-masked]; [email-masked]
> Subject: RE: [Gen-art] draft-ietf-v6ops-unique-ipv6-prefix-per-host
> 
> Wfm
> 
> > s/The Best Current Practice documented in this note is/The optional
> > Best Current Practice documented in this note is/
> >
> > Regards
> >    Brian
> >
> > >> community wifi networks from the address related aspects. John and
> > >> I will have a discussion on the subject and propose a path to
> > >> resolution of
> > >>     " The proposed status seems questionable.  We as a community
> > >> are not recommending that operators assign unique prefixes to hosts.
> > >> This document is saying "if you want to do that, here is a way,
> > >> using existing tools, to make that work."  The document also
> > >> recommends specific setting of other flags (the O flag in the RA,
> > >> for example) that are not closely coupled to the particular topic.
> > >> This looks like an ordinary Informational RFC.  I would have no
> > >> concern with this

---

From: "Joel M. Halpern" <[email-masked]>
Date: Mon, 8 May 2017 10:57:27 -0400

I do not think Brian's proposal addresses the issue.
Either this is indeed a Best / Recommended Current Practice, or it isn't.
All RFCs are optional.  So saying that this is optional does not seem to 
help.

It seems very odd to defend the status on the basis that it was part of 
a compromise.
To me, the document still reads like a conventional informational RFC.
To make it a BCP, in my view, it would have to describe the context in 
which this was actually a recommended behavio.  I doubt we actually have 
agreement on that.
As far as I can tell, we do have agreement on this description of how to 
do this when you want to.  Which is what Informational RFCs are for.

In the end, this is up to the IESG.

Yours,
Joel

---

From: "Brzozowski, John" <[email-masked]>
Date: Tue, 9 May 2017 00:04:19 +0000

Joel,

Please send the criteria for BCP v Informational so we can all evaluate accordingly.

The document describes the *behavior* that is expected by UEs based on the network configuration.  This was deliberate, not accidental or assumed.  I am not sure there is anything to disagree about, data pertaining to device behavior is clear and well known.

John
+1-484-962-0060

-----Original Message-----
From: Joel Halpern <[email-masked]>
Date: Monday, May 8, 2017 at 10:57
To: Ronald Bonica <[email-masked]>, Brian Carpenter <[email-masked]>, Gunter Van de Velde <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [Gen-art] draft-ietf-v6ops-unique-ipv6-prefix-per-host
Resent-From: <[email-masked]>
Resent-To: <[email-masked]>, Gunter Van de Velde <[email-masked]>, Ronald Bonica <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>, Ronald Bonica <[email-masked]>
Resent-Date: Monday, May 8, 2017 at 10:57

    
    
    Yours,
    Joel

---

From: "Joel M. Halpern" <[email-masked]>
Date: Mon, 8 May 2017 20:31:07 -0400

John, I absolutely agree that this document describes behavior that is 
useful.  And it describes that behavior clearly.
One could, on that basis argue for PS status.
I think it better fits as informational.
I do not think it needs to be marked experimental.
I do think it should be published.

There are at least 3 definitions of BCP floating around out there.
One clearly does not apply (this is not documenting a widely practiced 
current usage as far as I know.)  I understand that BCPs are not 
restricted to that.
Another definition is a generally recommended behavior (even if folks do 
not actually do it, cf BCP 38). I do not think that definition applies 
to this document.
The third, and only enforced definition, is "what the IESG says is a 
BCP."  Not a very helpful definition, but it is the actual one in use.

Which is why I ended my note by saying that I leave it to the IESG.

Yours,
Joel

---

From: "Brzozowski, John" <[email-masked]>
Date: Tue, 9 May 2017 12:09:28 +0000

Thanks Joel.  We are OK letting the IESG decide, as such our request for BCP will remain for now.  If they decide Informational we will accept this as well.

John
+1-484-962-0060

-----Original Message-----
From: Joel Halpern <[email-masked]>
Date: Monday, May 8, 2017 at 20:31
To: John Brzozowski <[email-masked]>, Ronald Bonica <[email-masked]>, Brian Carpenter <[email-masked]>, Gunter Van de Velde <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [Gen-art] draft-ietf-v6ops-unique-ipv6-prefix-per-host

    
    
    Yours,
    Joel

---

From: Ron Bonica <[email-masked]>
Date: Tue, 9 May 2017 15:17:40 +0000

Joel,

I think that you have hit the nail on the head. There is no clearly documented definition of BCP. In reality, the only enforced definition is that "a BCP is whatever the sitting IESG says is a BCP".

So, rather than arguing the point, why don't we just ask the IESG?

I will update the shepherds write-up noting that there was a question about whether this document should be BCP or INFO and send the document on to the IESG. We will defer to their judgement regarding the label.

                                                Ron

> From: Joel M. Halpern [mailto:[email-masked]]
> Sent: Monday, May 8, 2017 8:31 PM
> To: Brzozowski, John <[email-masked]>; Ron Bonica
> <[email-masked]>; Brian E Carpenter <[email-masked]>;
> Van De Velde, Gunter (Nokia - BE/Antwerp)
> <[email-masked]>; draft-ietf-v6ops-unique-ipv6-prefix-
> John, I absolutely agree that this document describes behavior that is useful.
> And it describes that behavior clearly.
> current usage as far as I know.)  I understand that BCPs are not restricted to
> that.
> Another definition is a generally recommended behavior (even if folks do not
> actually do it, cf BCP 38). I do not think that definition applies to this
> document.
> The third, and only enforced definition, is "what the IESG says is a BCP."  Not
> a very helpful definition, but it is the actual one in use.
> 
> > The document describes the *behavior* that is expected by UEs based on
> the network configuration.  This was deliberate, not accidental or assumed.  I
> am not sure there is anything to disagree about, data pertaining to device
> behavior is clear and well known.
> >
> > John
> > +1-484-962-0060
> >
> > To: Ronald Bonica <[email-masked]>, Brian Carpenter
> > <[email-masked]>, Gunter Van de Velde
> > <[email-masked]>,
> > "[email-masked]"
> > <[email-masked]>,
> > "[email-masked]" <[email-masked]>
> > Resent-To: <[email-masked]>, Gunter Van de Velde
> > <[email-masked]>, Ronald Bonica
> <[email-masked]>,
> > <[email-masked]>, <[email-masked]>, <[email-masked]>,
> > <[email-masked]>, Ronald Bonica <[email-masked]>
> >     >>>>>     The following is status for draft-ietf-v6ops-unique-ipv6-prefix-
> per-
> >     >> host:
> >     >>>>>
> >     >>>>>     - WG last call complete

---

From: "Joel M. Halpern" <[email-masked]>
Date: Tue, 9 May 2017 11:26:21 -0400

Works for me as a path forward.
Yours,
Joel

---

From: "Brzozowski, John" <[email-masked]>
Date: Tue, 9 May 2017 15:26:59 +0000

The following needs to be addressed:

"a BCP is whatever the sitting IESG says is a BCP"

IMO this is subjective and does not yield a consistent experience across IESG cohorts.  For the IETF and work under the same there must be ONE definition of BCP that can be applied uniformly and consistently over time.

John
+1-484-962-0060

-----Original Message-----
From: Ronald Bonica <[email-masked]>
Date: Tuesday, May 9, 2017 at 11:17
To: Joel Halpern <[email-masked]>, John Brzozowski <[email-masked]>, Brian Carpenter <[email-masked]>, Gunter Van de Velde <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: RE: [Gen-art] draft-ietf-v6ops-unique-ipv6-prefix-per-host

    Joel,

    
    
                                                    Ron

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 10 May 2017 11:17:42 +1200

> IMO this is subjective and does not yield a consistent experience across IESG cohorts.  For the IETF and work under the same there must be ONE definition of BCP that can be applied uniformly and co…

There is:
https://tools.ietf.org/html/rfc2026#section-5

I don't see the problem with "best current thinking
on a statement of principle or on what is believed to be the best way
to perform some operations or IETF process function".

Obviously the words "best" and "believed" imply a judgment
call, first by the community and then by the IESG.

  Brian