Subject: [Gen-art] review of draft-ietf-teas-gmpls-lsp-fastreroute-09.txt

From: Francis Dupont <[email-masked]>
Date: Sat, 08 Jul 2017 11:01:28 +0200

I am the assigned Gen-ART reviewer for this draft. The General Area
Review Team (Gen-ART) reviews all IETF documents being processed
by the IESG for the IETF Chair.  Please treat these comments just
like any other last call comments.

For more information, please see the FAQ at

<https://trac.ietf.org/trac/gen/wiki/GenArtfaq>.

Document: draft-ietf-teas-gmpls-lsp-fastreroute-09.txt
Reviewer: Francis Dupont
Review Date: 20170706
IETF LC End Date: 20170707
IESG Telechat date: unknown

Summary: Ready

Major issues: None

Minor issues: None

Nits/editorial comments: 
 - ToC page 3 and Acknowledgments page 21:
   Acknowledgements -> AcknowledgDements

 - 1 page 4: you should introduce the LSP abbrev too (BTW if GMPLS
  is a well known abbrev cf
  https://www.rfc-editor.org/materials/abbrev.expansion.txt
  LSP is not, IMHO because this abbrev has some other meanings in
  the IETF scope)

 - 4.5.1 page 9: The Node-ID address must match the source -> MUST
  or has to

 - 4.5.1 page 9: may -> can (RFC 2119 did not clearly specify that
  keywords are only in uppercase. Note only the previous item is
  really ambiguous).

 - 5.1 page 11 and 5.2.2 page 14: e.g. -> e.g.,

 - 5.3 page 15 and 6 page 16: may -> can

 - 11.1 page 20 RFC3473: should be ReserVation -> ReSerVation
  but the bug is in the RFC 3473 title please don't fix...

 - Contributors page 21:
  * Orange CH is ambiguous: there are some cities named Orange,
   for instance a medium one in France. I suggest to put the CH
   on the next line
  * China -> PR China or CN (i.e., follow UPU or IETF specs)

Thanks

[email-masked]

---

From: "Rakesh Gandhi (rgandhi)" <[email-masked]>
Date: Tue, 11 Jul 2017 15:29:00 +0000

Thank you Francis for the review and your comments.

Please find attached diff file with the suggested changes.

I could not understand your following comment. Are you suggesting to remove last “e” from “Acklowledge” ?

Thanks,
Rakesh

On 2017-07-08, 5:01 AM, "Francis Dupont" <[email-masked]> wrote:

    

    Summary: Ready
    
    Major issues: None
    
    Minor issues: None
    
    Nits/editorial comments: 

    

    
    
     - Contributors page 21:
    
    Thanks

---

From: "Mirja Kuehlewind (IETF)" <[email-masked]>
Date: Mon, 31 Jul 2017 15:29:30 +0200

Thanks for the review!

> Am 08.07.2017 um 11:01 schrieb Francis Dupont <[email-masked]>:
> 
> _______________________________________________
> Gen-art mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/gen-art

---

From: "Mirja Kuehlewind (IETF)" <[email-masked]>
Date: Mon, 31 Jul 2017 15:31:20 +0200

One comment: there is an update to rfc2119 to clarify the use of not upper cases musts and should aso. published since May -> see rfc8174

> Am 31.07.2017 um 15:29 schrieb Mirja Kuehlewind (IETF) <[email-masked]>:
> 
> Thanks for the review!
>