Subject: [Gen-art] Genart last call review of draft-ietf-nvo3-mcast-framework-09

From: Christer Holmberg <[email-masked]>
Date: Wed, 04 Oct 2017 11:45:12 -0700

Reviewer: Christer Holmberg
Review result: Ready with Nits

I am the assigned Gen-ART reviewer for this draft. The General Area
Review Team (Gen-ART) reviews all IETF documents being processed
by the IESG for the IETF Chair.  Please treat these comments just
like any other last call comments.

For more information, please see the FAQ at

<https://trac.ietf.org/trac/gen/wiki/GenArtfaq>.

Document: draft-ietf-nvo3-mcast-framework-09
Reviewer: Christer Holmberg
Review Date: 2017-10-04
IETF LC End Date: 2017-10-02
IESG Telechat date: 2017-10-12

Summary: The document is almost ready for publication, but there are a few
issues that I'd like the authors to address.

Major issues: N/A

Minor issues:

Q1:
The Introduction says that the document "provides a framework". I guess it
depends on how you define "framework", but to me it seems like the document
only evaluates and discusses different mechanisms - which the text also says.

Nits/editorial comments:

Q2:
The Abstract says: "This document discusses a framework of supporting..."

Assuming the document actually does provide a framework (see Q1), I would
suggest to say "provides" (which you also use in the Introduction) instead of
"discusses".

Q3:
The Introduction says: "Network virtualization using Overlays over Layer 3
(NVO3) is a Technology... "

Please add a reference to RFC 7365 and/or RFC 8014 on the first occurrence of
NVO3.

Q4:
I don't think the last paragraph of the Introdution (Section 1) belongs to the
Introduction. It should be in a terminology section. In addition, I don't think
you need to say that "the user is assumed to be familiar with...". You should
simply reference the RFCs for the terminology used in the document.

---

From: Linda Dunbar <[email-masked]>
Date: Thu, 5 Oct 2017 22:09:12 +0000

Christer,

Thank you very much for reviewing the draft and provided the comments. Please see below the reply to your questions.

-----Original Message-----
From: Christer Holmberg [mailto:[email-masked]]
Sent: Wednesday, October 04, 2017 1:45 PM
To: [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Genart last call review of draft-ietf-nvo3-mcast-framework-09

I am the assigned Gen-ART reviewer for this draft. The General Area Review Team (Gen-ART) reviews all IETF documents being processed by the IESG for the IETF Chair.  Please treat these comments just like any other last call comments.

Summary: The document is almost ready for publication, but there are a few issues that I'd like the authors to address.

Major issues: N/A

Minor issues:

Q1:
The Introduction says that the document "provides a framework". I guess it depends on how you define "framework", but to me it seems like the document only evaluates and discusses different mechanisms - which the text also says.
[Linda] you are correct. The word *framework* is chosen (by WG) because the draft describes the “framework” of how to handing various multicast traffic.

Nits/editorial comments:

Q2:

Assuming the document actually does provide a framework (see Q1), I would suggest to say "provides" (which you also use in the Introduction) instead of "discusses".
[Linda] Okay, changed.

Q3:

Please add a reference to RFC 7365 and/or RFC 8014 on the first occurrence of NVO3.
[Linda] added.

Q4:
I don't think the last paragraph of the Introdution (Section 1) belongs to the Introduction. It should be in a terminology section. In addition, I don't think you need to say that "the user is assumed to be familiar with...". You should simply reference the RFCs for the terminology used in the document.
[Linda] Okay, changed.

Thank you very much.

Linda Dunbar

---

From: Alissa Cooper <[email-masked]>
Date: Thu, 12 Oct 2017 09:15:12 -0400

Christer, thanks for your review. Linda, thanks for your response. I have entered a No Objection ballot.

Alissa

> On Oct 4, 2017, at 2:45 PM, Christer Holmberg <[email-masked]> wrote:
> 
> _______________________________________________
> Gen-art mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/gen-art