Subject: [Gen-art] Gen-ART Last Call review of draft-ietf-tcpinc-tcpeno-10

From: Meral Shirazipour <[email-masked]>
Date: Tue, 17 Oct 2017 01:20:53 +0000

I am the assigned Gen-ART reviewer for this draft. The General Area Review Team (Gen-ART) reviews all IETF documents being processed by the IESG for the IETF Chair.  Please treat these comments just like any other last call comments.
For more information, please see the FAQ at <http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>.

Document: draft-ietf-tcpinc-tcpeno-10
Reviewer: Meral Shirazipour
Review Date: 2017-10-16
IETF LC End Date:   2017-10-19
IESG Telechat date: 2017-10-26

Summary:
This draft is ready to be published as Experimental RFC but I have some comments.

Major issues:

Minor issues:
The discussions around misbehaving middleboxes was good but more examples would have been better:
Would it make sense to add some examples of well-behaved TCP-proxy middleboxes (TCP terminating proxies)? What is allowed for example? E.g. can the TEP on each side of the proxy be different?
Security section could also be enhanced in that regard.

Nits/editorial comments:
[Page 7] , "TEP identifer"---->"TEP identifier"
[Page 16] , "Futhermore,"-----"Furthermore,"
[Page 19], "unlikely to to"---->"unlikely to"
General, some acronyms not spelled at first use

Best Regards,
Meral
---
Meral Shirazipour
Ericsson Research
www.ericsson.com

---

From: Meral Shirazipour <[email-masked]>
Date: Tue, 17 Oct 2017 01:25:28 +0000

Trying again-got a bounce back from the draft's email list.

Best Regards,
Meral
---
Meral Shirazipour
Ericsson Research
www.ericsson.com<http://www.ericsson.com>

From: Gen-art [mailto:[email-masked]] On Behalf Of Meral Shirazipour
Sent: Monday, October 16, 2017 6:21 PM
To: [email-masked]; [email-masked]
Subject: [Gen-art] Gen-ART Last Call review of draft-ietf-tcpinc-tcpeno-10

Summary:

Major issues:

Minor issues:

Nits/editorial comments:

Best Regards,
Meral
---
Meral Shirazipour
Ericsson Research
www.ericsson.com<http://www.ericsson.com>

---

From: Meral Shirazipour <[email-masked]>
Date: Tue, 17 Oct 2017 01:29:58 +0000

Last try, I promise.

Best Regards,
Meral
---
Meral Shirazipour
Ericsson Research

From: Gen-art [mailto:[email-masked]] On Behalf Of Meral Shirazipour
Sent: Monday, October 16, 2017 6:25 PM
To: [email-masked]; [email-masked]
Cc: [email-masked]
Subject: Re: [Gen-art] Gen-ART Last Call review of draft-ietf-tcpinc-tcpeno-10

Best Regards,
Meral
---
Meral Shirazipour
Ericsson Research

From: Gen-art [mailto:[email-masked]] On Behalf Of Meral Shirazipour
Sent: Monday, October 16, 2017 6:21 PM
To: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: [Gen-art] Gen-ART Last Call review of draft-ietf-tcpinc-tcpeno-10

Summary:

Major issues:

Minor issues:

Nits/editorial comments:

Best Regards,
Meral
---
Meral Shirazipour
Ericsson Research