Subject: [Gen-art] Genart last call review of draft-ietf-xrblock-rtcweb-rtcp-xr-metrics-08

From: Robert Sparks <[email-masked]>
Date: Mon, 19 Feb 2018 10:47:31 -0800

Reviewer: Robert Sparks
Review result: Ready with Nits

I am the assigned Gen-ART reviewer for this draft. The General Area
Review Team (Gen-ART) reviews all IETF documents being processed
by the IESG for the IETF Chair.  Please treat these comments just
like any other last call comments.

For more information, please see the FAQ at

<https://trac.ietf.org/trac/gen/wiki/GenArtfaq>.

Document: draft-ietf-xrblock-rtcweb-rtcp-xr-metrics-08
Reviewer: Robert Sparks
Review Date: 2018-02-19
IETF LC End Date: 2018-02-23
IESG Telechat date: Not scheduled for a telechat

Summary: Ready for publication as an Informational RFC, but with nits to
consider before publication

The document argues to include things in the W3C statistics API in the last
paragraph of 5.2.2. Section 7 seems to say those have been included already. It
would be good to rework both of these mentions to reflect what's true at the
time of the publication of the RFC, in a way that the text will make sense when
read years from now.

---

From: "Huangyihong (Rachel)" <[email-masked]>
Date: Mon, 26 Feb 2018 07:08:29 +0000

Hi Robert, 

Thanks for the comment.

I propose to change the last paragraph of 5.2.2 from

"
The following metrics can also be considered for WebRTC's Statistics
   API: number of discarded key frames, number of lost key frames,
   number of discarded derived frames, number of lost derived frames.
   These metrics can be used to calculate Media Loss Rate (MLR) of MDI.
   Details of the definition of these metrics are described in
   [RFC7003].  Additionally, the metric provides the rendered frame
   rate, an important parameter for quality estimation.
"

To

"
The metrics in this category includes
: number of discarded key frames, number of lost key frames,
   number of discarded derived frames, number of lost derived frames.
   These metrics can be used to calculate Media Loss Rate (MLR) of MDI.
   Details of the definition of these metrics are described in
   [RFC7003].  Additionally, the metric provides the rendered frame
   rate, an important parameter for quality estimation.
"

This change is to just talk about the metrics itself, so as to avoid any confusion that readers may have. The fact is that the W3C has already included the metrics, and made an informational reference to this document.

If the proposal looks good to you, we'll reflect it in the new version.

BR,
Rachel

> -----Original Message-----
> From: Robert Sparks [mailto:[email-masked]]
> Sent: Tuesday, February 20, 2018 2:48 AM
> To: [email-masked]
> Cc: [email-masked]; [email-masked];
> [email-masked]
> Subject: Genart last call review of draft-ietf-xrblock-rtcweb-rtcp-xr-metrics-08
> 
> Reviewer: Robert Sparks
> I am the assigned Gen-ART reviewer for this draft. The General Area Review
> Team (Gen-ART) reviews all IETF documents being processed by the IESG for
> the IETF Chair.  Please treat these comments just like any other last call
> comments.
>