Subject: Re: [Gen-art] [6tisch] Genart telechat review of draft-ietf-6tisch-6top-protocol-09

From: Brian E Carpenter <[email-masked]>
Date: Tue, 6 Mar 2018 14:21:55 +1300

Hi,
On 27/02/2018 05:31, Qin Wang wrote:
...
> [Qin] Add following textin both section 3.1.1 and 3.1.2
> In case a race conditionhappens during the communication, the TSCH schedule of node A may becomeinconsistent with the TSCH schedule of node B. 6top handles the schedule inconsistency in the way described in Section3.4.6.2

I don't think that made it into the -10 version.

    Brian

---

From: Qin Wang <[email-masked]>
Date: Tue, 6 Mar 2018 16:12:19 +0000 (UTC)

Hi Brian,
Section 3.4.6.2 describes the method to deal with schedule inconsistency, which could happen in various conditions, including the race condition you mentioned. The sentence added in 3.1.1 and 3.1.2 looks redundant in that sense. Thus, we remove them at the last minute. Sorry for not notifying you in advance, and thank you for your review again.
ThanksQin 

    On Monday, March 5, 2018 8:21 PM, Brian E Carpenter <[email-masked]> wrote:

 Hi,

    Brian