Subject: [Gen-art] Genart last call review of draft-ietf-dnsop-terminology-bis-11

From: Roni Even <[email-masked]>
Date: Wed, 08 Aug 2018 05:40:51 -0700

Reviewer: Roni Even
Review result: Ready with Nits

I am the assigned Gen-ART reviewer for this draft. The General Area
Review Team (Gen-ART) reviews all IETF documents being processed
by the IESG for the IETF Chair.  Please treat these comments just
like any other last call comments.

For more information, please see the FAQ at

<https://trac.ietf.org/trac/gen/wiki/GenArtfaq>.

Document: draft-ietf-dnsop-terminology-bis-??
Reviewer: Roni Even
Review Date: 2018-08-08
IETF LC End Date: 2018-08-13
IESG Telechat date: Not scheduled for a telechat

Summary: The document is ready for publication as a BCP with nits

Major issues:

Minor issues:

Nits/editorial comments:

1.  In section 2 the term DNAME is mentioned and while CNAME is specified DNAME
is not (maybe reference RFC6672?)

2. In section 5 "Most resorece record " typo.

3. This is more a comment and since I did not follow the progress of the
document I am not sure the motivation here. Reading the text I noticed that in
the definition of referrals in section 4 the text include also what looks to me
like logic starting from the third paragraph. I was wondering why is it here
and not in one of the standard track documents and referenced here. I saw that
this is a big change from RFC7719.

---

From: Paul Hoffman <[email-masked]>
Date: Wed, 8 Aug 2018 14:57:09 +0000

> is not (maybe reference RFC6672?)

We have been trying to use this document to define terms. In the case of DNAME, it doesn't appear to actually mean anything (at least, I couldn't find an RFC that said what the D was for). I suspect it was the early DNS folks being cute, something along the lines of "D is bigger than C". Having said that, we will add a reference without adding an explanation.

> 2. In section 5 "Most resorece record " typo.

Thanks!

> this is a big change from RFC7719.

Yes, that all came from the extensive WG discussion. You are correct that there is not an RFC that says "here are the kinds of referrals and what they mean", but there was a strong desire that we define "referrals" because that term is used in many other documents in many contexts. Someone could (maybe SHOULD) write a "DNS referrals" RFC, and the terminology-ter document (if such a thing comes into existence) could rip out this section and refer to it.

The main thing here is that this document doesn't change an existing definition of "referrals". We just kinda realized that we had to get it written down the first time.

--Paul Hoffman

---

From: "Roni Even (A)" <[email-masked]>
Date: Thu, 9 Aug 2018 05:04:09 +0000

Hi Paul,
I am OK with your response
Thanks
Roni

-----Original Message-----
From: Gen-art [mailto:[email-masked]] On Behalf Of Paul Hoffman
Sent: Wednesday, August 08, 2018 5:57 PM
To: Roni Even
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: Re: [Gen-art] [Ext] Genart last call review of draft-ietf-dnsop-terminology-bis-11

On Aug 8, 2018, at 5:40 AM, Roni Even <[email-masked]> wrote:
> 1.  In section 2 the term DNAME is mentioned and while CNAME is 
> specified DNAME is not (maybe reference RFC6672?)

Thanks!

> 3. This is more a comment and since I did not follow the progress of 
> the document I am not sure the motivation here. Reading the text I 
> noticed that in the definition of referrals in section 4 the text 
> include also what looks to me like logic starting from the third 
> paragraph. I was wondering why is it here and not in one of the 
> standard track documents and referenced here. I saw that this is a big change from RFC7719.

--Paul Hoffman
_______________________________________________
Gen-art mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/gen-art