Subject: [Gen-art] (full) review of draft-ietf-lisp-rfc6830bis

From: Francis Dupont <[email-masked]>
Date: Mon, 17 Sep 2018 18:24:39 +0200

This completes the review I sent last week.

I am the assigned Gen-ART reviewer for this draft. The General Area
Review Team (Gen-ART) reviews all IETF documents being processed
by the IESG for the IETF Chair. Please wait for direction from your
document shepherd or AD before posting a new version of the draft.

For more information, please see the FAQ at

<https://trac.ietf.org/trac/gen/wiki/GenArtfaq>.

Document: draft-ietf-lisp-rfc6830bis-17.txt
Reviewer: Francis Dupont
Review Date: 20180911
IESG Telechat date: 20180927

Summary: Ready with Nits

Major issues: None

Minor issues: None

Nits/editorial comments:
 - 3 pages 4-8: some abbrevs are used before being defined *. I don't know
  a good way to fix this and anyway there are only a few  specific terms
  so IMHO it is not a real problem.
  * e.g. ETR is used the entry before its definition.

 - 5.1 page 16: the I bit text is not very clear IMHO both because
  the Instance ID is not defined before section 8 and because L and I
  bits interfere. As the problem comes from RFC 6830 I propose to keep
  the current text.

 - 10.1 pages 26 and 27: the order between nonce word and derivations
  from echo is not very consistent. If you have another reason to revisit
  the section please fix this very minor issue.

 - B.3 page 40: implementators -> implementors

 - 8.12 page 42: addreses -> addresses

 - B.13 page 43: Reencapsulating -> Re-encapsulating
  (BTW these spelling errors are in text which should be dropped :-)

 - as it is a RFC revision perhaps it should be fine to add some words
  about real world deployments of LISP?

Regards

[email-masked]

---

From: Dino Farinacci <[email-masked]>
Date: Mon, 17 Sep 2018 10:26:44 -0700

> IESG Telechat date: 20180927

Thanks for your review Francis. A new diff file for 6830bis in enclosed at the end.

>  * e.g. ETR is used the entry before its definition.

This was brought up in the RFC6830 review back in 2012. And it was decided by everyone involved at the time to not change anything.

>  bits interfere. As the problem comes from RFC 6830 I propose to keep

Kept.

> - 8.12 page 42: addreses -> addresses

Both occurrences fixed.

>  (BTW these spelling errors are in text which should be dropped :-)

Right, fixed anyways.

>  about real world deployments of LISP?

We have an entire deployment draft about this. And we had deployment information in RFC6830 and during the IESG rewview, it was asked to be removed.

Dino

---

From: Alissa Cooper <[email-masked]>
Date: Thu, 27 Sep 2018 06:15:18 -0700

Francis, thanks for your review. Dino, thanks for your responses. I have entered a No Objection ballot.

Alissa

> On Sep 17, 2018, at 10:26 AM, Dino Farinacci <[email-masked]> wrote:
> 
>> [email-masked] <mailto:[email-masked]>
> 
> <rfcdiff-6830bis.html>
> 
> _______________________________________________
> Gen-art mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/gen-art <https://www.ietf.org/mailman/listinfo/gen-art>