Subject: Re: [Gen-art] Genart last call review of draft-ietf-sipcore-sip-push-21 - The pull request

From: Christer Holmberg <[email-masked]>
Date: Fri, 21 Dec 2018 08:50:58 +0000

Hi,

Based on the gen-art comments from Stewart, I have created a pull request for the suggested changes.

https://github.com/cdh4u/draft-sip-push/pull/31

Regards,

Christer

From: Christer Holmberg <[email-masked]>
Date: Thursday, 20 December 2018 at 17.37
To: Stewart Bryant <[email-masked]>, "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [Gen-art] Genart last call review of draft-ietf-sipcore-sip-push-21
Resent-From: <[email-masked]>
Resent-To: Christer Holmberg <[email-masked]>, <[email-masked]>, "A. Mahoney" <[email-masked]>, Brian Rosen <[email-masked]>, Ben Campbell <[email-masked]>, "[email-masked]" <[email-masked]>, <[email-masked]>, Brian Rosen <[email-masked]>
Resent-Date: Thursday, 20 December 2018 at 17.37

Hi Stewart,

Thank You for the review! Please see inline.

>Summary: A well written document with some minor points that could use a little
>attention.
>
>Major issues: None
>
>Minor issues:
>
>In Figure 1 the following is included:
>
>     REGISTER sip:[email-masked] SIP/2.0
>     Via: SIP/2.0/TCP alicemobile.example.com:5060;branch=z9hG4bKnashds7
>     Max-Forwards: 70
>     To: Alice <sip:[email-masked]>
>     From: Alice <sip:[email-masked]>;tag=456248
>     Call-ID: 843817637684230@998sdasdh09
>     CSeq: 1826 REGISTER
>     Contact: <sip:[email-masked];
>       pn-provider=acme;
>       pn-param=acme-param;
>       pn-prid=ZTY4ZDJlMzODE1NmUgKi0K>
>     Expires: 7200
>     Content-Length: 0
>
> SB> However I don't at this stage of the text see the relationship between the
> SB> packet flow digram and the text that follows.

I could add the following:

“Below is an example of a SIP REGISTER request in Figure 1.”

=========

>   Contact: IESG ([email-masked]<mailto:[email-masked]>)
>
> SB> Is the whole IESG the most appropriate first point of contact?

That is what I was told :)

Note that I have used it also for other documents.

=========

>Nits/editorial comments:
>Presumably the references to RFC XXXX will be replaced by RFC <this RFC> but
>that does not seem to be noted in the text

I will add a note to the RFC editor about that.

        “[RFC EDITOR NOTE: Please replace RFCXXXX with the RFC number of this document.]”

========

> SB> As dicussed in [RFC4320] and [RFC4321], non-INVITE transactions must
> SB> Typo s/dicussed/discussed/

I will fix as suggested.

========

>   Example: pn-prid = 00fc13adff78512
>
>   For more information about the APNs Topic and device token:
>
> SB> Is the following part of the example? If so it could usefully be delimited
> SB> as such, otherwise, I don't understand why it is not a normal document
> SB> reference.
>
>   https://developer.apple.com/library/archive/documentation/NetworkingI
>   nternet/Conceptual/RemoteNotificationsPG/CommunicatingwithAPNs.html
>
> SB> Similarly in the following section

The link reference is not part of the example. Perhaps I could place to reference before the examples, to make that more clear?

Are you suggesting that I add the link to the reference section, similar to document references?

=========

Regards,

Christer

---

From: Ben Campbell <[email-masked]>
Date: Fri, 21 Dec 2018 17:43:43 -0600

This looks good to me. Please submit a new revision when you are ready.

Since these changes look minor and not likely to be controversial, I am going to go ahead and create a ballot for this. It will likely end up on the 10 January telechat.

Thanks!

Ben.

> On Dec 21, 2018, at 2:50 AM, Christer Holmberg <[email-masked]> wrote:
> 
> Hi,
> 
> https://github.com/cdh4u/draft-sip-push/pull/31 <https://github.com/cdh4u/draft-sip-push/pull/31>
> 
> Regards,
> 
> Christer
> 
> From: Christer Holmberg <[email-masked] <mailto:[email-masked]>>
> To: Stewart Bryant <[email-masked] <mailto:[email-masked]>>, "[email-masked] <mailto:[email-masked]>" <[email-masked] <mailto:[email-masked]>>
> Cc: "[email-masked] <mailto:[email-masked]>" <[email-masked] <mailto:[email-masked]>>, "[email-masked] <mailto:[email-masked]>" <[email-masked] <mailto:[email-masked]>>, "[email-masked] <mailto:[email-masked]>" <[email-masked] <mailto:[email-masked]>>
> Resent-From: <[email-masked] <mailto:[email-masked]>>
> Resent-To: Christer Holmberg <[email-masked] <mailto:[email-masked]>>, <[email-masked] <mailto:[email-masked]>>, "A. Mahoney" <[email-masked] <mailto:[email-masked]>>, Brian Rosen <[email-masked] <mailto:[email-masked]>>, Ben Campbell <[email-masked] <mailto:[email-masked]>>, "[email-masked] <mailto:[email-masked]>" <[email-masked] <mailto:[email-masked]>>, <[email-masked] <mailto:[email-masked]>>, Brian Rosen <[email-masked] <mailto:[email-masked]>>
> >     REGISTER sip:[email-masked] <sip:[email-masked]> SIP/2.0
> >     Via: SIP/2.0/TCP alicemobile.example.com:5060 <http://alicemobile.example.com:5060/>;branch=z9hG4bKnashds7
> >     Max-Forwards: 70
> >     To: Alice <sip:[email-masked] <sip:[email-masked]>>
> >     From: Alice <sip:[email-masked] <sip:[email-masked]>>;tag=456248
> >     Contact: <sip:[email-masked] <sip:[email-masked]>;
> >       pn-provider=acme;
> >       pn-param=acme-param;
> >   Contact: IESG ([email-masked] <mailto:[email-masked]>)
> >
> >   https://developer.apple.com/library/archive/documentation/NetworkingI <https://developer.apple.com/library/archive/documentation/NetworkingI>