Subject: Re: [Gen-art] Genart last call review of draft-op3ft-leaptofrogans-uri-scheme-03

From: Alissa Cooper <[email-masked]>
Date: Wed, 6 Feb 2019 16:51:39 -0500

Erik, thanks for your review. I entered a DISCUSS position to ask an IPR question and pointed to your review.

Alissa

> On Nov 13, 2018, at 11:53 PM, Erik Kline <[email-masked]> wrote:
> 
> On Tue, 13 Nov 2018 at 20:23, Dale R. Worley <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> Erik Kline <ek=[email-masked]> writes:
>>> Nits/editorial comments: I can't help but wonder if an example or two wouldn't
>>> round out the document.  But maybe leaptofrogans: URIs/IRIs aren't amenable to
>>> constructing an example?
>> 
>> I agree in principle with this.  Looking at reference [IFAP], here are
>> two examples:
>> 
>>    leaptofrogans:mynetwork*mysite
>>    leaptofrogans:my-network*MySite
>> 
>> The syntax of frogan addresses is very carefully specified, but most of
>> the work seems to revolve around using Unicode well:  Frogans are fully
>> internationalized, so there's a lot of work in [IFAP] specifying how to
>> use Unicode so that an address aligns with the intuitive sense of "a
>> text string".
>> 
>> But beyond the fact that a frogan address is split into two parts by a
>> "*" character, there isn't much syntax that's easily displayed by a
>> series of ASCII examples.
> 
> I understand about the limitations of the current RFC format w.r.t.
> non-ASCII characters (but I suspect you wouldn't want to wait for the
> new format to be readily available :-).
> 
> FWIW I think those two examples would be perfectly fine.  They may not
> seem overly expressive or especially illustrative, but including them
> might scratch an itch for some readers.
> 
> But it's certainly not anything worth holding up publication for, IMHO.
> 
> _______________________________________________
> Gen-art mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/gen-art <https://www.ietf.org/mailman/listinfo/gen-art>

---

From: Benjamin PHISTER <[email-masked]>
Date: Thu, 7 Feb 2019 11:40:14 +0100

Hi Alissa, Hi Erik,

Sorry that we didn't respond directly to your comment, Erik.

Following your suggestion and after a brief discussion with Alexey and 
Peter, we added examples to the I-D starting with version -04, at the 
end of section 4.1, as follows:

>     Examples of 'leaptofrogans' URIs:
>
>     -  if the Frogans address is the string of US-ASCII characters
>        "Network-Name*Site-Name":
>
>          leaptofrogans:Network-Name*Site-Name
>
>     -  if the Frogans address is the string of Unicode characters U+7F51,
>        U+7EDC, U+540D, U+002A, U+7AD9, U+540D (which is a Chinese
>        translation of the Frogans address in the previous example):
>
>          leaptofrogans:%E7%BD%91%E7%BB%9C%E5%90%8D*%E7%AB%99%E5%90%8D

Thanks again for your input!

Alissa, we will respond to the IPR questions you raised and to Brad's 
comments within a couple of hours.

Best regards,

Ben and Alexis

------------------------------------------------------------------------
*From:* Alissa Cooper <[email-masked]>
*Subject:* [Gen-art] Genart last call review of 
draft-op3ft-leaptofrogans-uri-scheme-03
*Date:* Wednesday, Feb 6, 2019 10:51 PM CET
*To:* [email-masked]
*Cc:* Dale Worley <[email-masked]>, IETF Gen-ART <[email-masked]>, 
Erik Kline <ek=[email-masked]>, 
[email-masked]

>> On Nov 13, 2018, at 11:53 PM, Erik Kline <[email-masked] 
>> <mailto:[email-masked]>> wrote:
>>
>> On Tue, 13 Nov 2018 at 20:23, Dale R. Worley <[email-masked] 
>> <mailto:[email-masked]>wrote:
>>>
>>> Erik Kline <ek=[email-masked] 
>>> <mailto:ek=[email-masked]>> writes:
>> https://www.ietf.org/mailman/listinfo/gen-art
>

-- 
Benjamin Phister
Head of Technical Specifications
[email-masked]

OP3FT
6 square Mozart
75016 Paris - France
Tel: +33 1 5392 0040
https://www.op3ft.org/
frogans*op3ft