Subject: [Gen-art] Genart telechat review of draft-ietf-dots-requirements-18

From: Robert Sparks <[email-masked]>
Date: Wed, 13 Feb 2019 07:16:54 -0800

Reviewer: Robert Sparks
Review result: Ready with Issues

I am the assigned Gen-ART reviewer for this draft. The General Area
Review Team (Gen-ART) reviews all IETF documents being processed
by the IESG for the IETF Chair. Please wait for direction from your
document shepherd or AD before posting a new version of the draft.

For more information, please see the FAQ at

<https://trac.ietf.org/trac/gen/wiki/GenArtfaq>.

Document: draft-ietf-dots-requirements-18
Reviewer: Robert Sparks
Review Date: 2019-02-13
IETF LC End Date: 2018-11-23
IESG Telechat date: 2019-02-21

Summary: Ready, but with a process issue for the shepherd and AD to consider.

This version addressed all of my comments on version -16. Thank you.

However, the diff shows that a large number of SHOULDs were changed to MUSTs.
I'm guessing that was in response to a comment in the TSVART review of -16.
This large scale substitution makes me worry - are they really the right
adjustments? Has the group reviewed and agreed to these normative changes?

As a nit, I'll note that the additional description of heartbeating creeps into
specifying protocol rather than requirements.

---

From: "Konda, Tirumaleswar Reddy" <[email-masked]>
Date: Thu, 14 Feb 2019 06:08:13 +0000

Hi Robert,

Please see inline

> -----Original Message-----
> From: Robert Sparks <[email-masked]>
> Sent: Wednesday, February 13, 2019 8:47 PM
> To: [email-masked]
> Cc: [email-masked]; [email-masked]; [email-masked]
> Subject: Genart telechat review of draft-ietf-dots-requirements-18
> 
> This email originated from outside of the organization. Do not click links or
> open attachments unless you recognize the sender and know the content is safe.
> 
> Reviewer: Robert Sparks
> I am the assigned Gen-ART reviewer for this draft. The General Area Review
> Team (Gen-ART) reviews all IETF documents being processed by the IESG for
> the IETF Chair. Please wait for direction from your document shepherd or AD
> before posting a new version of the draft.
> 

Yup.

> adjustments? Has the group reviewed and agreed to these normative changes?

The WG has not identified any qualifying exceptional conditions for these requirements when the discussing the DOTS protocol and requirements drafts, hence I updated 
these requirements to use MUST.

> specifying protocol rather than requirements.

The additional text in SIG-004 is added to justify the reason for using "SHOULD".

Cheers,
-Tiru

---

From: Alissa Cooper <[email-masked]>
Date: Thu, 21 Feb 2019 09:18:35 -0500

Robert, thanks for your review. I agree about the heartbeat requirements and said so in my No Objection ballot. Tiru, thanks for your response on the other point.

Alissa

> On Feb 14, 2019, at 1:08 AM, Konda, Tirumaleswar Reddy <[email-masked]> wrote:
> 
> Hi Robert,
> 
> Please see inline
> 
>> From: Robert Sparks <[email-masked] <mailto:[email-masked]>>
>> To: [email-masked] <mailto:[email-masked]>
>> Cc: [email-masked] <mailto:[email-masked]>; [email-masked] <mailto:[email-masked]>; [email-masked] <mailto:[email-masked]>
> _______________________________________________
> Gen-art mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/gen-art <https://www.ietf.org/mailman/listinfo/gen-art>