Subject: [Gen-art] Genart last call review of draft-ietf-kitten-pkinit-alg-agility-05

From: Christer Holmberg <[email-masked]>
Date: Fri, 01 Mar 2019 00:36:53 -0800

Reviewer: Christer Holmberg
Review result: Ready with Issues

I am the assigned Gen-ART reviewer for this draft. The General Area
Review Team (Gen-ART) reviews all IETF documents being processed
by the IESG for the IETF Chair.  Please treat these comments just
like any other last call comments.

For more information, please see the FAQ at

<https://trac.ietf.org/trac/gen/wiki/GenArtfaq>.

Document: draft-ietf-kitten-pkinit-alg-agility-05
Reviewer: Christer Holmberg
Review Date: 2019-03-01
IETF LC End Date: 2019-02-17
IESG Telechat date: 2019-03-07

Summary: The draft needs to be more clear on how RFC 4556 is updated.

Major issues: None

Minor issues:

Q1:

For the unfamiliar reader, it is unclear exactly how RFC 4556 is updated. There
is e.g., no text indicating what sections of 4556 are updated, and there is no
"Updates to RFC 4556" section.

I assume the remainder of the draft then updates RFC 4556, but I think it needs
to be more clear for the unfamiliar reader.

Even if a "Updates to RFC 4556" section would not be feasible, the document
should indicate what parts/sections of 4556 are updated, and what sections in
the draft defines those updates.

Nits/editorial comments:

Q2:

Both the Abstract and the Introduction start with "This document updates
PKINIT,..."

I think it would be good to first give some background information on the
issue(s), and then state that the document fixes those issues by updating RFC
4556.

---

From: Robbie Harwood <[email-masked]>
Date: Wed, 06 Mar 2019 16:01:05 -0500

> issue(s), and then state that the document fixes those issues by updating RFC

Hi Christer, thanks for your review.

Greg has created and uploaded a new version (-06) to the tracker that
hopefully addresses your concerns.

Thanks,
--Robbie

---

From: Alissa Cooper <[email-masked]>
Date: Wed, 6 Mar 2019 22:28:44 -0500

Christer, thank you for your review. Robbie and Greg, thanks for your responses. I entered a No Objection ballot.

Alissa

> On Mar 6, 2019, at 4:01 PM, Robbie Harwood <[email-masked]> wrote:
> 
> Christer Holmberg <[email-masked] <mailto:[email-masked]>> writes:
> 
> _______________________________________________
> Gen-art mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/gen-art <https://www.ietf.org/mailman/listinfo/gen-art>