Subject: [Gen-art] Genart last call review of draft-housley-hkdf-oids-01

From: Francesca Palombini via Datatracker <[email-masked]>
Date: Mon, 08 Apr 2019 04:51:39 -0700

Reviewer: Francesca Palombini
Review result: Ready

I am the assigned Gen-ART reviewer for this draft. The General Area
Review Team (Gen-ART) reviews all IETF documents being processed
by the IESG for the IETF Chair.  Please treat these comments just
like any other last call comments.

For more information, please see the FAQ at

<https://trac.ietf.org/trac/gen/wiki/GenArtfaq>.

Document: draft-housley-hkdf-oids-01
Reviewer: Francesca Palombini
Review Date: 2019-04-08
IETF LC End Date: 2019-04-22
IESG Telechat date: Not scheduled for a telechat

Summary: This draft is ready for publication as an Informational RFC

Major issues: N/A

Minor issues: N/A

Nits/editorial comments: N/A

Other: IANA registration does not require the document to be on Standard track,
AFAIK. Is there a reason to go for Proposed Standard rather than Informational
in this doc? (Also considering RFC7107 is informational)

---

From: Russ Housley <[email-masked]>
Date: Mon, 8 Apr 2019 10:27:27 -0400

HKDF is gaining in popularity.  The only reason for standards track over informational is to avoid a future issue with a downward reference.

Russ

> On Apr 8, 2019, at 7:51 AM, Francesca Palombini via Datatracker <[email-masked]> wrote:
>

---

From: "Salz, Rich" <[email-masked]>
Date: Mon, 8 Apr 2019 15:26:06 +0000

>    HKDF is gaining in popularity.  The only reason for standards track over informational is to avoid a future issue with a downward reference.
  
Yes it is, thanks to TLS 1.3's adoption of it.  I think the "only" reason is actually "an excellent reason" for, well, the reason given.