Subject: [Gen-art] Gen-ART Telechat Call review of draft-ietf-extra-imap-fetch-preview-03

From: Meral Shirazipour <[email-masked]>
Date: Sun, 7 Apr 2019 18:50:54 +0000

I am the assigned Gen-ART reviewer for this draft. The General Area Review Team (Gen-ART) reviews all IETF documents being processed by the IESG for the IETF Chair. Please wait for direction from your document shepherd or AD before posting a new version of the draft.

For more information, please see the FAQ at <http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>.

Document: draft-ietf-extra-imap-fetch-preview-03
Reviewer: Meral Shirazipour
Review Date: 2019-04-07
IETF LC End Date:
IESG Telechat date: 2019-04-09

Summary: This draft is ready to be published as Standards Track RFC but I have some comments.

Major issues:

Minor issues:
-It may be obvious to most but it would be good to also mention how encrypted email should be handle and what type of preview should be allowed if any.
-The Fuzzy algorithm was proposed. It would be good to clarify if future algorithms are possible and if they would be extensions to this RFC.

Nits/editorial comments:
-[Page 5] ,"to the the language "---->"to the language "

Best Regards,
Meral
---
Meral Shirazipour
Ericsson Research
www.ericsson.com

---

From: Barry Leiba <[email-masked]>
Date: Sun, 7 Apr 2019 15:30:20 -0400

Thanks, Meral, for the review.

> Minor issues:
> -It may be obvious to most but it would be good to also mention how encrypted email
> should be handle and what type of preview should be allowed if any

It's certainly easy to say something, and I'll leave it to the author
to decide whether to.  But, yes, it's obvious: if the mail is
encrypted, the server *can't* provide any meaningful preview.

One reason it might be useful to say something is that the end of
Section 3.2 makes a semantic distinction between a zero-length string
and NIL, so it might be useful to say which one is applicable to an
encrypted message.

Barry

---

From: Meral Shirazipour <[email-masked]>
Date: Mon, 8 Apr 2019 00:30:23 +0000

Hi,
  Thanks that would be great.

Best,
Meral

-----Original Message-----
From: Barry Leiba <[email-masked]> 
Sent: Sunday, April 7, 2019 12:30 PM
To: Meral Shirazipour <[email-masked]>
Cc: [email-masked]; [email-masked]
Subject: Re: Gen-ART Telechat Call review of draft-ietf-extra-imap-fetch-preview-03

> Minor issues:
> -It may be obvious to most but it would be good to also mention how 
> encrypted email should be handle and what type of preview should be 
> allowed if any

It's certainly easy to say something, and I'll leave it to the author to decide whether to.  But, yes, it's obvious: if the mail is encrypted, the server *can't* provide any meaningful preview.

One reason it might be useful to say something is that the end of Section 3.2 makes a semantic distinction between a zero-length string and NIL, so it might be useful to say which one is applicable to an encrypted message.

Barry

---

From: Alissa Cooper <[email-masked]>
Date: Wed, 10 Apr 2019 12:34:08 -0400

Meral, thanks for your review. I see Barry incorporated your point about encrypted email into his ballot. I entered a No Objection ballot.

Alissa

> On Apr 7, 2019, at 8:30 PM, Meral Shirazipour <[email-masked]> wrote:
> 
> Hi,
> _______________________________________________
> Gen-art mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/gen-art