Subject: [Gen-art] review of draft-ietf-6tisch-architecture-20.txt

From: Francis Dupont <[email-masked]>
Date: Mon, 01 Jul 2019 14:05:34 +0200

I am the assigned Gen-ART reviewer for this draft. The General Area
Review Team (Gen-ART) reviews all IETF documents being processed
by the IESG for the IETF Chair.  Please treat these comments just
like any other last call comments.

For more information, please see the FAQ at

<https://trac.ietf.org/trac/gen/wiki/GenArtfaq>.

Document: draft-ietf-6tisch-architecture-20.txt
Reviewer: Francis Dupont
Review Date: 20190633
IETF LC End Date: 20190626
IESG Telechat date: unknown

Summary: Ready

Major issues: None

Minor issues: None

Nits/editorial comments:
 - 1 page 3: the IT abbrev is not introduced

 - 2.1 page 5 (bundle), page 9 (slotOffset), 4.61 page 38 (2.): i.e. -> i.e.,

 - 2.1 page 6 (chunk): missing closing parenthesis

 - 2.1 page 9 (Track): the text says the root is the destination. IMHO
   the DODAG has an unique leaf which is the destination?

 - 3.1 page 12: please expand the PCE abbrev here (first occurrence,
   note the expansion is in 3.3. page 15: you can move or duplicate it).

 - 3.2 page 14: the 6LBR ... need -> needs

 - 4.2.2 pafge 25 figure 6: there are multiple arrows for the RS. I believe
   it is a way to figure multicasting?

 - 4.3.1.1 page 27, 4.3.3 page 29, 4.5.3 page 35 (3 times), 4.7.1.2 page 42:
    e.g. -> e.g.,

 - 4.6 page 37: 
    one or more destination(s) 6TiSCH node(s)
  ->
    one or more destination 6TiSCH nodes

Spelling:
 - 1 page 3: undated -> updated
 - 4.1.1 page 21: settig -> setting
 - 4.3.3. page 29: infoirmation -> information
 - 4.3.3 page 29: behaviour -> behavior
 - 4.4 page 33: multithop -> multihop
 - 4.7.1.1 page 42: dependant -> dependent
 - 7.1 page 51: implementaton -> implementation
 - A page 60 (PAW): Predicatable -> Predictable  

At the exception of the DODAG root in Track definition there is nothing
which can't be done by the RFC Editor so could require a new version.

Regards

[email-masked]

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Tue, 2 Jul 2019 13:08:07 +0000

Hello Francis

Many thanks for your review. It clearly indicates a thorough reading, this is much appreciated.

>  - 2.1 page 6 (chunk): missing closing parenthesis
All done

>    the DODAG has an unique leaf which is the destination?

Well, no, the traffic comes from the leaves to the root. Arguable from any node in the DODAG but then the schedule must make sure there is no collision if there are multiple sources.
What's unique is the root, that's the DO in DODAG

>     one or more destination 6TiSCH nodes

All done

>  - 1 page 3: undated -> updated

Replaced by "without a date"

> At the exception of the DODAG root in Track definition there is nothing which
> can't be done by the RFC Editor so could require a new version.
> 

All cool, publishing 24.

Many thanks Francis!