Subject: [Gen-art] Genart last call review of draft-ietf-tls-tls13-cert-with-extern-psk-03

From: Ines Robles via Datatracker <[email-masked]>
Date: Mon, 02 Dec 2019 15:59:11 -0800

Reviewer: Ines Robles
Review result: Ready

I am the assigned Gen-ART reviewer for this draft. The General Area
Review Team (Gen-ART) reviews all IETF documents being processed
by the IESG for the IETF Chair.  Please treat these comments just
like any other last call comments.

For more information, please see the FAQ at

<https://trac.ietf.org/trac/gen/wiki/GenArtfaq>.

Document: draft-ietf-tls-tls13-cert-with-extern-psk-??
Reviewer: Ines Robles
Review Date: 2019-12-02
IETF LC End Date: 2019-12-02
IESG Telechat date: Not scheduled for a telechat

Summary:

The document is well written.

This document specifies a TLS 1.3 extension permitting certificate-based server
authentication to be combined with an external PSK as an input to the TLS 1.3
key schedule.

Major issues: Not found

Minor issues: Not found

Nits/editorial comments:

I think that would be nice to add in IANA Considerations a table specifying the
fields of the TLS ExtensionType Values indicated in
https://www.iana.org/assignments/tls-extensiontype-values/tls-extensiontype-values.xhtml

Thank you for this document,

Ines.

---

From: Alissa Cooper <[email-masked]>
Date: Thu, 19 Dec 2019 08:55:08 -0500

Ines, thanks for your review. I entered a No Objection ballot.

Alissa

> On Dec 2, 2019, at 6:59 PM, Ines Robles via Datatracker <[email-masked]> wrote:
> 
> Reviewer: Ines Robles
> Review result: Ready
> 
> _______________________________________________
> Gen-art mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/gen-art

---

From: Russ Housley <[email-masked]>
Date: Thu, 19 Dec 2019 10:08:41 -0500

Ines:

Thanks for taking the time to review the document.

> https://www.iana.org/assignments/tls-extensiontype-values/tls-extensiontype-values.xhtml <https://www.iana.org/assignments/tls-extensiontype-values/tls-extensiontype-values.xhtml>

I am willing to add the table, but I observe that IANA was able to correctly add the entry based on the words in the document.  You will see that they have assigned the number 33 to this extension.

Russ