Subject: [Gen-art] Genart last call review of draft-ietf-6lo-minimal-fragment-08

From: Francesca Palombini via Datatracker <[email-masked]>
Date: Thu, 30 Jan 2020 22:40:58 -0800

Reviewer: Francesca Palombini
Review result: Ready with Nits

I am the assigned Gen-ART reviewer for this draft. The General Area
Review Team (Gen-ART) reviews all IETF documents being processed
by the IESG for the IETF Chair.  Please treat these comments just
like any other last call comments.

For more information, please see the FAQ at

<https://trac.ietf.org/trac/gen/wiki/GenArtfaq>.

Document: draft-ietf-6lo-minimal-fragment-08
Reviewer: Francesca Palombini
Review Date: 2020-01-30
IETF LC End Date: 2020-01-31
IESG Telechat date: Not scheduled for a telechat

Summary: This draft is basically ready for publication. However, I noticed the
normative reference to an informative document,
draft-ietf-lwig-6lowpan-virtual-reassembly (ref. 'LWIG-VRB'), which is
problematic, since this draft is on the standard track.

Major issues: -

Minor issues: -

Nits/editorial comments:

* Last paragraph of Section 5, I suggest a minor reformulation for clarity.

OLD:
   An associated
   caveat is that on a half duplex radio, if node A sends the next
   fragment at the same time as node B forwards the previous fragment to
   a node C down the path then node B will miss the next fragment.
NEW:
   An associated
   caveat is that on a half duplex radio, if node A sends the next
   fragment at the same time as node B forwards the previous fragment to
   a node C down the path then node B will miss the next fragment from node A.

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Fri, 31 Jan 2020 09:55:41 +0000

Hello Francesca:

Many thanks for your review : )

> normative reference to an informative document, draft-ietf-lwig-6lowpan-
> virtual-reassembly (ref. 'LWIG-VRB'), which is problematic, since this draft is
> on the standard track.

Moved both this and the reference to recoverable frags to informational. They are just illustrative anyway.

>    a node C down the path then node B will miss the next fragment from node

Applied, and published 09. Please let me know if we are all set now? 

Again, many thanks, Francesca!

Pascal