Subject: [Gen-art] Genart last call review of draft-ietf-extra-imap-fetch-preview-09

From: Meral Shirazipour via Datatracker <[email-masked]>
Date: Tue, 15 Sep 2020 13:52:29 -0700

Reviewer: Meral Shirazipour
Review result: Ready with Nits

I am the assigned Gen-ART reviewer for this draft. The General Area
Review Team (Gen-ART) reviews all IETF documents being processed
by the IESG for the IETF Chair.  Please treat these comments just
like any other last call comments.

For more information, please see the FAQ at

<https://trac.ietf.org/trac/gen/wiki/GenArtfaq>.

Document: draft-ietf-extra-imap-fetch-preview-09
Reviewer: Meral Shirazipour
Review Date: 2020-09-15
IETF LC End Date: 2020-09-14
IESG Telechat date: Not scheduled for a telechat

Summary: This draft is ready to be published as Standards Track RFC but I have
some comments.

Major issues:

Minor issues:

Nits/editorial comments: In Section 4.2, it would have been good to give some
example and advice on when the client uses the preview to take some action. Is
this to be avoided? (Was not very clear to me).

Best Regards,
Meral Shirazipour
www.ericsson.com

---

From: Barry Leiba <[email-masked]>
Date: Tue, 15 Sep 2020 17:26:33 -0400

Meral, thanks for the review.  The document does say in the first sentence
of the Introduction that the preview is for the end user.  I agree that it
would be useful to emphasize that, though, and I think the right place to
do it is by adding to the first paragraph of Section 3.2 something like the
following: “The preview string is meant to help the end-user, and is not
intended to be interpreted in any way by the client software.”

Barry

---

From: Michael Slusarz <[email-masked]>
Date: Sun, 20 Sep 2020 20:35:34 -0600 (MDT)

How about changing the first paragraph of Section 3.2 to the following:

"The server returns a variable-length string that is the generated preview for that message.  This string is intended to be viewed by the user as a contextual preview of the entire message, and is not intended to be interpreted in any way by the client software."

Slightly altered Barry's wording - "user" is already defined in Section 2 as the human user, so to be consistent I think we should use "user" instead of "end-user".

michael

>     On 09/15/2020 3:26 PM Barry Leiba <[email-masked]> wrote:
> 
> 
>     Meral, thanks for the review.  The document does say in the first sentence of the Introduction that the preview is for the end user.  I agree that it would be useful to emphasize that, though, and I think the right place to do it is by adding to the first paragraph of Section 3.2 something like the following: “The preview string is meant to help the end-user, and is not intended to be interpreted in any way by the client software.”
> 
>     Barry
> 
>     On Tue, Sep 15, 2020 at 4:52 PM Meral Shirazipour via Datatracker <[email-masked] mailto:[email-masked] > wrote:
> 
> >         http://www.ericsson.com

---

From: Barry Leiba <[email-masked]>
Date: Sun, 20 Sep 2020 22:52:15 -0400

That looks good to me, Michael.

Barry

On Sun, Sep 20, 2020 at 10:35 PM Michael Slusarz <
[email-masked]> wrote:

> "The server returns a variable-length string that is the generated preview
> for that message.  This string is intended to be viewed by the user as a
> contextual preview of the entire message, and is not intended to be
> interpreted in any way by the client software."
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
> Slightly altered Barry's wording - "user" is already defined in Section 2
> as the human user, so to be consistent I think we should use "user" instead
> of "end-user".
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
> michael
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>

---

From: Alissa Cooper <[email-masked]>
Date: Wed, 23 Sep 2020 10:33:33 -0400

Meral, thanks for your review. Michael, thanks for the update. I entered a No Objection ballot.

Alissa

> On Sep 20, 2020, at 10:52 PM, Barry Leiba <[email-masked]> wrote:
> 
> On Sun, Sep 20, 2020 at 10:35 PM Michael Slusarz <[email-masked] <mailto:[email-masked]>> wrote:
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
>> On 09/15/2020 3:26 PM Barry Leiba <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> 
>> 
>> 
>> 
>> 
>> 
>> 
>> 
>> 
>> 
>> 
>> 
>> 
>> 
>> 
>> 
>> 
>> 
>> On Tue, Sep 15, 2020 at 4:52 PM Meral Shirazipour via Datatracker <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> 
>> 
>> 
>> 
>> 
>> 
>> 
>> <https://trac.ietf.org/trac/gen/wiki/GenArtfaq <https://trac.ietf.org/trac/gen/wiki/GenArtfaq>>.
>> 
>> 
>> 
>> 
>> 
>> 
>> 
>> 
>> 
>> 
>> 
>> www.ericsson.com <http://www.ericsson.com/>
>> 
>> 
>> 
>> 
>> 
>> 
>> 
>> 
>> 
>> 
>> 
>> 
>> 
>> 
>> 
>> 
>> 
>> 
>> 
>> 
>> 
>> 
>> 
>> 
>> 
>> 
>> 
>> 
>> 
>> 
>> 
> 
> 
> 
> 
> _______________________________________________
> Gen-art mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/gen-art