Subject: [Gen-art] Gen-ART Last Call review of draft-ietf-avtcore-cc-feedback-message-08

From: Paul Kyzivat <[email-masked]>
Date: Mon, 7 Sep 2020 11:46:42 -0400

I am the assigned Gen-ART reviewer for this draft. The General Area
Review Team (Gen-ART) reviews all IETF documents being processed
by the IESG for the IETF Chair.  Please treat these comments just
like any other last call comments.

For more information, please see the FAQ at

<https://trac.ietf.org/trac/gen/wiki/GenArtfaq>.

Document: draft-ietf-avtcore-cc-feedback-message-08
Reviewer: Paul Kyzivat
Review Date: 2020-09-16
IETF LC End Date: 2020-09-16
IESG Telechat date: ?

This draft is basically ready for publication, but has nits that should 
be fixed before publication.

I noticed one nit (typo) in section 7:

    s/ecn-capaable-rtp/ecn-capable-rtp/

Beyond that I have one question/suggestion that I'm happy to have you 
consider or ignore as you see fit:

In the case of missing packets it seems that you have the opportunity to 
save some space by encoding a run of contiguous missing packets as a 
single packet metric block with L=0, using the remaining bits in the 
metric block to encode the number of missing packets. Whether that is an 
optimization worth the trouble to do is a question I can't answer.

Otherwise, IMO this draft is ready to go.

---

From: Colin Perkins <[email-masked]>
Date: Thu, 17 Sep 2020 23:43:10 +0100

> On 7 Sep 2020, at 16:46, Paul Kyzivat <[email-masked]> wrote:
> 
> This draft is basically ready for publication, but has nits that should be fixed before publication.
> 

Will fix.

> Beyond that I have one question/suggestion that I'm happy to have you consider or ignore as you see fit:
> 
> In the case of missing packets it seems that you have the opportunity to save some space by encoding a run of contiguous missing packets as a single packet metric block with L=0, using the remaining bits in the metric block to encode the number of missing packets. Whether that is an optimization worth the trouble to do is a question I can't answer.

It’s certainly possible to do that, and the WG did discuss optimisations and more complex formats. At present, I think simple and published outweigh optimised.

Cheers,
Colin

-- 
Colin Perkins
https://csperkins.org/