Subject: [Gen-art] Genart last call review of draft-allan-5g-fmc-encapsulation-07

From: Russ Housley via Datatracker <[email-masked]>
Date: Thu, 28 Jan 2021 08:02:24 -0800

Reviewer: Russ Housley
Review result: Almost Ready

I am the assigned Gen-ART reviewer for this draft. The General Area
Review Team (Gen-ART) reviews all IETF documents being processed
by the IESG for the IETF Chair.  Please treat these comments just
like any other last call comments.

For more information, please see the FAQ at
<http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>.

Document: draft-allan-5g-fmc-encapsulation-07
Reviewer: Russ Housley
Review Date: 2021-01-28
IETF LC End Date: 2021-02-05
IESG Telechat date: Unknown

Summary: Almost Ready

Thank you for addressing all of the concerns raie in my earlier review.

Major Concerns:

Section 1 says:

   This encapsulation is expected to be used in environments where RFC
   2516 is deployed. Therefore implementations are required to examine
   the version number and react accordingly.

Please reword as a MUST statement.  Also, a simple sentence that tells
the implementer how to "react accordingly" is needed.  I suspect that
one should follow RFC 2516 if the version is 0x01 and follow this
memo if the version is 0x02.

Minor Concerns:

None.

Nits:

Section 1 says: "... same offset as the [RFC2516] PPPoE data ...".
The [RFC2516] is placed in an awkward location in the sentence.

---

From: David Allan I <[email-masked]>
Date: Thu, 28 Jan 2021 23:51:34 +0000

HI Russ:

I understand your major concern. How does this work?

   This encapsulation is expected to be used in environments where RFC 2516 is deployed. Therefore implementations MUST examine the version number:
    - if the version number is 1, and PPPoE [RFC2516] is supported, process the frame further, else silently discard it.
    - if the version number is 2 and 5WE is supported, process the frame further, else silently discard it.  
   In both cases frames for the supported version number should  have session IDs corresponding to established sessions for the respective protocol models. A 5WE frame with an unrecognized session ID MUST be silently discarded.

We'll correct the minor nit along with the wherever we get to with the above, and any other updates that come out of the LC.

Rgds
Dave

-----Original Message-----
From: Russ Housley via Datatracker <[email-masked]> 
Sent: Thursday, January 28, 2021 8:02 AM
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: Genart last call review of draft-allan-5g-fmc-encapsulation-07

Reviewer: Russ Housley

I am the assigned Gen-ART reviewer for this draft. The General Area Review Team (Gen-ART) reviews all IETF documents being processed by the IESG for the IETF Chair.  Please treat these comments just like any other last call comments.

For more information, please see the FAQ at <http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>.

Summary: Almost Ready

Major Concerns:

Section 1 says:

Please reword as a MUST statement.  Also, a simple sentence that tells the implementer how to "react accordingly" is needed.  I suspect that one should follow RFC 2516 if the version is 0x01 and follow this memo if the version is 0x02.

Minor Concerns:

None.

Nits:

---

From: Russ Housley <[email-masked]>
Date: Thu, 28 Jan 2021 19:28:46 -0500

That works for me.

> On Jan 28, 2021, at 6:51 PM, David Allan I <[email-masked]> wrote:
> 
> HI Russ:
>