Subject: [Gen-art] Genart last call review of draft-ietf-lwig-minimal-esp-04

From: Roni Even via Datatracker <[email-masked]>
Date: Fri, 02 Apr 2021 00:58:06 -0700

Reviewer: Roni Even
Review result: Ready with Issues

I am the assigned Gen-ART reviewer for this draft. The General Area
Review Team (Gen-ART) reviews all IETF documents being processed
by the IESG for the IETF Chair.  Please treat these comments just
like any other last call comments.

For more information, please see the FAQ at

<https://trac.ietf.org/trac/gen/wiki/GenArtfaq>.

Document: draft-ietf-lwig-minimal-esp-??
Reviewer: Roni Even
Review Date: 2021-04-02
IETF LC End Date: None
IESG Telechat date: Not scheduled for a telechat

Summary:
This is an early review of the draft. I find the 04 version easy to understand
but have one comment

Major issues:

Minor issues:
the last paragraph in the abstract , mostly the last sentence " RFC 4303
remains the authoritative description." should be in my opinion in the main
body of the document and not only in the abstract. I also see some difference
between the document and RFC4303

Nits/editorial comments:

---

From: Daniel Migault <[email-masked]>
Date: Sat, 3 Apr 2021 00:53:14 +0000

Hi Roni, 

Thanks for the review. We can of course add that RFC4303 is authoritative in the main body. I will update the document.

I am wondering what differences you have in mind. Of course the document are different but I am wondering if there is anything we should clarify. 

Yours, 
Daniel

-----Original Message-----
From: Roni Even via Datatracker <[email-masked]> 
Sent: Friday, April 2, 2021 3:58 AM
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: Genart last call review of draft-ietf-lwig-minimal-esp-04

Reviewer: Roni Even

I am the assigned Gen-ART reviewer for this draft. The General Area Review Team (Gen-ART) reviews all IETF documents being processed by the IESG for the IETF Chair.  Please treat these comments just like any other last call comments.

Summary:
This is an early review of the draft. I find the 04 version easy to understand but have one comment

Major issues:

Minor issues:
the last paragraph in the abstract , mostly the last sentence " RFC 4303 remains the authoritative description." should be in my opinion in the main body of the document and not only in the abstract. I also see some difference between the document and RFC4303

Nits/editorial comments:

---

From: "Roni Even" <[email-masked]>
Date: Thu, 8 Apr 2021 09:40:01 +0300

Hi Daniel,
About the difference between the draft and RFC4303 when reading for the first time I thought that section 7 is not the same as 2.8 in RFC4303 about integrity only but it was my mistake. So forget this comment. Still you use authentication while RFC4303 use integrity but the recommendation is the same.
Roni

> From: Daniel Migault [mailto:[email-masked]]
> Sent: Saturday, April 03, 2021 3:53 AM
> To: Roni Even; [email-masked]
> Subject: RE: Genart last call review of draft-ietf-lwig-minimal-esp-04
> 
> Hi Roni,
> 
> Thanks for the review. We can of course add that RFC4303 is authoritative in
> the main body. I will update the document.
> 
> I am wondering what differences you have in mind. Of course the document are
> different but I am wondering if there is anything we should clarify.
> 
> Yours,
> Daniel
> 
> 
> I am the assigned Gen-ART reviewer for this draft. The General Area Review
> Team (Gen-ART) reviews all IETF documents being processed by the IESG for the
> IETF Chair.  Please treat these comments just like any other last call comments.
> 
> the last paragraph in the abstract , mostly the last sentence " RFC 4303 remains
> the authoritative description." should be in my opinion in the main body of the
> document and not only in the abstract. I also see some difference between the
> document and RFC4303
> 
> Nits/editorial comments:
> 
>

---

From: Daniel Migault <[email-masked]>
Date: Thu, 8 Apr 2021 09:33:27 -0400

Hi Roni,

Thanks for the clarification.

Yours,
Daniel

On Thu, Apr 8, 2021 at 2:40 AM Roni Even <[email-masked]> wrote:

> Hi Daniel,
> About the difference between the draft and RFC4303 when reading for the
> first time I thought that section 7 is not the same as 2.8 in RFC4303 about
> integrity only but it was my mistake. So forget this comment. Still you use
> authentication while RFC4303 use integrity but the recommendation is the
> same.
> Roni
>
> Review
> > This is an early review of the draft. I find the 04 version easy to
> understand but
> > have one comment
> >
> > Major issues:
> >
> > Minor issues:
> remains
> _______________________________________________
> Lwip mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lwip
>

-- 
Daniel Migault
Ericsson

---

From: Daniel Migault <[email-masked]>
Date: Tue, 13 Apr 2021 11:29:54 -0400

Hi Roni,

As a follow up, I just posted version 05 that reflects the change to
address your concern.

Yours,
Daniel

-- 
Daniel Migault
Ericsson