Subject: [Gen-art] Genart last call review of draft-ietf-payload-rtp-jpegxs-12

From: Russ Housley via Datatracker <[email-masked]>
Date: Thu, 06 May 2021 10:49:02 -0700

Reviewer: Russ Housley
Review result: Almost Ready

I am the assigned Gen-ART reviewer for this draft. The General Area
Review Team (Gen-ART) reviews all IETF documents being processed
by the IESG for the IETF Chair.  Please treat these comments just
like any other last call comments.

For more information, please see the FAQ at
<http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>.

Document: draft-ietf-payload-rtp-jpegxs-12
Reviewer: Russ Housley
Review Date: 2021-05-06
IETF LC End Date: 2021-05-17
IESG Telechat date: Unknown

Summary: Almost Ready

Major Concerns:

Section 7.2.1:  Does the SHALL related to [SMPTE-ST2110-10] only apply
when TP=2110TPNL or TP=2110TPW?  Please reword to be clear when this
SHALL statement applies.

Minor Concerns:

Section 3.3:  I do not have [ISO21122-2], and obviously an implementer
will need that document.  Can a bit more be said about "the profile"
and "the level and sublevel used" without making this document too
big?  I am able to get a feel for the other things listed here from
their names.

Section 3.4:  Can you please provide some explanation of the "frat
field"?

Nits:

Section 3.2:  I do not understand the the last sentence?  Is it the
same as: It represents sample values of a single image, without any
interpretation relative to a colour space.

Section 5: s/of ST 2110-21 do not /of [SMPTE-ST2110-21] do not /

---

From: Russ Housley <[email-masked]>
Date: Fri, 7 May 2021 10:58:29 -0400

Tim:

> Thank you for the review and the comments. Please find the following answers to your comments below. I have modified the draft and uploaded a -13 version.
> 
> 
>> Major Concerns:
>> Section 7.2.1:  Does the SHALL related to [SMPTE-ST2110-10] only apply when TP=2110TPNL or TP=2110TPW?  Please reword to be clear when this SHALL statement applies.
> 
> The short answer is yes, the SHALL only applies when using the RTP specification in combination with SMPTE ST 2110. But, we chose to remove the SHALL sentence about ST 2110. Originally it was trying to say that in the case of using this RTP Payload under a SMPTE ST 2110 system, that the SDP description must then also follow the rules of STMPTE ST 2110-10. But, it is evident that when implementing another standard, the one must follow that standard. It is a concern of a ST 2110 implementer. For this specification it changes nothing specifically (ST 2110-10 mandates some specific SDP fields and values, but this is allowed by the memo). We specifically made these changes to allow the RTP payload to be used also outside of a ST 2110 ecosystem.

That resolves my concern; thanks.

>> Minor Concerns:
>> Section 3.3:  I do not have [ISO21122-2], and obviously an implementer will need that document.  Can a bit more be said about "the profile" and "the level and sublevel used" without making this document too big?  I am able to get a feel for the other things listed here from their names.
> 
> We reworked this section to clarify better the concepts of the profile and level/sublevel fields, without duplicating content from ISO21122-2.

This helps; thanks.

>> Section 3.4:  Can you please provide some explanation of the "frat field"?
> 
> We reformulated the text a bit and added an explicit reference for the frat field to ISO21122-3 where it is defined.

Thanks for adding that context.

>> Nits:
>> Section 3.2:  I do not understand the the last sentence?  Is it the same as: It represents sample values of a single image, without any interpretation relative to a colour space.
> 
> Yes, that is correct. We changed the sentence to use your suggested wording.

That is more clear to me; thanks.

> We have updated the reference.

Thanks.

Russ

---

From: Tim Bruylants <[email-masked]>
Date: Fri, 7 May 2021 12:59:35 +0000

Dear Russ,

I hope this addresses all concerns. If not, please let us know.

Best regards,
Tim Bruylants.

-----Original Message-----
From: avt <[email-masked]> On Behalf Of Russ Housley via Datatracker
Sent: Thursday 6 May 2021 19:49
To: [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: [AVTCORE] Genart last call review of draft-ietf-payload-rtp-jpegxs-12

Reviewer: Russ Housley

I am the assigned Gen-ART reviewer for this draft. The General Area Review Team (Gen-ART) reviews all IETF documents being processed by the IESG for the IETF Chair.  Please treat these comments just like any other last call comments.

For more information, please see the FAQ at <https://urldefense.proofpoint.com/v2/url?u=http-3A__wiki.tools.ietf.org_area_gen_trac_wiki_GenArtfaq&d=DwICAg&c=euGZstcaTDllvimEN8b7jXrwqOf-v5A_CdpgnVfiiMM&r=LTxUGukLCEfEUdo_bq048Q&m=z2S49lWIieCrrBDNEiE0OzMQ61wadfshm9Ih9Hhkn2s&s=hEKUOxSpF8FPOPqAxvBrFJ9z2wBYMsQ774TGg8xqbJQ&e=>.

Summary: Almost Ready

Major Concerns:

Minor Concerns:

Section 3.3:  I do not have [ISO21122-2], and obviously an implementer will need that document.  Can a bit more be said about "the profile"
and "the level and sublevel used" without making this document too big?  I am able to get a feel for the other things listed here from their names.

Nits:

_______________________________________________
Audio/Video Transport Core Maintenance
[email-masked]
https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_avt&d=DwICAg&c=euGZstcaTDllvimEN8b7jXrwqOf-v5A_CdpgnVfiiMM&r=LTxUGukLCEfEUdo_bq048Q&m=z2S49lWIieCrrBDNEiE0OzMQ61wadfshm9Ih9Hhkn2s&s=o16hyf29LBiyL98baNxoA8_0Xsng0H8HPcS4gX7o9qA&e=