Subject: [Gen-art] Genart last call review of draft-ietf-httpbis-bcp56bis-13

From: David Schinazi via Datatracker <[email-masked]>
Date: Thu, 12 Aug 2021 11:36:09 -0700

Reviewer: David Schinazi
Review result: Ready with Issues

I am the assigned Gen-ART reviewer for this draft. The General Area Review Team
(Gen-ART) reviews all IETF documents being processed by the IESG for the IETF
Chair.  Please treat these comments just like any other last call comments. For
more information, please see the FAQ at
<https://trac.ietf.org/trac/gen/wiki/GenArtfaq>.

Document: draft-ietf-httpbis-bcp56bis-13
Reviewer: David Schinazi
Review Date: 2021-08-12
IETF LC End Date: 2021-07-23
IESG Telechat date: Not scheduled for a telechat

Summary: Well-written and easy to read document.

Major issues: None

Minor issues:
* s4.5 seems to prohibit defining new non-generic HTTP methods. How do we
reconcile that with the work happening in MASQUE? I know that CONNECT is its
own special-case, but should we have a carveout here? (Though MASQUE might end
up using extended CONNECT which side steps the issue). Or is it the case that
MASQUE is modifying HTTP itself instead of building an application over HTTP?

Nits/editorial comments:
* s3.2 uses the term "link" without explaining what it is. Perhaps a reference
to RFC 8288 if that's what is meant here? * s4.11 mentions HTTP/3 without
referencing its specification

---

From: Mark Nottingham <[email-masked]>
Date: Fri, 13 Aug 2021 10:23:26 +1000

Hi David,

Thanks for the feedback. Responses below.

> On 13 Aug 2021, at 4:36 am, David Schinazi via Datatracker <[email-masked]> wrote:
> 
> Minor issues:

That is only restating the requirements of HTTP:

'Unlike distributed objects, the standardized request methods in HTTP are not resource-specific, since uniform interfaces provide for better visibility and reuse in network-based systems [REST]. Once defined, a standardized method ought to have the same semantics when applied to any resource, though each resource determines for itself whether those semantics are implemented or allowed.' -- https://httpwg.org/http-core/draft-ietf-httpbis-semantics-latest.html#method.overview

'Standardized methods are generic; that is, they are potentially applicable to any resource, not just one particular media type, kind of resource, or application. As such, it is preferred that new methods be registered in a document that isn't specific to a single application or data format, since orthogonal technologies deserve orthogonal specification.' -- https://httpwg.org/http-core/draft-ietf-httpbis-semantics-latest.html#considerations.for.new.methods

That said, I don't see MASQUE as an application of HTTP; it's a generic extension.

> referencing its specification

See:
  https://github.com/httpwg/http-extensions/commit/70c3ee4dde

Cheers and thanks again,

--
Mark Nottingham   https://www.mnot.net/

---

From: David Schinazi <[email-masked]>
Date: Fri, 13 Aug 2021 13:36:58 -0700

Thanks Mark!

Your explanation of the interaction with MASQUE makes sense to me and
addresses my minor issue, and your commit fully addresses my nits.

My GenART review result is now "Ready" with no further comments.

David

On Thu, Aug 12, 2021 at 5:23 PM Mark Nottingham <[email-masked]> wrote:

> 'Unlike distributed objects, the standardized request methods in HTTP are
> not resource-specific, since uniform interfaces provide for better
> visibility and reuse in network-based systems [REST]. Once defined, a
> standardized method ought to have the same semantics when applied to any
> resource, though each resource determines for itself whether those
> semantics are implemented or allowed.' --
> https://httpwg.org/http-core/draft-ietf-httpbis-semantics-latest.html#method.overview
>
> 'Standardized methods are generic; that is, they are potentially
> applicable to any resource, not just one particular media type, kind of
> resource, or application. As such, it is preferred that new methods be
> registered in a document that isn't specific to a single application or
> data format, since orthogonal technologies deserve orthogonal
> specification.' --
> https://httpwg.org/http-core/draft-ietf-httpbis-semantics-latest.html#considerations.for.new.methods
>

---

From: Lars Eggert <[email-masked]>
Date: Tue, 24 Aug 2021 14:12:07 +0300

David, thank you for your review. I have entered a (procedural) Discuss ballot for this document (due to a still-missing IANA review).

Lars

> On 2021-8-12, at 21:36, David Schinazi via Datatracker <[email-masked]> wrote:
> 
> Reviewer: David Schinazi
> last-call mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/last-call