Subject: [Gen-art] Genart last call review of draft-carpenter-rfced-iab-charter-05

From: Pete Resnick via Datatracker <[email-masked]>
Date: Tue, 15 Feb 2022 12:02:15 -0800

Reviewer: Pete Resnick
Review result: Ready with Nits

I am the assigned Gen-ART reviewer for this draft. The General Area
Review Team (Gen-ART) reviews all IETF documents being processed
by the IESG for the IETF Chair.  Please treat these comments just
like any other last call comments.

For more information, please see the FAQ at

<https://trac.ietf.org/trac/gen/wiki/GenArtfaq>.

Document: draft-carpenter-rfced-iab-charter-05
Reviewer: Pete Resnick
Review Date: 2022-02-15
IETF LC End Date: 2022-03-07
IESG Telechat date: 2022-03-10

Summary: Looks fine, save one typo

Major issues: None

Minor issues: None

Nits/editorial comments: In section 2, change "(b) RFC Series and IANA" to "(d) RFC Series and IANA"

---

From: Pete Resnick <[email-masked]>
Date: Tue, 15 Feb 2022 14:08:11 -0600

[Sorry; resending from the proper From address.]

Oh, one other bit: In the <rfc> directive at the top of the XML, you 
should add seriesNo="39" as an indicator to the RFC Editor to make sure 
that this document is added to BCP 39, not create a new BCP number.

On 15 Feb 2022, at 14:02, Pete Resnick via Datatracker wrote:

> <https://trac.ietf.org/trac/gen/wiki/GenArtfaq> .
>

-- 
Pete Resnick https://www.episteme.net/
All connections to the world are tenuous at best

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 16 Feb 2022 10:25:27 +1300

Pete,

Good catches, thanks.

Can somebody tell me how to insert that seriesNo="39" in kramdown?

Regards
    Brian Carpenter

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 16 Feb 2022 10:33:57 +1300

> Can somebody tell me how to insert that seriesNo="39" in kramdown?

Never mind. I found out by trial and error (seriesNo: "39").

Regards
    Brian

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 15 Feb 2022 22:37:58 +0100

> Can somebody tell me how to insert that seriesNo="39" in kramdown?

Sure.  As with the other <rfc attributes, it’s another top-level parameter in the YAML:

title: Example Document
abbrev: concert
docname: draft-mehrtens-core-ace-concert-00
seriesno: 39
category: bcp

(Kramdown does the studlification for you, turning this into seriesNo.)

Grüße, Carsten

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 15 Feb 2022 22:47:24 +0100

> seriesno: 39

And now, the answer to the more important question:  Where is that documented?

https://github.com/cabo/kramdown-rfc2629/wiki/Syntax#the-yaml-header

(Documented since 2016-02-16.)

Grüße, Carsten

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 15 Feb 2022 22:56:49 +0100

And, even more importantly, why you shouldn’t use that attribute any more :-)

https://xml2rfc.tools.ietf.org/xml2rfc-doc.html#section-2.49.10 <https://xml2rfc.tools.ietf.org/xml2rfc-doc.html#section-2.49.10>
Tracing that back historically:
https://www.rfc-editor.org/rfc/rfc7991.html#section-2.45.10

Grüße, Carsten

> On 15. Feb 2022, at 22:47, Carsten Bormann <[email-masked]> wrote:
>