Subject: Re: [Gen-art] Genart last call review of draft-ietf-httpapi-linkset-06

From: Lars Eggert <[email-masked]>
Date: Tue, 1 Mar 2022 15:57:22 +0100

Christer, thank you for your review. I have entered a No Objection ballot for this document.

Lars

> On 2022-1-11, at 0:26, Christer Holmberg via Datatracker <[email-masked]> wrote:
> 
> Reviewer: Christer Holmberg
> Review result: Ready with Issues
> 
> I am the assigned Gen-ART reviewer for this draft. The General Area
> Review Team (Gen-ART) reviews all IETF documents being processed
> by the IESG for the IETF Chair.  Please treat these comments just
> like any other last call comments.
> 
> For more information, please see the FAQ at
> 
> <https://trac.ietf.org/trac/gen/wiki/GenArtfaq>.
> 
> Document: draft-ietf-httpapi-linkset-06
> Reviewer: Christer Holmberg
> Review Date: 2022-01-10
> IETF LC End Date: 2022-01-19
> IESG Telechat date: Not scheduled for a telechat
> 
> Summary: Technically I don't have any major issue.  However, I do have a minor
> technical, one administrative, and some editorial, comments.
> 
> Major issues:
> 
> Q1: The draft is intended to be published as Informational RFC. That sounds a
> little strange to me. Could you please explain what the reason is?
> 
> Minor issues:
> 
> Q2: The document defines the "application/linkset+json" format, and indicates
> that it can also be used for JSON-LD. What is the reason for not defining a
> separate format for JSON-LD? Separate formats ("application/json" and
> "application/ld+json") have previously been defined.
> 
> Nits/editorial comments:
> 
> Q3: The document has long sentences like "One serializes links in the same
> format as used in HTTP the Link header field". Couldn't one just say "based on
> the syntax of the HTTP Link header field", or something like that?
> 
> Q4: The document talks about "document format". People familiar with HTTP are
> probably familiar with that terminology, but I think it would be good to add a
> reference on first occurrence.
> 
> Q5: In Section 1, you talk about serializing links as JSON objects. Should it
> be JSON strings, or something? JSON object is not a serialization.
> 
> 
> _______________________________________________
> Gen-art mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/gen-art

---

From: "Salz, Rich" <[email-masked]>
Date: Tue, 1 Mar 2022 15:31:15 +0000

Just for the record, the linkset draft is now proposed standard, based on the issue Christer raised.

On 3/1/22, 9:57 AM, "Lars Eggert" <[email-masked]> wrote:

    Lars