Subject: [Gen-art] Genart last call review of draft-ietf-lisp-vendor-lcaf-09

From: Christer Holmberg via Datatracker <[email-masked]>
Date: Mon, 11 Apr 2022 13:35:34 -0700

Reviewer: Christer Holmberg
Review result: Ready with Issues

I am the assigned Gen-ART reviewer for this draft. The General Area
Review Team (Gen-ART) reviews all IETF documents being processed
by the IESG for the IETF Chair.  Please treat these comments just
like any other last call comments.

For more information, please see the FAQ at

<https://trac.ietf.org/trac/gen/wiki/GenArtfaq>.

Document: draft-ietf-lisp-vendor-lcaf-09
Reviewer: Christer Holmberg
Review Date: 2022-04-11
IETF LC End Date: 2022-04-12
IESG Telechat date: Not scheduled for a telechat

Summary:

The document is well written, and easy to read and understand. However, I do
have a couple of issues.

Major issues:

Q1:

I do wonder why the document is published as Experimental, however, due to the
following reasons:

   a)

   The document defines usage of the Type value 255.

   b)

   Section 3 says:

      "If a LISP device receives a LISP message containing a Vendor Specific
       LCAF with an OUI that it does not understand, it MUST drop the
       message and it SHOULD create a log message."

   This sounds like an update to LISP.

   c)

   Section 3 defines new header fields.

Minor issues:

N/A

Nits/editorial comments:

Q2:

Section 1 says:

   “The Vendor Specific LCAF allows organizations to create
   LCAF addresses to be used only internally on particular LISP
   deployments.”

Is “allows” the best wording? Where organizations previously disallowed to do
this?

Would it be more correct to say “defines how organizations can create…”?

---

From: Luigi Iannone <[email-masked]>
Date: Tue, 12 Apr 2022 09:14:23 +0200

Hi Christer,

Thanks for the review.

As a shepherd I have a couple of comments inline.

> On 11 Apr 2022, at 22:35, Christer Holmberg via Datatracker <[email-masked]> wrote:
> 

It is experimental because is an update to RFC 8060, which is experimental.
So unless we move that one to standard track I would say that is the right type of RFC.

>   This sounds like an update to LISP.

Excellent point. Actually this document updates RFC 8060, and this should be stated in the document.

> Would it be more correct to say “defines how organizations can create…”?

Yes, this wording is more correct.

Ciao

L.

---

From: "Alberto Rodriguez-Natal (natal)" <[email-masked]>
Date: Tue, 12 Apr 2022 08:42:19 +0000

Hi Christer, Luigi,

Thanks for the review Christer. I agree with your comments and with Luigi’s suggestions. We’ll edit the draft to include the feedback in the next iteration.

Thanks!
Alberto

From: Luigi Iannone <[email-masked]>
Date: Tuesday, April 12, 2022 at 9:15 AM
To: Christer Holmberg <[email-masked]>
Cc: [email-masked] <[email-masked]>, [email-masked] <[email-masked]>, [email-masked] <[email-masked]>, [email-masked] <[email-masked]>
Subject: Re: Genart last call review of draft-ietf-lisp-vendor-lcaf-09
Hi Christer,

Thanks for the review.

Ciao

L.

---

From: Christer Holmberg <[email-masked]>
Date: Tue, 12 Apr 2022 10:09:02 +0000

Hi,

Thanks for addressing my comments, and for explaining the reason for Experimental :)

Regards,

Christer

-----Original Message-----
From: Luigi Iannone <[email-masked]> 
Sent: tiistai 12. huhtikuuta 2022 10.14
To: Christer Holmberg <[email-masked]>
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: Re: Genart last call review of draft-ietf-lisp-vendor-lcaf-09

Hi Christer,

Thanks for the review.

> Review Team (Gen-ART) reviews all IETF documents being processed by 
> the IESG for the IETF Chair.  Please treat these comments just like 
> any other last call comments.
> 
> The document is well written, and easy to read and understand. 
> However, I do have a couple of issues.
> 
> Major issues:
> 
> Q1:
> 
> I do wonder why the document is published as Experimental, however, 
> due to the following reasons:

> Is “allows” the best wording? Where organizations previously 
> disallowed to do this?
> 

Ciao

L.

---

From: Alvaro Retana <[email-masked]>
Date: Wed, 13 Apr 2022 04:27:55 -0700

On April 12, 2022 at 3:14:41 AM, Luigi Iannone wrote:
> > On 11 Apr 2022, at 22:35, Christer Holmberg via Datatracker wrote:

Hi!

Sorry I missed this before.

...
> Excellent point. Actually this document updates RFC 8060, and this should be

The word "updates" has a specific connotation in an RFC.  One
interpretation is that the functionality defined in this document has
to be considered part of the original (rfc8060 in this case).  It also
requires an indication in the header.

The text above talks about what a node that supports this
specification is required to do.  rfc8060-only nodes are not affected.
IOW, the statement above qualifies as a formal update.

The introduction of a new LCAF doesn't require a formal update either
because new LCAFs are defined using the registry.

s/updates/extends/g

Thanks!

Alvaro.