Subject: Re: [Geojson] [draft-geojson] can position "extensions" be non-number values? (#57)

From: Erik Wilde <[email-masked]>
Date: Wed, 2 Dec 2015 09:25:01 +0100

On 2015-12-02 01:57, Sean Gillies wrote:
> I've taken this to the list.

i am fine with the proposal made at 
http://mailarchive.ietf.org/arch/msg/geojson/wfb6Nd0nEHW70EfZmdtvfC0stfQ, and 
this would resolve this issue.

it was one of the issues where i thought that answering obvious 
questions ("can i add non-number values?" "how do i add values if i do 
not have elevation values?") was harder than it should be. i am 
proposing to take this to the extensibility section as well, if the 
ability remains to add number values. then the section should also 
explicitly say that those numbers only can be added if elevation values 
are present.

if the extensibility point gets removed, then this means a breaking 
change (something that previously was valid GeoJSON now isn't anymore). 
i am fine with this as well, if there's consensus to go this way.

speaking in terms of the spec giving implementation guidance: if the 
spec says that there can be extensions, then those should be reported. 
but if they are non-number values, then it seems clear that this should 
result in an error instead. if, on the other hand, the spec disallows 
extensions, then any additional values should probably be ignored 
instead of being reported.

cheers,

dret.

---

From: Allan Doyle <[email-masked]>
Date: Wed, 2 Dec 2015 08:47:01 -0500

I agree with the proposal, and I think “..SHOULD contain no more than 3…” is the best way to put it. 

Even my libertarian side has its limits :)

> On Dec 2, 2015, at 3:25 AM, Erik Wilde <[email-masked]> wrote:
> 
> i am fine with the proposal made at http://mailarchive.ietf.org/arch/msg/geojson/wfb6Nd0nEHW70EfZmdtvfC0stfQ, and this would resolve this issue.
> 
> it was one of the issues where i thought that answering obvious questions ("can i add non-number values?" "how do i add values if i do not have elevation values?") was harder than it should be. i am proposing to take this to the extensibility section as well, if the ability remains to add number values. then the section should also explicitly say that those numbers only can be added if elevation values are present.
> 
> if the extensibility point gets removed, then this means a breaking change (something that previously was valid GeoJSON now isn't anymore). i am fine with this as well, if there's consensus to go this way.
> 
> speaking in terms of the spec giving implementation guidance: if the spec says that there can be extensions, then those should be reported. but if they are non-number values, then it seems clear that this should result in an error instead. if, on the other hand, the spec disallows extensions, then any additional values should probably be ignored instead of being reported.
> 
> cheers,
> 
> dret.
> 
> _______________________________________________
> GeoJSON mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/geojson