Subject: [Geojson] Question on Redundancy

From: Chris Goodman <[email-masked]>
Date: Mon, 3 Jul 2017 01:06:39 +0000

Hello,
In the IETF standard
https://tools.ietf.org/html/rfc7946#section-3.1.6
3.1.6<https://tools.ietf.org/html/rfc7946#section-3.1.6>.  Polygon

   To specify a constraint specific to Polygons, it is useful to

   introduce the concept of a linear ring:

   o  A linear ring is a closed LineString with four or more positions.

   o  The first and last positions are equivalent, and they MUST contain

      identical values; their representation SHOULD also be identical.

The last point is redundant. Why didn't the standard define a LinearRing as a new type and avoid the redundancy?

For example, in an IOT  LoRa network, the low data and small packet size places constraints on the data. The redundancy could be avoided if we assume the closing coordinate has the same values as the first.

Regards, Chris

Chris Goodman
Supervising Consultant
M:  +61 419 482 620
Office:  +61 3 8615 4500
Web: www.objectconsulting.com.au
Email: [email-masked]<mailto:[email-masked]>

---

From: Sean Gillies <[email-masked]>
Date: Thu, 6 Jul 2017 19:27:59 +0200

Hello Chris,

The GeoJSON authors and working group didn't identify a use case for a
linear ring outside the context of a polygon and did not define the type.

I would have to go back through the archives to see why redundancy was
settled upon, but I suspect it had to do with a desire to distinguish
between closed curves and curves accidentally left open.

I hope this helps,

On Mon, Jul 3, 2017 at 3:06 AM, Chris Goodman <
[email-masked]> wrote:

> Hello, In the IETF standard https://tools.ietf.org/html/
> rfc7946#section-3.1.6 3.1.6
> <https://tools.ietf.org/html/rfc7946#section-3.1.6>.  Polygon
>
>
>
>
>
> The last point is redundant. Why didn’t the standard define a LinearRing
> as a new type and avoid the redundancy?
>
>
>
> For example, in an IOT  LoRa network, the low data and small packet size
> places constraints on the data. The redundancy could be avoided if we
> assume the closing coordinate has the same values as the first.
>
>
>
> Regards, Chris
>
>
>
>
>
> *Chris Goodman*
>
> Supervising Consultant
> M:  +61 419 482 620 <+61%20419%20482%20620>
>
> Office:  +61 3 8615 4500 <+61%203%208615%204500>
>
> Web: *www.objectconsulting.com.au <http://www.objectconsulting.com.au>*
>
> Email: [email-masked]
>
>
>
> _______________________________________________
> GeoJSON mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/geojson
>
>

-- 
Sean Gillies

---

From: Chris Goodman <[email-masked]>
Date: Thu, 6 Jul 2017 23:51:51 +0000

Hi Sean,
Thanks for the background. That makes sense.
Regards, Chris

From: Sean Gillies [mailto:[email-masked]]
Sent: Friday, 7 July 2017 3:28 AM
To: Chris Goodman <[email-masked]>
Cc: [email-masked]
Subject: Re: [Geojson] Question on Redundancy

Hello Chris,
The GeoJSON authors and working group didn't identify a use case for a linear ring outside the context of a polygon and did not define the type.
I would have to go back through the archives to see why redundancy was settled upon, but I suspect it had to do with a desire to distinguish between closed curves and curves accidentally left open.
I hope this helps,

On Mon, Jul 3, 2017 at 3:06 AM, Chris Goodman <[email-masked]<mailto:[email-masked]>> wrote:
Hello,
In the IETF standard
https://tools.ietf.org/html/rfc7946#section-3.1.6
3.1.6<https://tools.ietf.org/html/rfc7946#section-3.1.6>.  Polygon

The last point is redundant. Why didn’t the standard define a LinearRing as a new type and avoid the redundancy?

Regards, Chris

Chris Goodman
Supervising Consultant
M:  +61 419 482 620<tel:+61%20419%20482%20620>
Office:  +61 3 8615 4500<tel:+61%203%208615%204500>
Web: www.objectconsulting.com.au<http://www.objectconsulting.com.au>
Email: [email-masked]<mailto:[email-masked]>

_______________________________________________
GeoJSON mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/geojson

--
Sean Gillies