Subject: [Geojson] GeoJSON proposal

From: "Pollok, Andrew" <[email-masked]>
Date: Thu, 6 Feb 2020 10:30:43 +0000

Hello geojson aficionados,

I'm looking to propose extending RFC7946 to allow FeatureCollection to have a 'properties' key, very similar to how Feature has. This will allow FeatureCollection to have useful metadata surrounding the collection for use by certainly my service, but hopefully others too.

Thanks,
Andrew Pollok

________________________________

This email is intended solely for the recipient. It may contain privileged, proprietary or confidential information or material. If you are not the intended recipient, please delete this email and any attachments and notify the sender of the error.
To find out how information about you will be used, please see our updated Privacy Policy.<https://www.woodmac.com/privacy-policy/>

---

From: Martin Daly <[email-masked]>
Date: Thu, 6 Feb 2020 12:23:50 +0000

Andrew,

> I'm looking to propose extending RFC7946 to allow FeatureCollection to have
> a 'properties' key, very similar to how Feature has. This will allow
> FeatureCollection to have useful metadata surrounding the collection for use
> by certainly my service, but hopefully others too.

Is there a reason not to use a "foreign member" (https://tools.ietf.org/html/rfc7946#page-15)?

eg

{
       "type": "FeatureCollection",
       "features": [...],
        "metadata": {...}
}

Martin

---

From: "Pollok, Andrew" <[email-masked]>
Date: Fri, 7 Feb 2020 09:15:37 +0000

This seems a great match for our use case. I should have read the RFC closer, my apologies

thanks for the help,
Andrew Pollok

-----Original Message-----
From: Martin Daly <[email-masked]>
Sent: 06 February 2020 12:24
To: Pollok, Andrew <[email-masked]>; [email-masked]
Subject: RE: GeoJSON proposal

Andrew,

> I'm looking to propose extending RFC7946 to allow FeatureCollection to
> have a 'properties' key, very similar to how Feature has. This will
> allow FeatureCollection to have useful metadata surrounding the
> collection for use by certainly my service, but hopefully others too.

Is there a reason not to use a "foreign member" (https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_rfc7946-23page-2D15-29-3F&d=DwIFAg&c=birp9sjcGzT9DCP3EIAtLA&r=0S_5v1fu4MESM35VYvk4zCKcFX7mt5XKiqMjVCOgktk&m=I5ZoO3ch_dYTnSpcfpgb4n34X_sC3ly8tQ30HVM6Hvg&s=AL9CggKfw2N2FOXOyQOACwaG7ytTK9pQb94b8xGbgUQ&e=

eg

{

Martin