Subject: Re: [Geojson] Question regarding position definition in RFC 7946 vs. ISO 6709 / RFC 5870

From: Martin Daly <[email-masked]>
Date: Fri, 1 May 2020 08:28:29 +0000

Hi Florian,

Assuming that your question is “why does GeoJSON coordinate order contradict ISO 6709 coordinate order?”, then the answer is: because it does.

The decision was taken in full possession of the facts, not lightly, or without regard to the consequences. There are *extensive* email exchanges on lists.geojson.org, if you like that kind of thing. This response, from Howard, is more or less definitive (albeit replying to slightly different questions):

http://lists.geojson.org/pipermail/geojson-geojson.org/2013-April/000707.html

Martin

From: GeoJSON [mailto:[email-masked]] On Behalf Of Florian Wolff
Sent: 30 April 2020 16:52
To: [email-masked]
Subject: [Geojson] Question regarding position definition in RFC 7946 vs. ISO 6709 / RFC 5870

I stumbled across this definitions years after publication, however please excuse the following question as GeoJSON specifies

   A position is an array of numbers.  There MUST be two or more

   elements.  The first two elements are longitude and latitude, or

   easting and northing, precisely in that order and using decimal

   numbers.

while according to ISO 6709 Standard representation of geographic point location by coordinate and RFC 5870 the order of coordinates is

  1.  First horizontal coordinate (y), such as latitude (negative number south of equator and positive north of equator)
  2.  Second horizontal coordinate (x), such as longitude (negative values west of Prime Meridian and positive values east of Prime Meridian)

With best regards,

Florian.

---

From: Florian Wolff <[email-masked]>
Date: Mon, 4 May 2020 16:11:58 +0200

Hi Martin,

thank you very much for guessing and answering my question. This was 
exactly what I was looking for - the "good old philosophical" 
discussions if a point should be expressed as x,y or y,x (which in turn 
translates into y=lat/x=long).

Florian.

Am 01.05.2020 um 10:28 schrieb Martin Daly:
> Hi Florian,
> 
> Assuming that your question is “why does GeoJSON coordinate order 
> contradict ISO 6709 coordinate order?”, then the answer is: because it does.
> 
> The decision was taken in full possession of the facts, not lightly, or 
> without regard to the consequences. There are **extensive** email 
> exchanges on lists.geojson.org, if you like that kind of thing. This 
> response, from Howard, is more or less definitive (albeit replying to 
> slightly different questions):
> 
> *From:*GeoJSON [mailto:[email-masked]] *On Behalf Of *Florian 
> Wolff
> *Sent:* 30 April 2020 16:52
> *To:* [email-masked]
> *Subject:* [Geojson] Question regarding position definition in RFC 7946 
> vs. ISO 6709 / RFC 5870
> 
> I stumbled across this definitions years after publication, however 
> please excuse the following question as GeoJSON specifies
> 
>     A position is an array of numbers.  There MUST be two or more||
> 
>     elements.  The first two elements are longitude and latitude, or||
> 
>     easting and northing, precisely in that order and using decimal||
> 
>     numbers.
> 
> while according to ISO 6709 Standard representation of geographic point 
> location by coordinate and RFC 5870 the order of coordinates is
> 
>  1. First horizontal coordinate (y), such as latitude (negative number
>     south of equator and positive north of equator)
>  2. Second horizontal coordinate (x), such as longitude (negative values
>     west of Prime Meridian and positive values east of Prime Meridian)
> 
> With best regards,
> 
> Florian.
>