Subject: RE: Requirements Document

From: "Rosen, Brian" <[email-masked]>
Date: Fri, 24 Aug 2001 08:22:47 -0400

I'm sorry, but if this group can't generate a solution
for emergency calls in a SIP environment, we need to
spin up a group RIGHT NOW for that purpose.

I do not read the charter as anywhere near that limiting.
In fact, I read it as it will define an object suitable for
a wide range of uses, and illustrate it with HTTP.

Chairs, could we have some guidance?

Brian

> -----Original Message-----
> From: John W Noerenberg II [mailto:[email-masked]]
> Sent: Thursday, August 23, 2001 6:38 PM
> To: Rosen, Brian
> Cc: [email-masked]
> Subject: RE: Requirements Document
> 
> 
> At 9:34 AM -0400 8/23/01, Brian Rosen wrote:
> >Well the charter is fixed.  The requirements have to be applicable to
> >a broad spectrum of use cases.
> 
> Certainly our goal is the protocol will be broadly applicable.  But 
> you can't get there by trying to account for every possible use.  It 
> is impossible to imagine all the potential applications.  That is a 
> guarantee this group will simply flail.  First, find a problem you 
> can solve.  We've decided to focus on HTTP and HTML.  Once we have 
> experience incorporating privacy considerations of location 
> information into those protocols, then we have a basis to generalize 
> to other situations.
> -- 
> 
> john noerenberg
> [email-masked]
>    
> --------------------------------------------------------------
> ------------
>    Peace of mind isn't at all superficial, really.  It's the 
> whole thing.
>    That which produces it is good maintenance; that which disturbs it
>    is poor maintenance.
>    -- Zen and the Art of Motorcycle Maintenance, Robert M. 
> Pirsig, 1974
>    
> --------------------------------------------------------------
> ------------
>

---

From: [email-masked]
Date: Fri, 24 Aug 2001 11:40:25 -0700 (PDT)

> spin up a group RIGHT NOW for that purpose.

Given the difficulty this group had getting chartered, there's precious little
chance of chartering such a group, regardless of how urgent you believe the
need for such a group to be. So I strongly recommend that you try and work
towards getting an acceptable solution here.

> a wide range of uses, and illustrate it with HTTP.

The primary goal is to meet the privacy and security requirements set forth in
the charter. This is absolute and nonnegotiable, and while this group may elect
to (and IMO should) provide mechanisms for emergency calls, a broader range of
scenarios much be dealt with as well.

A secondary goal is to produce a binding of the object/exchange mechanism this
group comes up with to HTTP.

I suppose it is possible that whatever this group decides is necessary
isn't well matched to HTTP. If that's the case then so be it -- privacy
and security concerns are paramount here.

				Ned