Subject: RE: [Geopriv] Location objects

From: "James M. Polk" <[email-masked]>
Date: Sat, 07 Feb 2004 16:16:11 -0600

At 01:36 PM 1/27/2004 -0500, Abbott, Nadine B. wrote:
>An excellent suggestion.
>
>In discussions with the National Emergency Number Association last fall, the
>idea of having the source of the location information identified had strong
>support.
>It might be useful (although perhaps not practical, given the limitations of
>the DHCP signaling) to include an identifier/contact information for the
>provider of the source location information, e.g., XYZ Wireless or ABC Map
>Co, or maybe a URI for the same.

This would necessitate an accompanied digital signature from who is 
asserting this valid location information - which needs to be checked 
somewhere - before believing it. This makes things a bit more complicated - 
and I can come up with a list of questions to this idea:

- If this signature fails, is the call completed?
- Is the location trusted?
- Is anyone dispatched before some other location information can be verified?
- How do all the PSAP databases get records of these digital signatures to 
match the inbound location organization assertion to?
- How often do they get them (meaning: how often is the local database 
updated)?
- How does this work internationally?
- How does this work with an non-US SIP device (traveler with a laptop) 
connected to a US network (maybe a Starbucks or in an airport)?

This is not meant as an attack on the idea, just opening up a lot of 
questions that ought to be looked into for this initial request above.

>Nadine Abbott
>
>-----Original Message-----
>From: [email-masked] [mailto:[email-masked]] On Behalf Of
>Henning Schulzrinne
>Sent: Tuesday, January 27, 2004 1:20 PM
>To: [email-masked]
>Subject: [Geopriv] Location objects
>
>
>In many scenarios, there will be multiple sources of location
>information. I think it would be useful to label location data with an
>optional enumerated (not free text) source identifier, such as
>    GPS
>    A-GPS
>    802.11 triangulation
>    manual configuration
>    location beacon
>    geocoded (e.g., translated from geo to civil or vice versa)
>
>There will be odd-ball scenarios that don't fit into any list of
>categories, but I suspect that the vast majority will be drawn from a
>relatively short and IANA-extensible list.
>
>This allows systems processing this information to make better decisions
>when they get conflicting information, for example. By making the label
>explicit, we can then also make this part of the privacy rules.
>
>Henning
>
>_______________________________________________
>Geopriv mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/geopriv
>
>_______________________________________________
>Geopriv mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/geopriv

cheers,
James

                                *******************
                 Truth is not to be argued... it is to be presented

_______________________________________________
Geopriv mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/geopriv

---

From: "Mark Lewis" <[email-masked]>
Date: Sun, 8 Feb 2004 16:05:34 -0500

Folks,

Hope I didn't dredge up something from the past. The "credibility" field can
be used to put some sort of value (or weight) on the type of location
determination technology the client received it's information from, since
there may be situations where the client's location can be both sent to the
client (DHCP) and determined via some other technology (SNMP and Call Server
registration event) it would allow the VoIP provider (or Enterprise) to
decide (based on the "credibility" of the technology) which information to
use.

I'm not suggesting that a specific scale or weighted value be written into
any RFC published by this group but consideration for a field to populate
with the data, call it a user defined field or call my crazy.

MDL

-----Original Message-----
From: James M. Polk [mailto:[email-masked]] 
Sent: Saturday, February 07, 2004 4:00 PM
To: Henning Schulzrinne; Lewis, Mark [SCH:3065:EXCH]
Cc: [email-masked]'
Subject: Re: [Geopriv] Location objects

At 03:29 PM 2/7/2004 -0500, Henning Schulzrinne wrote:
>Mark,
>
>how are you going to evaluate credibility on a linear scale?

I'm also at a loss as to how this would be done - and you're not the first 
to suggest this

>  I wish we had this for humans :-)

no kidding

>Henning
>
>Mark Lewis wrote:
>
>>I would also submit that an additional "field" that provides a value
>>indicating the "credibility" of the location information. This would be 
>>useful when location is determined from multiple sources.
>>Mark Lewis
>
>
>[email-masked] https://www1.ietf.org/mailman/listinfo/geopriv

cheers,
James

                                *******************