Subject: Re: [Geopriv] Location objects

From: [email-masked]
Date: Sun, 08 Feb 2004 22:37:18 -0500

I will be relaying this string to the NENA VoIP Operations Committee for review and input. For those attending the upcoming  March technical and operations development conferences, this might be another on a long list of discussion items needing additional discussion and input involving technical and operational committee members.

I remain hopeful that we can get more participation and involvement of emergency services access operational representatives worldwide into this process.  

Rick Jones

In a message dated 2/7/2004 5:16:11 PM Eastern Standard Time, [email-masked] writes:

> 
> 
> At 01:36 PM 1/27/2004 -0500, Abbott, Nadine B. wrote:
> >An excellent suggestion.
> >
> >In discussions with the National Emergency Number Association last fall, the
> >idea of having the source of the location information identified had strong
> >support.
> >It might be useful (although perhaps not practical, given the limitations of
> >the DHCP signaling) to include an identifier/contact information for the
> >provider of the source location information, e.g., XYZ Wireless or ABC Map
> >Co, or maybe a URI for the same.
> 
> This would necessitate an accompanied digital signature from who is 
> asserting this valid location information - which needs to be checked 
> somewhere - before believing it. This makes things a bit more complicated - 
> and I can come up with a list of questions to this idea:
> 
> - If this signature fails, is the call completed?
> - Is the location trusted?
> - Is anyone dispatched before some other location information can be verified?
> - How do all the PSAP databases get records of these digital signatures to 
> match the inbound location organization assertion to?
> - How often do they get them (meaning: how often is the local database 
> updated)?
> - How does this work internationally?
> - How does this work with an non-US SIP device (traveler with a laptop) 
> connected to a US network (maybe a Starbucks or in an airport)?
> 
> This is not meant as an attack on the idea, just opening up a lot of 
> questions that ought to be looked into for this initial request above.
> 
> 
> >Nadine Abbott
> >
> >-----Original Message-----
> >From: [email-masked] [mailto:[email-masked]] On Behalf Of
> >Henning Schulzrinne
> >Sent: Tuesday, January 27, 2004 1:20 PM
> >To: [email-masked]
> >Subject: [Geopriv] Location objects
> >
> >
> >In many scenarios, there will be multiple sources of location
> >information. I think it would be useful to label location data with an
> >optional enumerated (not free text) source identifier, such as
> >    GPS
> >    A-GPS
> >    802.11 triangulation
> >    manual configuration
> >    location beacon
> >    geocoded (e.g., translated from geo to civil or vice versa)
> >
> >There will be odd-ball scenarios that don't fit into any list of
> >categories, but I suspect that the vast majority will be drawn from a
> >relatively short and IANA-extensible list.
> >
> >This allows systems processing this information to make better decisions
> >when they get conflicting information, for example. By making the label
> >explicit, we can then also make this part of the privacy rules.
> >
> >Henning
> >
> >_______________________________________________
> >Geopriv mailing list
> >[email-masked]
> >https://www1.ietf.org/mailman/listinfo/geopriv
> >
> >_______________________________________________
> >Geopriv mailing list
> >[email-masked]
> >https://www1.ietf.org/mailman/listinfo/geopriv
> 
> 
> cheers,
> James
> 
>                                *******************
>                 Truth is not to be argued... it is to be 
> presented
> 
> 
> _______________________________________________
> Geopriv mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/geopriv 

_______________________________________________
Geopriv mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/geopriv

---

From: Henning Schulzrinne <[email-masked]>
Date: Sun, 08 Feb 2004 22:52:09 -0500

This problem is no different than signing any of the other location 
elements. If the geospatial or civil information or the source 
information is not signed, you have to trust the chain of nodes along 
the way, but source information does not seem fundamentally different.

---

From: "James M. Polk" <[email-masked]>
Date: Sun, 08 Feb 2004 22:55:33 -0600

At 10:52 PM 2/8/2004 -0500, Henning Schulzrinne wrote:

>elements. If the geospatial or civil information or the source information 
>is not signed, you have to trust the chain of nodes along the way, but 
>source information does not seem fundamentally different.

no, it is not. There is just a problem with asserting trust...

>>>somewhere - before believing it. This makes things a bit more 
>>>complicated - and I can come up with a list of questions to this idea:
>>>
>>>- How do all the PSAP databases get records of these digital signatures 
>>>to match the inbound location organization assertion to?
>>>                Truth is not to be argued... it is to be presented
>>>
>>>

cheers,
James

                                *******************
                 Truth is not to be argued... it is to be presented