Subject: RE: [Geopriv] Consensus call on <provided-by>

From: "Abbott, Nadine B." <[email-masked]>
Date: Thu, 8 Apr 2004 13:59:53 -0400

Well, if that proves to be a problem,
With only minor tweaking, the content of the proposed NENA XML schema input
is "internationalizable" in that it basically just includes one or all of
three identifiers for contacting the provider of the location information:
A national emergency number authority identifier (if any)
A 24x7 contact number indicated in a tel.uri 
A URL

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Rosen, Brian
Sent: Thursday, April 08, 2004 9:00 AM
To: [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: RE: [Geopriv] Consensus call on <provided-by>

I think it's a technical punt on time grounds,  but I can live with it.  It
has a real unfortunate "political" problem, which is that the only proposed
entry in the name space is a North American solution.

Brian

> -----Original Message-----
> From: Allison Mankin [mailto:[email-masked]]
> Sent: Tuesday, April 06, 2004 10:39 PM
> To: [email-masked]
> Cc: [email-masked]; [email-masked]; [email-masked]; 
> [email-masked]
> Subject: [Geopriv] Consensus call on <provided-by>
> 
> 
> 
> We're a ways past the end of the wglc on pidf-lo, so we'd like to call 
> consensus on this discussion of <provided-by> and move pidf-lo 
> forward.
> 
> The original text from James and company added the <provided-by> 
> element alone.  It offered a discussion of the risks and privacy 
> concerns related to the URI following this element.  Ted Hardie, as 
> our Area Director, noted that a general URI here would continue to be 
> unacceptable, because of the potential for unresolvable forms or even 
> harmful forms.
> 
> Following discussion on the list, Andy proposed adding an XML
> namespace
> for <provided-by>.  Under an XML namespace design, the objections
> to the general URI are gone. 
> 
> Could people send in their thoughts and comments on the XML namespace 
> proposal for <provided-by>?  Please send in thoughts if you are in 
> support of it, as well as if you have issues with it.  If you have 
> issues with it, what would work in its place, since a general URI will 
> not meet community review standards, as our AD has told us?
> 
> Allison
> 
> _______________________________________________
> Geopriv mailing list
> [email-masked] https://www1.ietf.org/mailman/listinfo/geopriv
> 

_______________________________________________
Geopriv mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/geopriv

_______________________________________________
Geopriv mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/geopriv

---

From: Allison Mankin <[email-masked]>
Date: Thu, 08 Apr 2004 17:10:03 -0700

Brian, Nadine,

As far as populating the XML namespace registry for <provided-by> 
with only a North American namespace to begin with, there are a few
points:

1. any other emergency organization in the world can request to register
   their namespace.  If others are known now, their namespaces do not
   need to appear in the document, but their intention to register
   could be mentioned (but they should speak up).

2. when Jon Peterson revs the document, my suggestion is that the
   NENA XML schema will be in a non-normative appendix.  The actual
   registration for NENA will not require this document.  Publishing
   the schema here will be of value to give an example to other emergency
   organizations for their future registration.

Allison

P.S. Any more comments from others?