Subject: RE: [Geopriv] a proposal for <provided-by>

From: "Abbott, Nadine B." <[email-masked]>
Date: Fri, 2 Apr 2004 17:16:34 -0500

Andy,
Seems reasonable.
Can you direct me to instructions for NENA to request inclusion in the IANA
registry?
Is there something new that would have to be created for this particular
element? 
Thanks,
Nadine

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Andrew Newton
Sent: Friday, April 02, 2004 12:40 PM
To: [email-masked]
Subject: [Geopriv] a proposal for <provided-by>

I have the following proposal for <provided-by>:

This element should contain an unbounded sequence of elements in other 
namespaces from a schema perspective.  It would look like this:

     <sequence>
       <any
         namespace="##other"
         processContents="skip"
         minOccurs="1"
         maxOccurs="unbounded" />
     </sequence>

The allowed namespaces will be governed by an IANA registry.  The 
registry will have expert reviewers and will initially be populated 
with a namespace for NENA (should be a simple schema associated with 
it).

This has the following advantage:
    1) interpretation of the provided-by information is much more 
specific allowing better interoperability
    2) the can be more than one set of provided-by information
    3) new sets of information go through a review process to insure 
they do not violate the spirit of GEOPRIV

-andy

_______________________________________________
Geopriv mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/geopriv

_______________________________________________
Geopriv mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/geopriv

---

From: Andrew Newton <[email-masked]>
Date: Fri, 2 Apr 2004 17:49:21 -0500

> Can you direct me to instructions for NENA to request inclusion in the 

Jon will have to set that up.  But he's got a lot of IANA work to do. :)
My proposal is that the PIDF-LO spec would have the registration for 
NENA in it.

> Is there something new that would have to be created for this 

The schema you provided seems to work.

-andy