Subject: Re: [Ecrit] RE: [Geopriv] Announcement of Joint GEOPRIV/ECRIT InterimMeeting

From: Henning Schulzrinne <[email-masked]>
Date: Wed, 20 Apr 2005 21:39:37 -0400

Brian Rosen wrote:
> Actually, there are quite a few ways that DSL systems work, and they don't
> always use PPP.  It would work for many deployments, but not all.

I've only seen DHCP or PPP (for PPPoE) systems for IP address assignment 
in DSL. What else is there?

_______________________________________________
Geopriv mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/geopriv

---

From: "Brian Rosen" <[email-masked]>
Date: Thu, 21 Apr 2005 08:48:09 -0400

L2TP and static assignments I am told.

Having said that, does L2TP assign IP addresses within the tunnel with PPP?
Always?

Brian

> -----Original Message-----
> From: Henning Schulzrinne [mailto:[email-masked]]
> Sent: Wednesday, April 20, 2005 9:40 PM
> To: Brian Rosen
> Cc: 'Michael Hammer (mhammer)'; [email-masked]; 'GEOPRIV WG';
> [email-masked]
> Subject: Re: [Ecrit] RE: [Geopriv] Announcement of Joint GEOPRIV/ECRIT
> InterimMeeting
> 
> Brian Rosen wrote:

---

From: Henning Schulzrinne <[email-masked]>
Date: Thu, 21 Apr 2005 08:57:07 -0400

> Having said that, does L2TP assign IP addresses within the tunnel with PPP?

As far as I know, L2TP itself has no address assignment capabilities, at 
least according to RFC 2661. Given that it is a 'layer-2 tunneling 
protocol', that also makes sense - layer 2 being something like PPP.

As long as PPP is used, static assignment would not seem to rule out use 
of PPP for conveying location references or values.