Subject: AW: [Geopriv] WGLC ondraft-ietf-geopriv-location-types-registry-03.txt

From: "Tschofenig, Hannes" <[email-masked]>
Date: Wed, 17 Aug 2005 09:49:10 +0200

hi john, 

andy was faster and gave you comments to most of your questions/comments already. 

a few additional minor comments below:  

> -----Ursprüngliche Nachricht-----
> Von: [email-masked] 
> [mailto:[email-masked]] Im Auftrag von John Schnizlein
> Gesendet: Mittwoch, 17. August 2005 00:19
> An: Andrew Newton
> Cc: GEOPRIV WG
> Betreff: Re: [Geopriv] WGLC 
> ondraft-ietf-geopriv-location-types-registry-03.txt
> 
> 
> Shouldn't the purpose of this location-types-registry be included in 
> the document?

i thought that the following sentence said already everything:

"
This document creates a registry for location types.  
"

if you have a better text please let us know. 

>  In particular, what is the relationship 
> between this and 
> the statement in draft-ietf-geopriv-dhcp-civil-06 that "Thus, this 
> draft establishes an IANA registry for civic location data fields. "?
> 
> Pending clarification of the above, it seems premature to 
> press forward 
> with WG last call on an IANA registry of this sort when there is a 
> DISCUSS in the IESG review of draft-ietf-geopriv-dhcp-civil-06 
> questioning this sort of structured addresses:
>   "Since these addresses are mostly intended for human use (emergency
>    workers) who know the local context, why not have a completely non
>    predescribed field for an adress? This also solves the problem for
>    other useful info as: 'room: 1:123', or cubicle 450D.
>    In addition, many addresses especially in rural areas are not only
>    non-standard, they also can describe a rather large area where the
>    user needs a human readable field to make it somewhat more clear to
>    where to find the user, for example, when entering the farm, look
>    for the building with the red roof."
> Wouldn't it be better to resolve the substantive question of the iESG 
> first?
i don't see the location-types-registry being dependent on the dhcp-civic draft. 

> Since these types are all English words, what provision is made for 
> other languages?

there was no plan from our side to translate these terms into many different languages. 

> 
> The abstract and introduction appear to be identical, is this 
> acceptable form for an RFC?

good question. we previously wanted to use a one-line abstract but then our draft bounced back. 

ciao
hannes

> 
> On Aug 16, 2005, at 4:47 PM, Andrew Newton wrote:
> > All,
> >
> > Today starts a 2 week working group last call on 
> > draft-ietf-geopriv-location-types-registry-03.txt.
> > Please send your comments and/or questions to this mailing list no 
> > later than 30 August 2005.
> >
> > -andy
> 
> _______________________________________________
> Geopriv mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/geopriv
> 

_______________________________________________
Geopriv mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/geopriv

---

From: John Schnizlein <[email-masked]>
Date: Wed, 17 Aug 2005 07:08:40 -0400

On Aug 17, 2005, at 3:49 AM, Tschofenig, Hannes wrote:
>>
>> Von: [email-masked] [mailto:[email-masked]] Im 
>> Auftrag von John Schnizlein
>>
> "This document creates a registry for location types.  "
>

The cited text states the purpose of the document, not the purpose of 
the registry.
It seems that a simple statement of why this registry is needed should 
be in the document.

>>  In particular, what is the relationship between this and
>> Pending clarification of the above, it seems premature to press
>>
>> forward with WG last call on an IANA registry of this sort when there
>>  is a DISCUSS in the IESG review of draft-ietf-geopriv-dhcp-civil-06

While no dependency is intended, I would hope that it is clear that the 
same question applies.

> there was no plan from our side to translate these terms into many 

I suspect that an English-only registration of terms would be a problem 
for the global Internet.

John