Subject: RE: [Geopriv] Making decisions based on location information

From: "Martin Thomson" <[email-masked]>
Date: Wed, 3 Aug 2005 02:45:32 +1000

> 
> > memory, but the order of magnitude is correct) based on the 
> fact that
> > the uncertainty is so large.  I believe that a 
> recommendation is beneficial.
> 
> The FCC already makes a "recommendation" (except that that 
> one has real 
> teeth, i.e., lawyers, behind it). It's of the 100m order and 
> depends on 
> the location technology used (see 
> http://www.fcc.gov/911/enhanced/). If 
> we were to recommend a larger value, the FCC and operators would just 
> ignore it. If we suggest a smaller value, it is unclear what 
> impact this 
> would have. As I said in my remarks, nobody is going to artificially 
> lower the resolution for their location-determining equipment for 
> emergency calls, so this essentially just guides a technology 
> choice.

I am aware of the FCC mandate, however, if you read my comments, I am not
talking about emergency routing only.  A recommendation of this nature would
extend to routing applications.

> I 
> don't see how we can make such a technology choice with any degree of 
> authority. Are we going to say that you have to use WAAS with 
> GPS, even 
> though it may not be available in the area you live in?
> 

WAAS isn't an option outside of the US, so I don't know why you would
suggest it.

> The additional problem is that there will be some cases where the 
> location represents not a user or room, but a whole building 
> or campus. 
> If you "require" a resolution below that campus size, you are 
> mandating 
> room-level location - something which is not legally mandated in most 
> countries. You can guess which recommendation providers will pay 
> attention to.

There wasn't any talk about "requiring" anything.  Like any recommendation,
you can only meet it if it is technically feasible.  On the other hand, some
jurisdictions require better than that resolution; I am sure you are aware
of certain states in the US requiring 400 sq. ft. (again the number eludes
me, but you get the drift) minimum resolution.

> 
> Since the same location information is likely to be used for 
> both call 
> routing and dispatch, just worrying about routing is not particularly 
> relevant.
> 

If you look at the cellular case, the same location information is NOT
likely to be used for routing and dispatch.  I don't see why that model is
so irrelevant in this case.  Do a little research and you can discover that
in 15 seconds I can do an assisted GPS fix - obviously not something you
want to do before routing, but certainly very helpful in dispatch.

> > Conversely, the target might decide that certain 
> information might not
> > be pertinent for inclusion in the response, this has already been 
> > agreed, looking at the transforms available in the authorization 
> > policy.  For instance, I might only like to provide very coarse 
> > information to someone I met on the street (I live in 
> Sydney), but that 
> > isn't enough to determine which of the hundreds of pizza 
> stores a call 
> > needs to be routed to. In this case a recommendation 
> provides guidance 
> > to whomever specifies the transformation - that is, don't 
> remove too 
> > much information if you want this to be useful.
> 
> Beyond the patently obvious "if you want your pizza to reach you, 
> country-level information is not likely to be useful (unless 
> you live in 
> Monaco or on Antarctica)", what value would a recommendation have?
> 

Because an implementer is not always across all these issues.  A
recommendation of this nature provides a goal, or a yardstick - precisely
the sort of thing that was requested in ECRIT earlier.

> I don't think padding documents with recommendations that 
> have no sound 
> technical basis, depend on technology choices we don't 
> control and are 
> likely to be overridden by people who actually matter in this 
> discussion 
> serves no purpose except to generate mailing list discussion.
>

You are yet to convince me of any of those statements.
_______________________________________________
Geopriv mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/geopriv

---

From: Henning Schulzrinne <[email-masked]>
Date: Tue, 02 Aug 2005 13:03:16 -0400

> I am aware of the FCC mandate, however, if you read my comments, I am 
> not talking about emergency routing only.  A recommendation of this 
> nature would extend to routing applications.

Then I'm even less sure what this would accomplish, given that the 
requirements may differ even more for other applications. (One could 
argue that pizza delivery has higher requirements since accidents and 
fires tend to announce themselves even if you're 100' away from the 
scene, while your pizza craving is unlikely to be as visible. But other 
location-based routing applications, such as calling an on-demand-bus to 
the nearest bus stop may have lower requirements, since the points of 
service delivery are limited.)

> WAAS isn't an option outside of the US, so I don't know why you would 

It illustrates that a resolution value that might be reasonable or 
desirable within the US is unavailable elsewhere.

> likely to be used for routing and dispatch.  I don't see why that model 
> is so irrelevant in this case.  Do a little research and you can 
> discover that in 15 seconds I can do an assisted GPS fix - obviously not 
> something you want to do before routing, but certainly very helpful in 
> dispatch.

Again, a case where this strongly depends on technology. Unless you 
restrict the technology, you are only going to be able to recommend the 
least-restrictive solution.

> recommendation of this nature provides a goal, or a yardstick - 
> precisely the sort of thing that was requested in ECRIT earlier.
> 

You will see, I believe, that any suggestion of a number will yield 
endless and non-terminable debates as it will be essentially arbitrary. 
The IETF does not do technology requirements - almost never for its own 
technology and never for technology that is outside its scope of influence.

---

From: "Carl Reed OGC" <[email-masked]>
Date: Fri, 5 Aug 2005 09:11:48 -0600

RE: [Geopriv] Making decisions based on location informationWhile it is important to meet the FCC requirements, this will be globally used standard. As such, there are location technologies (including cellular as well as any number of other sensors) that can provide much more accurate coordinates than the 100 m required by the FCC. We have had similar discussions in OASIS WRT the Common Alert Protocol. A requirement for the development of that standard is that we could make no assumptions about either accuracy or precision. Therefore, the specification can handle lat-longs that are accurate to microns (silly now but who knows) to kilometers (who the heck wants a coordinate only accurate to kilos, but you never know!).

Just another perspective.

Carl

  ----- Original Message ----- 
  From: Martin Thomson 
  To: 'Henning Schulzrinne' ; [email-masked] 
  Sent: Tuesday, August 02, 2005 10:45 AM
  Subject: RE: [Geopriv] Making decisions based on location information

  > emergency calls, so this essentially just guides a technology 

  I am aware of the FCC mandate, however, if you read my comments, I am not talking about emergency routing only.  A recommendation of this nature would extend to routing applications.

  > though it may not be available in the area you live in? 

  WAAS isn't an option outside of the US, so I don't know why you would suggest it. 

  > countries. You can guess which recommendation providers will pay 

  There wasn't any talk about "requiring" anything.  Like any recommendation, you can only meet it if it is technically feasible.  On the other hand, some jurisdictions require better than that resolution; I am sure you are aware of certain states in the US requiring 400 sq. ft. (again the number eludes me, but you get the drift) minimum resolution.

  > routing and dispatch, just worrying about routing is not particularly 

  If you look at the cellular case, the same location information is NOT likely to be used for routing and dispatch.  I don't see why that model is so irrelevant in this case.  Do a little research and you can discover that in 15 seconds I can do an assisted GPS fix - obviously not something you want to do before routing, but certainly very helpful in dispatch.

  > Monaco or on Antarctica)", what value would a recommendation have? 

  Because an implementer is not always across all these issues.  A recommendation of this nature provides a goal, or a yardstick - precisely the sort of thing that was requested in ECRIT earlier.

------------------------------------------------------------------------------