Subject: RE: [Geopriv] HELD - Spoofing of IP addresses

From: "Martin Thomson" <[email-masked]>
Date: Fri, 5 Aug 2005 00:31:14 +1000

I have it on good authority that return routability addresses the problem of
address spoofing.  HELD uses return routability, so I fail to see that this
problem is valid.  On the other hand, a clearer statement to that effect may
be beneficial.

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of James M. Polk
> Sent: Thursday, 4 August 2005 4:23 PM
> To: Brian Rosen; 'GEOPRIV'
> Subject: Re: [Geopriv] HELD - Spoofing of IP addresses
> 
> 
> I would add to this comment with the following:
> 
> I would like to see secuity considerations text discussing the 
> ramifications of what happens when IP addresses are spoofed.
> 
> At 09:06 AM 8/1/2005 -0400, Brian Rosen wrote:
> >Discussion of HELD was cut off with a request to bring issues to the 
> >list.
> >
> >One issue I have is that the draft does not discuss spoofing of IP 
> >addresses.  I think that the requirements for deploying this 
> protocol 
> >are difficult to achieve.  I am assured that some networks are 
> >engineered so that spoofing of IP addresses is very difficult if not 
> >impossible.  Without commenting on such assurances, I think 
> the draft 
> >should discuss the issue, and should assert when it is 
> appropriate to 
> >be used with respect to spoofing of IP addresses.
> >
> >Brian
> >
> >
> >
> >
> >
> >_______________________________________________
> >Geopriv mailing list
> >[email-masked] https://www1.ietf.org/mailman/listinfo/geopriv
> 
> 
> cheers,
> James
> 
>                                  *******************
>                  Truth is not to be argued... it is to be presented.
> 
> _______________________________________________
> Geopriv mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/geopriv
> 
_______________________________________________
Geopriv mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/geopriv

---

From: "Brian Rosen" <[email-masked]>
Date: Thu, 4 Aug 2005 11:08:27 -0400

No, return routability doesn't address the problem, it addresses a class of
problems, leaving several classes of problems standing.  A classic MITM
attack assumes you can send and receive packets addressed to both victims.
That's return routable, but not safe.   If you can monitor packets, and
inject packets with any source IP address of your choosing, you can break
HELD.  If the network prevents you from sending a packet with a source IP
address not assigned to you, then the number of attacks is significantly
lessened. 

Brian

  _____  

From: Martin Thomson [mailto:[email-masked]] 
Sent: Thursday, August 04, 2005 10:31 AM
To: 'James M. Polk'; Brian Rosen; 'GEOPRIV'
Subject: RE: [Geopriv] HELD - Spoofing of IP addresses