Subject: RE: [Geopriv] HELD - Spoofing of IP addresses

From: "Martin Thomson" <[email-masked]>
Date: Fri, 5 Aug 2005 01:25:59 +1000

So how does TLS and the provision of server-side certificates not address
those problems (MITM, monitoring, insertion of rogue packets)?

-----Original Message-----
From: Brian Rosen [mailto:[email-masked]] 
Sent: Thursday, 4 August 2005 5:08 PM
To: Thomson, Martin [WOLL:5500:EXCH]; 'James M. Polk'; 'GEOPRIV'
Subject: RE: [Geopriv] HELD - Spoofing of IP addresses

No, return routability doesn't address the problem, it addresses a class of
problems, leaving several classes of problems standing.  A classic MITM
attack assumes you can send and receive packets addressed to both victims.
That's return routable, but not safe.   If you can monitor packets, and
inject packets with any source IP address of your choosing, you can break
HELD.  If the network prevents you from sending a packet with a source IP
address not assigned to you, then the number of attacks is significantly
lessened. 

Brian

_______________________________________________
Geopriv mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/geopriv

---

From: "Brian Rosen" <[email-masked]>
Date: Thu, 4 Aug 2005 11:34:41 -0400

Because the client doesn't authenticate, and it's impersonating a valid
client to get a valid (signed) location object.  A rogue client can get a
location for another party from the HELD server with no credentials.

  _____  

From: Martin Thomson [mailto:[email-masked]] 
Sent: Thursday, August 04, 2005 11:26 AM
To: 'Brian Rosen'; 'James M. Polk'; 'GEOPRIV'
Subject: RE: [Geopriv] HELD - Spoofing of IP addresses

-----Original Message-----
From: Brian Rosen [mailto:[email-masked]] 
Sent: Thursday, 4 August 2005 5:08 PM
To: Thomson, Martin [WOLL:5500:EXCH]; 'James M. Polk'; 'GEOPRIV'
Subject: RE: [Geopriv] HELD - Spoofing of IP addresses

Brian

---

From: Andrew Newton <[email-masked]>
Date: Thu, 4 Aug 2005 11:58:20 -0400

This is spoofing at Layer 7.  It is what enables the spamming  
practice of joe-jobbing and some forms of phishing these days.

I believe Brian is correct.

-andy

On Aug 4, 2005, at 11:34 AM, Brian Rosen wrote:

> Because the client doesn’t authenticate, and it’s impersonating a  
> valid client to get a valid (signed) location object.  A rogue  
> client can get a location for another party from the HELD server  
> with no credentials.