Subject: [Geopriv] PIDF-LO civilLoc schema incomplete

From: "Martin Thomson" <[email-masked]>
Date: Thu, 11 Aug 2005 14:54:43 +1000

The schema definition for the element <civilAddress> is not included in
draft-ietf-geopriv-pidf-lo-03.  How this escaped my notice before is quite a
wonder.

The lesson is perhaps to be careful with schema.  The definition for
<location-info> defines processContents="lax", which instructs a schema
validator to not worry about validating the contents of that element (which
is nice in this case because the GML schema caused Xerces all sorts of
grief).

I don't think that this is necessarily earth shattering, but it is perhaps
worth remembering.

Cheers,
Martin 
_______________________________________________
Geopriv mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/geopriv

---

From: "Carl Reed OGC" <[email-masked]>
Date: Thu, 11 Aug 2005 08:20:39 -0600

PIDF-LO civilLoc schema incompleteIn terms of GML, PIDF-LO should probably be upgraded to use GML 3.1.1 schemas (available on the OGC web site). There were a number of errors in the 3.1 schemas (Sigh) that prevented validation. These have been corrected and the 3.1.1 schemas subsequently tested against a variety of validation tools. 

Cheers

Carl

  ----- Original Message ----- 
  From: Martin Thomson 
  To: GEOPRIV 
  Sent: Wednesday, August 10, 2005 10:54 PM
  Subject: [Geopriv] PIDF-LO civilLoc schema incomplete

  The schema definition for the element <civilAddress> is not included in draft-ietf-geopriv-pidf-lo-03.  How this escaped my notice before is quite a wonder.

  The lesson is perhaps to be careful with schema.  The definition for <location-info> defines processContents="lax", which instructs a schema validator to not worry about validating the contents of that element (which is nice in this case because the GML schema caused Xerces all sorts of grief).

  I don't think that this is necessarily earth shattering, but it is perhaps worth remembering. 

  Cheers, 
  Martin 

------------------------------------------------------------------------------