Subject: AW: [Geopriv] common-policy update

From: "Tschofenig, Hannes" <[email-masked]>
Date: Wed, 12 Oct 2005 21:47:23 +0200

hi henning, 

> A quick comment: I think RFC 2396 uses 'scheme', not 'schema', to 
> designate the type of URI.
ok, fine with me. 

> 
> I didn't see much discussion of tel URIs on my quick scan, but at the 
> level of functionality supported, this is probably unnecessary.
the discussion is missing because we need to re-read the discussion to
make sure that we capture all the issues. 
i think we also need to add something regarding the iana registration. 

ciao
hannes

> 
> Tschofenig, Hannes wrote:
> > hi all, 
> > 
> > we have worked on a draft update that can be found at: 
> > http://www.tschofenig.priv.at/TEMP/geopriv/
> > 
> > this directory contains the text/html files and the xml 
> schema including
> > some instance documents (as examples). 
> > (i used the xml editor oxygen to validate the instance 
> documents against
> > the xml schema. they worked fine.)
> > 
> > the update includes the modified text for the identity 
> condition section
> > and the respective changes throughout the document. this 
> text contains
> > the functionality that was agreed during the paris ietf 
> meeting (with
> > the minor comment that the discussion about the tel uri's was a bit
> > fuzzy and this part might be a bit shaky). 
> > 
> > i will setup an issue tracker (if needed) to make sure that 
> we capture
> > all comments. 
> > 
> > note that we have not yet submitted this draft version. we 
> want todo a
> > document review before we submit it just before the deadline. 
> > 
> > ciao
> > hannes
> > 
> > 
> > _______________________________________________
> > Geopriv mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/geopriv
> 

_______________________________________________
Geopriv mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/geopriv

---

From: Henning Schulzrinne <[email-masked]>
Date: Wed, 12 Oct 2005 16:12:12 -0400

> make sure that we capture all the issues. 

This discussion probably needs to involve SIMPLE; I'm not sure all the 
interested parties hang out in this neighborhood. If I recall, issues 
included:

- Do we want to support things like tel:+49  (for all German callers or 
tel:+1-2*1-555-1212 for all callers in the 201, 212, 222, etc. area 
codes); I think the consensus was that we'd skip this for now.

This implies that <many domain="+49">, for example, would not be 
supported. I don't think this restriction requires a change in the text 
as you have it.

- What does the tel URI mean, in terms of protocol? Does this imply a 
SUBSCRIBE, say, of

From: tel:+1-212-555-1234

(with some appropriate, but unspecified, authentication identity.)

Also, 7.1.3.2 should probably be re-labeled since it describes 
exceptions (except id=) that are individual identities, not whole domains.

> i think we also need to add something regarding the iana registration. 

Probably. Schemes are already registered; what else were you thinking of?