Subject: [Geopriv] multiple values in the scheme and sphere

From: "Tschofenig, Hannes" <[email-masked]>
Date: Tue, 18 Oct 2005 15:12:05 +0200

hi all, 

we had a few examples in the common-policy schema where attributes
contained a list of values, such as

- the scheme attribute of the entity element: 

    <rule id="f3g44r1">
        <conditions>
            <identity>
              <one>
                <entity id="[email-masked]" scheme="sip mailto xmpp"/>
              </one>
            </identity>
        </conditions>
        <actions/>
        <transformations/>
    </rule>

or 

- the value attribute of the sphere element

    <rule id="f3g44r1">
        <conditions>
          <identity/>
          <sphere value="work home"/>
        </conditions>
        <actions/>
        <transformations/>
    </rule>

it would be good to know whether we should
a) allow multiple values in an attribute (in the case of scheme and
sphere/value) or
b) disallow it (i.e., only a single value is allowed)

regarding (b) the consequence is that the above rule has to be rewritten
to 

    <rule id="f3g44r1">
        <conditions>
            <identity>
              <one>
                <entity id="[email-masked]" scheme="sip"/>
                <entity id="[email-masked]" scheme="mailto"/>
                <entity id="[email-masked]" scheme="xmpp"/>
              </one>
            </identity>
        </conditions>
        <actions/>
        <transformations/>
    </rule>

since the <entity> elements are matched as logical 'OR's the
transformation is ok. 

for the sphere example we have two choices:
1) we only allow a single value of sphere in a single rule. 
2) we modify the sphere condition to something like:

    <rule id="f3g44r1">
        <conditions>
          <identity/>
          <sphere>
            <value>work</value>
            <value>home</value>
          </sphere>
        </conditions>
        <actions/>
        <transformations/>
    </rule>

the child elements of the sphere element match if any of the <value>
elements matches. 

i prefer b.2 since it is more consistent with the rest of the
conditions. 
i would like to know what other geopriv members think about it. 

ciao
hannes

_______________________________________________
Geopriv mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/geopriv

---

From: "Thomson, Martin" <[email-masked]>
Date: Wed, 19 Oct 2005 17:34:08 -0500

I tend to think that the list version is good.  It is certainly a good idea to make things consistent.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Tschofenig, Hannes
Sent: Tuesday, 18 October 2005 11:12 PM
To: [email-masked]
Subject: [Geopriv] multiple values in the scheme and sphere

hi all, 

    <rule id="f3g44r1">
        <conditions>
            <identity>
              <one>

or 

    <rule id="f3g44r1">
        <conditions>
          <identity/>

    <rule id="f3g44r1">
        <conditions>
            <identity>
              <one>

    <rule id="f3g44r1">
        <conditions>
          <identity/>
          <sphere>
            <value>work</value>
            <value>home</value>
          </sphere>
        </conditions>
        <actions/>
        <transformations/>
    </rule>

ciao
hannes

------------------------------------------------------------------------------------------------
This message is for the designated recipient only and may
contain privileged, proprietary, or otherwise private information.  
If you have received it in error, please notify the sender
immediately and delete the original.  Any unauthorized use of
this email is prohibited.
------------------------------------------------------------------------------------------------
[mf2]