Subject: RE: AW: [Geopriv] common-policy update

From: "Thomson, Martin" <[email-masked]>
Date: Wed, 12 Oct 2005 22:25:54 -0500

> - What does the tel URI mean, in terms of protocol? Does this imply a 
> SUBSCRIBE, say, of
>
> From: tel:+1-212-555-1234
>
> (with some appropriate, but unspecified, authentication identity.)

I can answer one of these - it's outside the normal IETF domain, but I don't think that it makes it any less relevant.  Authorization policies for location information don't exist in this form elsewhere (to my knowledge), so I can see that this could be adopted to address, for instance, privacy profiles in 3GPP.

So what you could have is some protocol other than SIP being used.  OMA are currently defining such a protocol in PCP.
------------------------------------------------------------------------------------------------
This message is for the designated recipient only and may
contain privileged, proprietary, or otherwise private information.  
If you have received it in error, please notify the sender
immediately and delete the original.  Any unauthorized use of
this email is prohibited.
------------------------------------------------------------------------------------------------
[mf2]

_______________________________________________
Geopriv mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/geopriv

---

From: [email-masked]
Date: Mon, 17 Oct 2005 18:33:31 +0300

Hi Hannes,

Thanks for the updated common-policy draft. I reviewed the Identity Condition section (7.1). Here are the comments:

- In general this is good, I have only some clarifications to make

- I can understand how the logical OR's and AND's work in the examples, but I admit I could not figure it out based on the text in the 2nd paragraph of 7.1.1. The document says: 

   The child element of an identity condition
   (i.e., the <one/> and the <many/> elements defined in this document)
   of a rule matches if all of the conditions match, i.e., the matching
   uses a logical AND.  

I would understand this in a way that if you have e.g. several <one/>'s as children of identity, the condition matches only if ALL of them match. But I know this is not right so either I don't understand the definition or the definition is wrong. 

Should this be something like:

   An identity condition matches if any of its child elements (i.e., the <one/> and the <many/> elements defined in this document) matches with the authenticated identity, i.e., the results of the individual child element matches are combined with a logical OR.

I had similarly problems with the next sentence:

   The child elements of the <one/> and the <many/>
   elements matche if any of them match, i.e., the matching uses a
   logical OR.

I suppose <one/> does not have any child elements, so perhaps it could be left out. How about:

   A <many> element does not match, if any of the <except> elements that are its children matches with the authenticated identity, i.e., the exception results are combined with a logical OR.

- I would rename 7.1.3.2. as 'Matching Any Identity Excepting Enumerated Domains and Identities' and 7.1.3.3. as 'Matching Any Identity Within a Domain Excepting Enumerated Identities'. 

Regards,
	Markus

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On
> Behalf Of ext Tschofenig, Hannes
> Sent: 12 October, 2005 21:55
> To: [email-masked]
> Subject: [Geopriv] common-policy update
> 
> 
> hi all, 
> 
> we have worked on a draft update that can be found at: 
> http://www.tschofenig.priv.at/TEMP/geopriv/
> 
> this directory contains the text/html files and the xml 
> schema including
> some instance documents (as examples). 
> (i used the xml editor oxygen to validate the instance 
> documents against
> the xml schema. they worked fine.)
> 
> the update includes the modified text for the identity 
> condition section
> and the respective changes throughout the document. this text contains
> the functionality that was agreed during the paris ietf meeting (with
> the minor comment that the discussion about the tel uri's was a bit
> fuzzy and this part might be a bit shaky). 
> 
> i will setup an issue tracker (if needed) to make sure that we capture
> all comments. 
> 
> note that we have not yet submitted this draft version. we want todo a
> document review before we submit it just before the deadline. 
> 
> ciao
> hannes
> 
>

---

From: "Tschofenig, Hannes" <[email-masked]>
Date: Fri, 21 Oct 2005 16:39:21 +0200

hi markus, 

i incorporated your suggestions. thanks for the feedback !

ciao
hannes

> -----Ursprüngliche Nachricht-----
> Von: [email-masked] [mailto:[email-masked]] 
> Gesendet: Montag, 17. Oktober 2005 17:34
> An: Tschofenig, Hannes; [email-masked]
> Betreff: RE: [Geopriv] common-policy update
> 
> 
> Hi Hannes,
> 
> Thanks for the updated common-policy draft. I reviewed the 
> Identity Condition section (7.1). Here are the comments:
> 
> - I can understand how the logical OR's and AND's work in the 
> examples, but I admit I could not figure it out based on the 
> text in the 2nd paragraph of 7.1.1. The document says: 
> 
> I would understand this in a way that if you have e.g. 
> several <one/>'s as children of identity, the condition 
> matches only if ALL of them match. But I know this is not 
> right so either I don't understand the definition or the 
> definition is wrong. 
> 
>    An identity condition matches if any of its child elements 
> (i.e., the <one/> and the <many/> elements defined in this 
> document) matches with the authenticated identity, i.e., the 
> results of the individual child element matches are combined 
> with a logical OR.
> 
>    A <many> element does not match, if any of the <except> 
> elements that are its children matches with the authenticated 
> identity, i.e., the exception results are combined with a logical OR.
> 
> - I would rename 7.1.3.2. as 'Matching Any Identity Excepting 
> Enumerated Domains and Identities' and 7.1.3.3. as 'Matching 
> Any Identity Within a Domain Excepting Enumerated Identities'. 
> 
> Regards,
> 	Markus
>  
>