Subject: RE: [Geopriv] Geo-HTTP/HTML and location URIs

From: "Thomson, Martin" <[email-masked]>
Date: Tue, 8 Nov 2005 15:29:47 -0600

Thanks Andy,

Based on those minutes I conclude that:

 - Geo tags are acceptable in much the same format as they are - with respect to these I agree with Marc about this particular draft.  I also think that the small amount of static data here is at the right level of detail and complexity - PIDF-LO would be too large a hammer for that particular nut.

 - The HTTP headers would be better served by location URIs, since they give us PIDF-LO without adding too large a burden on the HTTP message.

Cheers,
Martin

> -----Original Message-----
> From: Andrew Newton [mailto:[email-masked]]
> Sent: Wednesday, 9 November 2005 4:01 AM
> To: Thomson, Martin
> Cc: [email-masked]
> Subject: Re: [Geopriv] Geo-HTTP/HTML and location URIs
> 
> 
> On Nov 7, 2005, at 10:30 PM, Thomson, Martin wrote:
> 
> > My question is: what do we anticipate for the future of these
> > drafts within GEOPRIV?
> 
> I should have pointed to this earlier.  From the minutes of our
> interim meeting in May:
> 
> 5) PIDF-LO in HTTP
>    Andrew opened discussion on draft-daviel-kaegi-html-geo-tag and
> draft-daviel-kaegi-http-geo-header.  He noted that these drafts had
> been discussed at the GEOPRIV interim meeting in Washington DC, but
> was willing to reopen discussion because he felt the group had not
> fully understood the intended use cases.
>    There was some discussion regarding forward progress of this work,
> interest in it by the working group, and the understanding of IETF
> process by the draft authors.  Andrew stated that he did not believe
> the draft authors understood IETF process, but that unfamiliarity of
> IETF process should not be a reason drafts are not given IETF
> consideration.
>    Several participants expressed concerns that these drafts were
> attempting to by-pass all the privacy considerations that GEOPRIV has
> defined.  Many participants felt both drafts needed to be clarified.
>    It was the consensus of the participants that draft-daviel-kaegi-
> html-geo-tag be accepted as a working group document so long as it
> described static location information meant for public consumption,
> and that this draft should reference GEOPRIV work for any other work.
>    It was the consensus of the participants that draft-daviel-kaegi-
> http-geo-header would only be accepted as a working group item if it
> were first rewritten to use PIDF-LO.
> 
> -andy

------------------------------------------------------------------------------------------------
This message is for the designated recipient only and may
contain privileged, proprietary, or otherwise private information.  
If you have received it in error, please notify the sender
immediately and delete the original.  Any unauthorized use of
this email is prohibited.
------------------------------------------------------------------------------------------------
[mf2]

_______________________________________________
Geopriv mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/geopriv

---

From: Henning Schulzrinne <[email-masked]>
Date: Tue, 08 Nov 2005 16:34:21 -0500

>  - The HTTP headers would be better served by location URIs, since they give us PIDF-LO without adding too large a burden on the HTTP message.

I would guess that a simple geo coordinate pair is shorter than most 
URLs (more so if absolute URLs are needed). Even most civic data items 
are probably on the order of 60 bytes, so the size difference is truly 
minuscule.