Subject: [Geopriv] ENUM input request

From: "Thomson, Martin" <[email-masked]>
Date: Wed, 14 Dec 2005 23:14:14 -0600

The meeting minutes from #64 include the following brief snippet:
    2.5 Any Other Business
        2.5.1 Particpants of the ENUM working group asked that GEOPRIV
          participants review the ENUM validation work and offer
          suggestions or improvements on the civic schema.

I did some digging and the following I-D includes civic address information for contact purposes (as in postal address).

http://www.ietf.org/internet-drafts/draft-ietf-enum-validation-token-00.txt

So, perhaps I can open discussion on this.  My opinion is that we should recommend using the civic address draft, of course :).  I don't see any reason to recommend PIDF-LO, or any related presence components given their apparent usage.

Incidentally, the new civic draft has been submitted just now, so expect a new version here shortly:

http://www.ietf.org/internet-drafts/draft-ietf-geopriv-revised-civic-lo-00.txt

Cheers,
Martin 

------------------------------------------------------------------------------------------------
This message is for the designated recipient only and may
contain privileged, proprietary, or otherwise private information.  
If you have received it in error, please notify the sender
immediately and delete the original.  Any unauthorized use of
this email is prohibited.
------------------------------------------------------------------------------------------------
[mf2]

_______________________________________________
Geopriv mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/geopriv

---

From: Andrew Newton <[email-masked]>
Date: Thu, 15 Dec 2005 06:58:35 -0500

On Dec 15, 2005, at 12:14 AM, Thomson, Martin wrote:

> I did some digging and the following I-D includes civic address  
> information for contact purposes (as in postal address).
>
> So, perhaps I can open discussion on this.  My opinion is that we  
> should recommend using the civic address draft, of course :).  I  
> don't see any reason to recommend PIDF-LO, or any related presence  
> components given their apparent usage.

Certainly, our civic address is more detailed.  But the use cases are  
different:

Ours) The address is injected into the system via a sighting  
mechanism.  In some cases, it comes down to knowing the port number  
on a switch.  The address gives the location of the presentity and  
also, hopefully, allows another entity to be routed to that  
location.  And while ours is more structured, we believe in most  
cases the address will be interpretted by a human.

Theirs) The address is entered via a web page by the registrant  
wanting to map their PSTN telephone number to their SIP phone.  Most  
likely, they have a bill from their telephone company handy and can  
enter in the address exactly as it appears on the bill.  The address  
is used for comparison purposes (does it match what is on record) to  
validate the assignment of the TN.  And there is a good chance that  
the validation entity is automated.

I'm inclined to say that they ought to stick with what they have as  
it might serve them better.  It seems to me that a typical user aided  
by their telephone bill would have a bit of trouble getting the right  
details into the right slots of PIDF-LO.

-andy

---

From: Otmar Lendl <[email-masked]>
Date: Thu, 15 Dec 2005 13:29:18 +0100

> the validation entity is automated.

Correct. Our main focus was to be compatible to the data formats used
in the directory assistance DB and the telco's own provisioning database.

We researched the data-format used by the respective bodies here
in Austria to arrive at the scheme we have in the I-D.

What we don't know is what address elements are used in other countries'
white pages and similar databases. That's the point where any input
from geopriv is appreciated.

/ol
-- 
< Otmar Lendl ([email-masked]) | nic.at Systems Engineer >