Subject: RE: [Geopriv] LCI and Uncertainty Representation

From: "Thomson, Martin" <[email-masked]>
Date: Tue, 28 Mar 2006 09:01:58 -0600

That looks correct John.  So how would you propose to fix it?  3825bis?
 
If you revise 3825, perhaps the new version should include some guidance on how to do a conversion from a known uncertainty into the 3825 form.
 
Martin

________________________________

From: John Schnizlein [mailto:[email-masked]]
Sent: Tue 3/28/2006 10:32 PM
To: Thomson, Martin
Cc: [email-masked]
Subject: Re: [Geopriv] LCI and Uncertainty Representation

Yes, the truncation calculation of the resolution shown in RFC 3825 is
an error.  As you indicate, truncation of the value leads to large
errors where resolution is better than the difference of the value from
the nearest power of 2.

The correct method to find the upper and lower bounds (respectively)
from resolution is to add and subtract
  (2 ^ (34 - resolution) - 1) * 2 ^ -25 from the value at the center of
the region.

It is not the encoding of location with binary-precision that is wrong,
but the application of truncation.  This should be fixed.

John

On Mar 27, 2006, at 11:58 PM, Thomson, Martin wrote:
>
> The weakness of this encoding is most clearly demonstrated at whole
> numbers of degrees, particularly powers of two.  Take the range from
> 31.9999985° to 32.00000274°, which is a mere 0.5 metre range about 32
> degrees.  This results in the following binary values:
>     000011111.1111111111111111111001110 to
>     000100000.0000000000000000001011100
>     ^^^
> You'll note that there are only three bits that are common to both. 
> This results in an encoding that represents a range from 0 to 64
> degrees, or a 3,500 kilometre distance!  If this encoding was
> converted to a PIDF-LO following the guidelines in RFC 3825, this
> information would be effectively useless.

------------------------------------------------------------------------------------------------
This message is for the designated recipient only and may
contain privileged, proprietary, or otherwise private information.  
If you have received it in error, please notify the sender
immediately and delete the original.  Any unauthorized use of
this email is prohibited.
------------------------------------------------------------------------------------------------
[mf2]

_______________________________________________
Geopriv mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/geopriv

---

From: "James M. Polk" <[email-masked]>
Date: Tue, 28 Mar 2006 13:56:44 -0600

All

Is the word "uncertainty " or its meaning in 3825?

I don't think so.

Resolution in 3825 was not about uncertainty - which is a cellular issue 
and not a wireline issue - but about defining bounds in which the target is 
within.  It is explicitly stated that the target is (100% known to be) 
within the trapezoid.  Resolution sometimes purposely expands those bounds 
to provide less resolution (or precision - depending on which word you want 
to use) to a requester or seeker of location information.

There is no uncertainty from a wireline outlet.

One of the fundamental agreements this WG made years ago when writing 3693 
was that there would be no lying about location. That the resolution would 
be reduced.  This means uncertainty discussions became moot right then.

At 09:01 AM 3/28/2006 -0600, Thomson, Martin wrote:
>If you revise 3825, perhaps the new version should include some guidance 
>on how to do a conversion from a known uncertainty into the 3825 form.
>
>Martin
>

---

From: "Thomson, Martin" <[email-masked]>
Date: Thu, 30 Mar 2006 06:45:17 -0600

James,

> within.

That is precisely the meaning and purpose of uncertainty.  For instance, if you are describing the bounding walls of a building, where the Target could be anywhere within that building, that is uncertainty.

> It is explicitly stated that the target is (100% known to be)
> within the trapezoid. 

You claim 100% confidence, which is different from uncertainty.  Read the geo-shape draft and you will see why confidence cannot be 100%.

This isn't about lying, this is about the inherent limitations of location determination.  DHCP, like any other technique is subject to both uncertainty and confidence.  What you call it doesn't change that fact.

From: James M. Polk [mailto:[email-masked]]
Sent: Wed 3/29/2006 5:56 AM
To: Thomson, Martin; John Schnizlein
Cc: [email-masked]
Subject: RE: [Geopriv] LCI and Uncertainty Representation

All

I don't think so.