Subject: RE: [Geopriv] Timezones in Civic locations

From: "Winterbottom, James" <[email-masked]>
Date: Tue, 4 Apr 2006 19:28:38 -0500

I am not sure that I agree with statement Andy.
The <location-info> element in PIDF-LO is defined as follows:

  <xs:complexType name="locInfoType">
    <xs:sequence>
      <xs:any namespace="##other" processContents="lax" minOccurs="0"
         maxOccurs="unbounded"/>
    </xs:sequence>
   </xs:complexType>

Which to me means that it can already be anything you want so I am not
sure how this adds complication the PIDF-LO. If you really want location
to be represented by timezone and you want to have the PIDF-LO rules
apply to it, I think that the existing PIDF-LO format is fine, without
having to explicitly add it to the revised civic notation.

Cheers
James

> -----Original Message-----
> From: Andrew Newton [mailto:[email-masked]]
> Sent: Wednesday, 5 April 2006 10:21 AM
> To: Henning Schulzrinne
> Cc: Winterbottom, James; [email-masked]; Thomson, Martin
> Subject: Re: [Geopriv] Timezones in Civic locations
> 
> 
> On Apr 4, 2006, at 7:57 PM, Henning Schulzrinne wrote:
> 
> > To respond to an earlier comment: given that RPID is just another
> > namespace, it would be easy to include this information in any
> > composite presence document, regardless of whether one would need
> > the other RPID elements. Thus, this is only an issue if we care
> > about situations where only location information can be transferred
> > for some reason.
> 
> Actually, I think the suggestion for using the representation in RPID
> does more harm than good.  This means that PIDF-LO processors must
> now pay attention to civic location in two places, one in the
> civicLoc namespace and one in the RPID namespace.  Additionally, it
> now means that the PIDF-LO rules may now apply to elements outside
> the <location-info> element.
> 
> -andy

------------------------------------------------------------------------------------------------
This message is for the designated recipient only and may
contain privileged, proprietary, or otherwise private information.  
If you have received it in error, please notify the sender
immediately and delete the original.  Any unauthorized use of
this email is prohibited.
------------------------------------------------------------------------------------------------
[mf2]

_______________________________________________
Geopriv mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/geopriv

---

From: Andrew Newton <[email-masked]>
Date: Tue, 4 Apr 2006 20:47:40 -0400

> having to explicitly add it to the revised civic notation.

And what you have stated here does not contradict what I just said.  
As in:

>> This means that PIDF-LO processors must
>> civicLoc namespace and one in the RPID namespace.

That is still true.  It would be:

   <location-info>
     <civicLoc:civicAddress> ... (or whatever it is)
     <rpid:tz> ... (or whatever it is)

That is civic location information in two namespaces.  If you believe  
that is fine, then would you accept putting the new elements for  
revised-civic in a separate namespace?

>>   Additionally, it

And this is what I believe Henning was getting at, though his  
language was imprecise.  The information would exist in RPID, which  
is part of the containing document.

-andy