Subject: [Geopriv] Common Policy Update

From: Hannes Tschofenig <[email-masked]>
Date: Sat, 01 Apr 2006 21:51:52 +0200

Hi all,

based on the discussion regarding the identity extension I have compiled 
a new draft version. Please find the updated draft at:

http://www.tschofenig.priv.at/TEMP/draft-ietf-geopriv-common-policy-09.txt
http://www.tschofenig.priv.at/TEMP/draft-ietf-geopriv-common-policy-09.html
(Note that I have not yet submitted the document.)

The important modification relates to the introduction of a new 
extension point at the <identity> element. Here is the modified XML schema:

------------

     ~snip~

     <!-- //conditions/identity -->
     <xs:complexType name="identityType">
         <xs:complexContent>
             <xs:restriction base="xs:anyType">
                 <xs:choice  minOccurs="0" maxOccurs="unbounded">
                     <xs:element name="one" type="cp:oneType"/>
                     <xs:element name="many" type="cp:manyType"/>
 >>                  <xs:any namespace="##other" processContents="lax"
 >>                  minOccurs="0" maxOccurs="unbounded"/>
                 </xs:choice>
             </xs:restriction>
         </xs:complexContent>
     </xs:complexType>

     ~snip~

------------

This issue was discussed during the Geopriv working group session at the 
last IETF meeting.

Additionally, I have added a new section about extensiblity with the 
following content:

------------

12.  Extensibility

    This document can be extended in the following ways:

    o  Conditions: The XML schema allows new child elements of the
       <conditions> element to be defined.

    o  Transformations: The XML schema allows new child elements of the
       <transformations> element to be defined.

    o  Actions: The XML schema allows new child elements of the <actions>
       element to be defined.

    o  Extensions to the Identity Element: The XML schema allows new
       child elements of the <identity> element to be defined.

    o  URI Schemes: New URI schemes can be defined for the 'id' attribute
       according to [10].

    Unknown extensions can be safely ignored without impacting the user's
    privacy.  In order to allow a RM to learn which extensions are
    supported by a PS the policy capability extensions might be useful
    (see [11], [12] and [13]).

------------

Thanks to Henning, Allison, Ted, Andy and Martin for the identity 
discussions. Please let me know if you are happy with the update.

Ciao
Hannes

_______________________________________________
Geopriv mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/geopriv

---

From: "Thomson, Martin" <[email-masked]>
Date: Tue, 4 Apr 2006 16:54:39 -0500

Thanks Hannes, that looks good.

> -----Original Message-----
> From: Hannes Tschofenig [mailto:[email-masked]]
> Sent: Tuesday, 4 April 2006 9:46 PM
> To: Thomson, Martin
> Cc: [email-masked]
> Subject: Re: [Geopriv] Common Policy Update
> 
> Hi Martin,
> 
> thanks for the quick response.
> 
> I have added the following sentence to Section 7.1;
> "
> If a child element of <identity> is in a namespace that is not
> known or not supported, it can be ignored.
> "
> and I deleted Section 12 about extensibility.
> 
> Here is the new draft version:
> http://www.tschofenig.com/TEMP/draft-ietf-geopriv-common-policy-09.txt
> http://www.tschofenig.com/TEMP/draft-ietf-geopriv-common-policy-09.html
> 
> Ciao
> Hannes
> 
mf2
------------------------------------------------------------------------------------------------
This message is for the designated recipient only and may
contain privileged, proprietary, or otherwise private information.  
If you have received it in error, please notify the sender
immediately and delete the original.  Any unauthorized use of
this email is prohibited.
------------------------------------------------------------------------------------------------
[mf2]