Subject: RE: [Geopriv] static location on a mobile device

From: "Stastny Richard" <[email-masked]>
Date: Thu, 6 Apr 2006 16:35:00 +0200

I consider a tag or warning useful not only with
static configuration, but also with dynamic configuration

Brian is proposing in his I-D ecrit-phonebcp,
that a device immediately gets his location at
attachment time, and each time the device is moved
The device may detect this by some means, e.g. change of
IP address or change of hotspot, etc.

What may happen here is that the device is not
able to retrieve the location at this time, so the
location information may be tagged as out-dated
until a new location information may be retrieved

The same could be done with manual configuration, if
the device detects a potential change in location.

Richard

> -----Original Message-----
> From: Marc Berryman [mailto:[email-masked]]
> Sent: Thursday, April 06, 2006 4:22 PM
> To: Marc Linsner; Andrew Newton; [email-masked]; [email-masked]
> Subject: RE: [Geopriv] static location on a mobile device
> 
> In the best of all worlds, the mobile device would "know" it has been
> moved and request the location information be updated (either by
manual
> update or obtaining the location from the new connection point e.g.
> wiremap). Of course this may would be the best case and not
necessarily
> the common case.
> 
> While it is out of the scope of this WG, we need to make sure there is
a
> consumer education / awareness aspect so the end users will know this
> may happen, and to update their location every time they move.
> 
> Marc B
> 
> -----Original Message-----
> From: Marc Linsner [mailto:[email-masked]]
> Sent: Thursday, April 06, 2006 8:10 AM
> To: 'Andrew Newton'; [email-masked]; [email-masked]
> Subject: RE: [Geopriv] static location on a mobile device
> 
> Obviously the use case is valid.
> 
> Are you suggesting that the 'Manual' pidf-lo method is not sufficient
to
> cover this use case?
> 
> -Marc-
> 
> > -----Original Message-----
> > From: Andrew Newton [mailto:[email-masked]]
> > Sent: Thursday, April 06, 2006 8:46 AM
> > To: [email-masked]; [email-masked]
> > Subject: [Geopriv] static location on a mobile device
> >
> > [  This is being cross-posted to both GEOPRIV and ECRIT.  The
> > use case is for emergency services but it deals with location.  ]
> >
> >
> > Despite our best efforts, I believe in less than ideal
> > situations (and
> > there will be many) we may end up with mobile devices configured
with
> > static locations.  Here is the scenario as the world works
> > today in some
> > situations:
> >
> >    A user signs up for voip service.  In the process of getting voip
> > service, their location is determined (either by asking the
> > user or some
> > database lookup).  This location is based on the endpoint of
> > the users
> > broadband connection.
> >    Now, the user takes the device associated with that
> > location to his
> > friends house.  If a call is placed, the location conveyed will be
> > different than the location of the actual device.
> >
> > This is simply a fact of life.  It will happen.  I was
> > thinking that it
> > would be a good thing if the location could be conveyed to
> > the PSAP with
> > the following note, "This location has been configured
> > statically, but
> > the device may have been moved."  Naturally, an actual
> > english message
> > is not the best thing... a well-known tag would work better
> > the world over.
> >
> > Before I jump into the solution space, I was wondering what people
> > thought of the idea.
> >
> > -andy
> >
> >
> >
> > _______________________________________________
> > Geopriv mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/geopriv
> 
> _______________________________________________
> Geopriv mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/geopriv
> 
> 
> 
> _______________________________________________
> Geopriv mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/geopriv

_______________________________________________
Geopriv mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/geopriv

---

From: "Thomson, Martin" <[email-masked]>
Date: Tue, 11 Apr 2006 18:00:39 -0500

It's safer to assume that the location will change.  If it doesn't move, then you haven't lost anything.  If you want to hint at this fact, you can provide more useful information by including an expiry time, so the user knows when to re-request.  That would obviate the need for a special flag.

________________________________

From: Randall Gellens [mailto:[email-masked]]
Sent: Wed 4/12/2006 8:27 AM
To: [email-masked]; 'Stark, Barbara'; 'Stastny Richard'; 'Marc Berryman'; 'Marc Linsner'; 'Andrew Newton'; [email-masked]; [email-masked]
Subject: RE: [Ecrit] RE: [Geopriv] static location on a mobile device

At 4:45 PM -0400 4/10/06, Brian Rosen wrote:

>  I do think we need a flag somewhere that says "caution, location can change
>  at any moment".

I can see how such a flag might be useful.  What I was wondering
about in my earlier mail was a flag that said "this device won't
move", as that seems less likely to be accurate.  So, the presence of
your flag is a warning that the device is likely to move; its absence
doesn't imply that the device won't move.
--
Randall Gellens
Opinions are personal;    facts are suspect;    I speak for myself only
-------------- Randomly-selected tag: ---------------
What is mind?  No matter.
What is matter?  Never mind.
        --Thomas Hewitt Key, 1799-1875

------------------------------------------------------------------------------------------------
This message is for the designated recipient only and may
contain privileged, proprietary, or otherwise private information.  
If you have received it in error, please notify the sender
immediately and delete the original.  Any unauthorized use of
this email is prohibited.
------------------------------------------------------------------------------------------------
[mf2]