Subject: RE: [Geopriv] Timezones in Civic locations

From: "Winterbottom, James" <[email-masked]>
Date: Tue, 4 Apr 2006 19:51:46 -0500

Perhaps I am misunderstanding something.
Is the argument that timezone is generally location based, or
specifically civic-location based?

If is the former, then I think it is a new location-info type, so my
recommendation would stand. If we are saying that it is civic specific,
then I would like to understand why.

> -----Original Message-----
> From: Andrew Newton [mailto:[email-masked]]
> Sent: Wednesday, 5 April 2006 10:48 AM
> To: Winterbottom, James
> Cc: Henning Schulzrinne; [email-masked]; Thomson, Martin
> Subject: Re: [Geopriv] Timezones in Civic locations
> 
> 
> 
> On Apr 4, 2006, at 8:28 PM, Winterbottom, James wrote:
> 
> > I am not sure that I agree with statement Andy.
> > The <location-info> element in PIDF-LO is defined as follows:
> >
> >   <xs:complexType name="locInfoType">
> >     <xs:sequence>
> >       <xs:any namespace="##other" processContents="lax"
minOccurs="0"
> >          maxOccurs="unbounded"/>
> >     </xs:sequence>
> >    </xs:complexType>
> >
> > Which to me means that it can already be anything you want so I am
not
> > sure how this adds complication the PIDF-LO. If you really want
> > location
> > to be represented by timezone and you want to have the PIDF-LO rules
> > apply to it, I think that the existing PIDF-LO format is fine,
without
> > having to explicitly add it to the revised civic notation.
> 
> And what you have stated here does not contradict what I just said.
> As in:
> 
> >> This means that PIDF-LO processors must
> >> now pay attention to civic location in two places, one in the
> >> civicLoc namespace and one in the RPID namespace.
> 
> That is still true.  It would be:
> 
>    <location-info>
>      <civicLoc:civicAddress> ... (or whatever it is)
>      <rpid:tz> ... (or whatever it is)
> 
> That is civic location information in two namespaces.  If you believe
> that is fine, then would you accept putting the new elements for
> revised-civic in a separate namespace?
> 
> >>   Additionally, it
> >> now means that the PIDF-LO rules may now apply to elements outside
> >> the <location-info> element.
> 
> And this is what I believe Henning was getting at, though his
> language was imprecise.  The information would exist in RPID, which
> is part of the containing document.
> 
> -andy

------------------------------------------------------------------------------------------------
This message is for the designated recipient only and may
contain privileged, proprietary, or otherwise private information.  
If you have received it in error, please notify the sender
immediately and delete the original.  Any unauthorized use of
this email is prohibited.
------------------------------------------------------------------------------------------------
[mf2]

_______________________________________________
Geopriv mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/geopriv

---

From: Andrew Newton <[email-masked]>
Date: Tue, 4 Apr 2006 21:27:26 -0400

> then I would like to understand why.

How is it not civic?  Aren't timezone boundaries determined in part  
by political process, much like other parts of civic locations?

-andy

---

From: Henning Schulzrinne <[email-masked]>
Date: Tue, 04 Apr 2006 21:35:40 -0400

Timezones exist in places without civic locations, such as the open 
ocean or Antarctica. I don't know how practically significant these are, 
but at least the usual maps in the back of airline magazines show these...

> How is it not civic?  Aren't timezone boundaries determined in part by 
> political process, much like other parts of civic locations?
> 
> -andy
>

---

From: Andrew Newton <[email-masked]>
Date: Tue, 4 Apr 2006 22:40:15 -0400

And they don't always follow straight lines in the oceans either:
http://reverie.aaeol.ca/about/timezone.p

I think what you have just pointed out is that in some places on the  
planet, all there is of a civic location is timezone.

-andy

On Apr 4, 2006, at 9:35 PM, Henning Schulzrinne wrote:

> ocean or Antarctica. I don't know how practically significant these  
> are, but at least the usual maps in the back of airline magazines  
> show these...
>
>> How is it not civic?  Aren't timezone boundaries determined in  
>> part by political process, much like other parts of civic locations?
>> -andy