Subject: [Geopriv] Question on use of "Speed" in Location Object (PIDF-LO)

From: Vishal Kumar Singh <[email-masked]>
Date: Tue, 01 Aug 2006 09:54:03 -0400

Hello,

I wanted to know where does "speed" of person/device (whose location is 
tracked) fits into the PIDF-LO.

I do not know much about GML, but based on some initial investigation, 
GML specs have following options to specify "Speed". I wanted to know 
which one is most appropriate?

A)In dynamicfeature.xsd

<complexType name="MovingObjectStatusType">
<annotation>
<documentation xml:lang="en">
This type encapsulates various dynamic properties of moving objects
(points, lines, regions). It is useful for dealing with features whose
geometry or topology changes over time.
</documentation>
</annotation>
<complexContent>
     <extension base="gml:AbstractTimeSliceType">
     <sequence>
         <element ref="gml:location"/>
         <element name="speed" type="gml:MeasureType" 
minOccurs="0"/> <element name="bearing" type="gml:DirectionPropertyType" 
minOccurs="0"/> <element name="acceleration" type="gml:MeasureType" 
minOccurs="0"/> <element name="elevation" type="gml:MeasureType" 
minOccurs="0"/> <element ref="gml:status" minOccurs="0"/>
     </sequence>
     </extension>
</complexContent>
</complexType>

B) in measures.xsd
<complexType name="SpeedType">
<annotation>
<documentation>
Value of a speed, with its units. Uses the MeasureType with the 
restriction that the unit of measure referenced by uom must be suitable 
for a velocity, such as metres per second or miles per hour.
</documentation>
</annotation>
   <simpleContent>
     <extension base="gml:MeasureType"/>
   </simpleContent>
</complexType>

C)
<complexType name="TrackType">
<annotation>
<documentation xml:lang="en">
The track of a moving object is a sequence of specialized timeslices 
  that indicate the status of the object.
</documentation>
</annotation>
<complexContent>
<restriction base="gml:HistoryPropertyType">
     <sequence>
     <element ref="gml:MovingObjectStatus" maxOccurs="unbounded"/>
     </sequence>
</restriction>
</complexContent>
</complexType>

Regards,
Vishal
-- 
Not everything that can be counted counts, and not everything that 
counts can be counted.
-By Albert Einstein

_______________________________________________
Geopriv mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/geopriv

---

From: "Tschofenig, Hannes" <[email-masked]>
Date: Wed, 2 Aug 2006 10:31:45 +0200

Hi Vihal, 

RFC 4119 says:

"
 For the purposes of
   baseline interoperability as defined by this document, only support
   for the 'feature.xsd' GML schema is REQUIRED.
"

dynamicFeature.xsd includes a speed element but is not included by feature.xsd. Supporting dynamicFeature.xsd would cause a number of other schemas to be imported. Hence, increased complexity.

Recently, we tried to get the simplify the feature.xsd functionality by profiling it. See 
http://www.ietf.org/internet-drafts/draft-thomson-geopriv-geo-shape-02.txt
http://www.ietf.org/internet-drafts/draft-ietf-geopriv-pdif-lo-profile-04.txt

The measures.xsd, which is imported by feature.xsd (via geometryBasic0d1d.xsd and geometryBasic2d.xsd), seems to be more promising when we want to avoid adding complexity. I have't looked at it in more detail though. I will, however, do that. 

I wonder whether we need to capture the usage of speed in draft-ietf-geopriv-pdif-lo-profile-04.txt. 

Ciao
Hannes

> -----Ursprüngliche Nachricht-----
> Von: Vishal Kumar Singh [mailto:[email-masked]] 
> Gesendet: Dienstag, 1. August 2006 15:54
> An: [email-masked]
> Betreff: [Geopriv] Question on use of "Speed" in Location 
> Object (PIDF-LO)
> 
> Hello,
>

---

From: "Winterbottom, James" <[email-masked]>
Date: Wed, 2 Aug 2006 03:35:24 -0500

I would prefer not to capture speed in PIDF-LO profile.
If someone has a real application in mind which requires speed I would prefer to have a specific document describing that. PIDF-LO profile was really meant to assist with address potential ambiguities in location representation so that interpretation is clear. I am not sure how speed plays into that equation.
 
Cheers
James

________________________________

From: Tschofenig, Hannes [mailto:[email-masked]]
Sent: Wed 2/08/2006 3:31 AM
To: Vishal Kumar Singh; [email-masked]
Subject: AW: [Geopriv] Question on use of "Speed" in Location Object (PIDF-LO)

Hi Vihal,

RFC 4119 says:

"
 For the purposes of

Ciao
Hannes

------------------------------------------------------------------------------------------------
This message is for the designated recipient only and may
contain privileged, proprietary, or otherwise private information.  
If you have received it in error, please notify the sender
immediately and delete the original.  Any unauthorized use of
this email is prohibited.
------------------------------------------------------------------------------------------------
[mf2]

---

From: Hannes Tschofenig <[email-masked]>
Date: Wed, 02 Aug 2006 10:38:26 +0200

Ok. Sounds reasonable.

---

From: Henning Schulzrinne <[email-masked]>
Date: Wed, 2 Aug 2006 08:59:07 -0400

We have a real application for a real customer, namely vehicle  
tracking for fleet management. Are you suggesting we draft a document  
that is essentially 4119 + speed, and called something other than  
PIDF-LO?

On Aug 2, 2006, at 4:35 AM, Winterbottom, James wrote:

> If someone has a real application in mind which requires speed I  
> would prefer to have a specific document describing that. PIDF-LO  
> profile was really meant to assist with address potential  
> ambiguities in location representation so that interpretation is  
> clear. I am not sure how speed plays into that equation.
>
> Cheers
> James
>
> dynamicFeature.xsd includes a speed element but is not included by  
> feature.xsd. Supporting dynamicFeature.xsd would cause a number of  
> other schemas to be imported. Hence, increased complexity.
>
> The measures.xsd, which is imported by feature.xsd (via  
> geometryBasic0d1d.xsd and geometryBasic2d.xsd), seems to be more  
> promising when we want to avoid adding complexity. I have't looked  
> at it in more detail though. I will, however, do that.
>

---

From: "James M. Polk" <[email-masked]>
Date: Sun, 06 Aug 2006 18:54:03 -0500

>that is essentially 4119 + speed, and called something other than

Well... anyone looking back at the really old discussions within this WG 
will see that we did discuss speed, velocity, the direction of travel, the 
direction the target is pointed in (regardless of the direction the target 
is traveling in), vector, temperature of the target, wind speed (felt by 
target), current (as in that of water against the target), acceleration, 
the delta of any of these from the previous measurement, and many other 
elements.  I think Rohan also made a valid case for "Nautical dead 
reckoning" be added if any of the others were.

The decision at the time by our chairs (and that of Ted as he was first 
being bomb-blasted by us as a new AD) was to have these elements be part of 
"Geopriv Phase II"... whatever that meant.

That said, I don't really think speed is 4119 + speed, but 4119 + (phase II 
elements - which share something similar in characteristic (i.e. the list 
above, in addition to speed)).

I think a separate doc detailing where each of these (and others?) go in a 
PIDF-LO would be considered a single new idea worthy of a document in and 
of itself.  We should agreed that there is a phase III, so the really 
minute elements are all added to this Phase II doc - but I think it is 
worthy of a separate doc, to address as a WG in whole, and not bog down the 
pidf-lo-profile doc.

>>http://www.ietf.org/internet-drafts/draft-thomson-geopriv-geo- shape-02.txt