Subject: [Geopriv] New draft on using SIP events as an L7 location configuration protocol

From: Henning Schulzrinne <[email-masked]>
Date: Tue, 17 Oct 2006 13:24:22 -0400

Until it appears in the archives, you can find a draft at

http://www.cs.columbia.edu/sip/draft/l7-presence/draft-schulzrinne-geopriv-locationref-00.txt

or, in technicolor,

http://www.cs.columbia.edu/sip/draft/l7-presence/draft-schulzrinne-geopriv-locationref-00.html

This is the joint effort of a number of folks, but given the short 
gestation period between conception and birth, not all contributors have 
had a chance to vet the text, so the errors are all mine.

Comments are appreciated.

Henning

_______________________________________________
Geopriv mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/geopriv

---

From: "James M. Polk" <[email-masked]>
Date: Tue, 17 Oct 2006 13:32:31 -0500

Henning

This is a pretty cool idea.

---

From: Richard Barnes <[email-masked]>
Date: Fri, 20 Oct 2006 12:21:42 -0400

Henning,

I agree that this is a cool idea. 

I'd kind of like to see a service like tinyurl.com, where I could 
request a randomized URL with certain privacy parameters.  It seems like 
that's accommodated by your model, if a SUBSCRIBE request with Expires:0 
would generate a new URL every time.  Would that be consistent with what 
you guys were thinking?

Cheers,
--Richard

James M. Polk wrote:
>> gestation period between conception and birth, not all contributors 
>> have had a chance to vet the text, so the errors are all mine.
>>

---

From: Henning Schulzrinne <[email-masked]>
Date: Fri, 20 Oct 2006 21:27:00 -0400

On Oct 20, 2006, at 12:21 PM, Richard Barnes wrote:

> request a randomized URL with certain privacy parameters.  It seems  
> like that's accommodated by your model, if a SUBSCRIBE request with  
> Expires:0 would generate a new URL every time.  Would that be  
> consistent with what you guys were thinking?

Yes, kind of. We had discussed allowing to specify a privacy policy  
in the subscription, which would then be used for any notifications  
related to the RPRU. For simplicity, we have omitted this feature for  
now.

Henning

---

From: "Dawson, Martin" <[email-masked]>
Date: Sun, 22 Oct 2006 21:32:01 -0500

Hi Henning,

Could you clarify whether this specification is "in addition to" or "as
an alternative to" Relo?

Cheers,
Martin

> -----Original Message-----
> From: Henning Schulzrinne [mailto:[email-masked]]
> Sent: Wednesday, 18 October 2006 3:24 AM
> To: [email-masked]
> Subject: [Geopriv] New draft on using SIP events as an L7
> locationconfiguration protocol
> 
have
> Comments are appreciated.

------------------------------------------------------------------------------------------------
This message is for the designated recipient only and may
contain privileged, proprietary, or otherwise private information.  
If you have received it in error, please notify the sender
immediately and delete the original.  Any unauthorized use of
this email is prohibited.
------------------------------------------------------------------------------------------------
[mf2]

---

From: Henning Schulzrinne <[email-masked]>
Date: Sun, 22 Oct 2006 22:49:19 -0400

Martin,

this depends on whether we can get agreement on whether this approach  
satisfies all of our L7 needs. If so, we presumably would not need  
(in alphabetical order) HELD, LCP, or RELO.

Henning