Subject: [Geopriv] Slides for LbyR/LbyV discussion

From: Henning Schulzrinne <[email-masked]>
Date: Sat, 4 Nov 2006 17:59:01 -0500

In the attempt to make the location-related discussion at the IETF  
somewhat more productive and structured, I've put together some  
slides on this topic

http://www.cs.columbia.edu/~hgs/papers/2006/IETF67-geopriv-lbyx.ppt

Input was provided by Hannes and Andy, but all mistakes are mine.

Henning

_______________________________________________
Geopriv mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/geopriv

---

From: "Rohan Mahy" <[email-masked]>
Date: Mon, 6 Nov 2006 14:27:22 -0800

A note on slide 7.  The target has no way of knowing what the watcher
considers a "significant" change in location unless it is told. In
many cases, the target does not know its exact location at the moment
and often cares less than an external watcher.

Any discussion on LbyV vs LbyR is incomplete without discussing these points.

thanks,
-rohan

---

From: "Marc Linsner" <[email-masked]>
Date: Mon, 6 Nov 2006 17:40:41 -0500

Rohan,

in-line,

> 
> A note on slide 7.  The target has no way of knowing what the 
> watcher considers a "significant" change in location unless 
> it is told. In many cases, the target does not know its exact 
> location at the moment and often cares less than an external watcher.

Interesting inference, the target does not know it's moving but the watcher
knows the target is moving?

Can you provide a real use case?

One would assume that implementers of mobile devices would allow such
devices to know they're mobile.

-Marc-

> > somewhat more productive and structured, I've put together 
> some slides 
> > on this topic
> >

---

From: "Richard L. Barnes" <[email-masked]>
Date: Mon, 06 Nov 2006 14:56:41 -0800

Marc,

To use the example of access-controlled locations on slide 10, if all 
the L-by-V objects are encrypted for the recipient, then neither the 
target nor the recipient would know that the target is moving.  The 
target would just see opaque objects, and the recipient would just see a 
snapshot of location; only the location determination function (in the 
access network, presumably) would know that the target is moving. 

This problem could be mitigated if the location determination function 
could create PIDF-LO with the dynamic feature extensions in 
draft-singh-geopriv-pidf-lo-dynamic.  That way at least the recipient 
would know that the target is on the move.

Cheers,
--Richard

---

From: "Thomson, Martin" <[email-masked]>
Date: Mon, 6 Nov 2006 16:44:05 -0600

Marc,

I didn't get that inference at all - Rohan suggested that the Target doesn't know where it is and doesn't necessarily care.  The watcher wants to know, that's all.

M

> -----Original Message-----
> From: Marc Linsner [mailto:[email-masked]]
> Sent: Tuesday, 7 November 2006 9:41 AM
> To: 'Rohan Mahy'; 'Henning Schulzrinne'
> Cc: 'GEOPRIV'
> Subject: RE: [Geopriv] Slides for LbyR/LbyV discussion
> 
> Rohan,
> 
> in-line,
> 
> >

------------------------------------------------------------------------------------------------
This message is for the designated recipient only and may
contain privileged, proprietary, or otherwise private information.  
If you have received it in error, please notify the sender
immediately and delete the original.  Any unauthorized use of
this email is prohibited.
------------------------------------------------------------------------------------------------
[mf2]
_______________________________________________
Geopriv mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/geopriv

---

From: "Marc Linsner" <[email-masked]>
Date: Mon, 6 Nov 2006 19:00:13 -0500

Richard,

I'm still missing the real-world use case.  I don't understand the
value/benefit of a target that doesn't know/care about it's location but
some other entity does.

-Marc-

________________________________

	From: Richard L. Barnes [mailto:[email-masked]] 
	Sent: Monday, November 06, 2006 5:57 PM
	To: Marc Linsner
	Cc: 'GEOPRIV'; 'Henning Schulzrinne'
	Subject: Re: [Geopriv] Slides for LbyR/LbyV discussion

	Marc,
	
	To use the example of access-controlled locations on slide 10, if
all the L-by-V objects are encrypted for the recipient, then neither the
target nor the recipient would know that the target is moving.  The target
would just see opaque objects, and the recipient would just see a snapshot
of location; only the location determination function (in the access
network, presumably) would know that the target is moving.  
	
	This problem could be mitigated if the location determination
function could create PIDF-LO with the dynamic feature extensions in
draft-singh-geopriv-pidf-lo-dynamic.  That way at least the recipient would
know that the target is on the move.
	
	Cheers,
	--Richard

	Marc Linsner wrote: 

		Rohan,
		
		in-line,

			A note on slide 7.  The target has no way of knowing
what the 
			watcher considers a "significant" change in location
unless 
			it is told. In many cases, the target does not know
its exact 
			location at the moment and often cares less than an
external watcher.

		Interesting inference, the target does not know it's moving
but the watcher
		knows the target is moving?

		One would assume that implementers of mobile devices would
allow such
		devices to know they're mobile.
		
		-Marc-

			Any discussion on LbyV vs LbyR is incomplete without

			discussing these points.
			
			thanks,
			-rohan
			
			On 11/4/06, Henning Schulzrinne
<[email-masked]> <mailto:[email-masked]>  wrote:

				In the attempt to make the location-related
discussion at the IETF 
				somewhat more productive and structured,
I've put together 

			some slides 

				on this topic

				Input was provided by Hannes and Andy, but
all mistakes are mine.
				
				Henning

---

From: "James M. Polk" <[email-masked]>
Date: Wed, 08 Nov 2006 15:42:05 -0600

>value/benefit of a target that doesn't know/care about it's location but

one use-case may be hinged on Rohan's use of the word "significant".  How 
far does a target move before it considers updating whoc it has already 
contacted with location the first time?

simple words, if a phone calls 911 and moves 50 feet, is there a trigger 
that is configured (or downloaded) to the phone that says "update needs to 
be sent every 25 feet".

50 feet in a normally warehouse setting isn't much, but 50 feet in downtown 
Chicago or Manhattan could be more than one address away, or even across a 
street. This distance may not matter to the phone, but it may (and not 
always!) matter to the recipent that wants this level of detail about 
movements.

BTW - 50 feet up or down has a great impact in most buildings.

Ultimately, this is only locally significant to the setting a 
watcher/target are in, but how does this policy (and thus configuration) 
get to the phone (or device)?

The handicap here is the watcher and the target are likely to be in two 
different organizations, and may not even be peering/adjacent orgs 
(target-in-business, SP-of-business, PSAP-to-SP).  i.e. this may be a 
degrees of separation issue

---

From: "Rohan Mahy" <[email-masked]>
Date: Wed, 8 Nov 2006 16:37:39 -0800

Hi Marc,

Say my phone has a mapping or navigation program on it.  When its
running, my phone (the target) is interested in its location.  When it
is not running, it is not interested in its own location.  Alice and
Bob are both on my buddy list. Alice is allowed to see my detailed
location information from my presence server down to the meter level.
Bob can find out what country and time zone I am in.  When Alice is
subscribed, my presence server needs detailed updates (that my phone
isn't interested in unless it is running the nav program).  When only
Bob is subscribed, my presence server needs much less granular
location information.

As a second example, Imagine the target is a dialysis machine in a
hospital. The target (the machine) does not care about its location.
Doctors and nurses looking for a dialysis machine do care.

Hope this helps.
thanks,
-rohan

---

From: "Dawson, Martin" <[email-masked]>
Date: Wed, 8 Nov 2006 18:45:47 -0600

Or - say - you've lost your phone and your trying to find it :)

> From: Rohan Mahy [mailto:[email-masked]]
> Sent: Thursday, 9 November 2006 11:38 AM
> To: Marc Linsner
> Cc: GEOPRIV
> >         To use the example of access-controlled locations on slide
10,
> if
> target
> >                         it is told. In many cases, the target does
not
> know
> > its exact
> >                         location at the moment and often cares less
than
> an
> >                                 Input was provided by Hannes and
Andy,
> but