Subject: [Geopriv] draft-thomson-geopriv-lis-discovery-00

From: Cullen Jennings <[email-masked]>
Date: Sat, 10 Mar 2007 14:00:10 -0800

UPnP will not discover the outer most NAT so I don think it should be  
used here.

Cullen <with my individual hat on>

_______________________________________________
Geopriv mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/geopriv

---

From: "Thomson, Martin" <[email-masked]>
Date: Sun, 11 Mar 2007 18:19:25 -0500

Hi Cullen,

The intent is not to discover the outermost NAT, at least not always.  If you look at the cases where two layers of NAT are used, a LIS is likely to exist within the second layer.

I'm thinking primarily of cable networks where it is common to have a NAT on the customer premises and another NAT for the entire ISP network (or parts thereof).  Say these are a 192.168.x.x (in my house) and a 10.x.x.x (for my ISP).  The ISP LIS needs to exist in the larger network so that it can see the necessary identifiers (primarly, the 10.x.x.x address that is given to your house/modem/router/NAT).  In this case, resolving the IP of the outermost NAT is counterproductive.

Perhaps this discussion is worth including in the draft.

Cheers,
Martin

> -----Original Message-----
> From: Cullen Jennings [mailto:[email-masked]]
> Sent: Sunday, 11 March 2007 9:00 AM
> To: [email-masked]
> Subject: [Geopriv] draft-thomson-geopriv-lis-discovery-00
> 
> 

------------------------------------------------------------------------------------------------
This message is for the designated recipient only and may
contain privileged, proprietary, or otherwise private information.  
If you have received it in error, please notify the sender
immediately and delete the original.  Any unauthorized use of
this email is prohibited.
------------------------------------------------------------------------------------------------
[mf2]
_______________________________________________
Geopriv mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/geopriv

---

From: Cullen Jennings <[email-masked]>
Date: Mon, 26 Mar 2007 12:18:31 -0700

I see what you are saying about the LIS being in in the second layer.  
Thanks for getting me less confused :-)

On Mar 11, 2007, at 4:19 PM, Thomson, Martin wrote:

> Hi Cullen,
>
> The intent is not to discover the outermost NAT, at least not  
> always.  If you look at the cases where two layers of NAT are used,  
> a LIS is likely to exist within the second layer.
>
> I'm thinking primarily of cable networks where it is common to have  
> a NAT on the customer premises and another NAT for the entire ISP  
> network (or parts thereof).  Say these are a 192.168.x.x (in my  
> house) and a 10.x.x.x (for my ISP).  The ISP LIS needs to exist in  
> the larger network so that it can see the necessary identifiers  
> (primarly, the 10.x.x.x address that is given to your house/modem/ 
> router/NAT).  In this case, resolving the IP of the outermost NAT  
> is counterproductive.
>