Subject: [Geopriv] Fwd: I-D ACTION:draft-marshall-geopriv-lbyr-requirements-01.txt

From: Andrew Newton <[email-masked]>
Date: Wed, 7 Mar 2007 20:10:59 -0500

FYI

Begin forwarded message:

> From: [email-masked]
> Date: March 7, 2007 3:50:02 PM EST
> To: [email-masked]
> Subject: I-D ACTION:draft-marshall-geopriv-lbyr-requirements-01.txt
> Reply-To: [email-masked]
>
> A New Internet-Draft is available from the on-line Internet-Drafts
> directories.
>
>
> 	Title		: Requirements for a Location-by-Reference Mechanism used  
> in Location Configuration and Conveyance
> 	Author(s)	: R. Marshall
> 	Filename	: draft-marshall-geopriv-lbyr-requirements-01.txt
> 	Pages		: 21
> 	Date		: 2007-3-7
> 	
> This document defines terminology and enumerates requirements for a
>    location-by-reference approach to location configuration and
>    conveyance interactions useful for emergency call routing for  
> voice-
>    over-IP (VoIP) and general Internet multimedia systems, where
>    Internet protocols are used end-to-end.
>
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-marshall-geopriv-lbyr- 
> requirements-01.txt
>
> To remove yourself from the I-D Announcement list, send a message to
> [email-masked] with the word unsubscribe in the body of
> the message.
> You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce
> to change your subscription settings.
>
> Internet-Drafts are also available by anonymous FTP. Login with the
> username "anonymous" and a password of your e-mail address. After
> logging in, type "cd internet-drafts" and then
> "get draft-marshall-geopriv-lbyr-requirements-01.txt".
>
> A list of Internet-Drafts directories can be found in
> http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>
> Internet-Drafts can also be obtained by e-mail.
>
> Send a message to:
> 	[email-masked].
> In the body type:
> 	"FILE /internet-drafts/draft-marshall-geopriv-lbyr- 
> requirements-01.txt".
> 	
> NOTE:	The mail server at ietf.org can return the document in
> 	MIME-encoded form by using the "mpack" utility.  To use this
> 	feature, insert the command "ENCODING mime" before the "FILE"
> 	command.  To decode the response(s), you will need "munpack" or
> 	a MIME-compliant mail reader.  Different MIME-compliant mail readers
> 	exhibit different behavior, especially when dealing with
> 	"multipart" MIME messages (i.e. documents which have been split
> 	up into multiple messages), so check your local documentation on
> 	how to manipulate these messages.
>
> Below is the data which will enable a MIME compliant mail reader
> implementation to automatically retrieve the ASCII version of the
> Internet-Draft.
> Content-Type: text/plain
> Content-ID: <[email-masked]>
>
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/i-d-announce

_______________________________________________
Geopriv mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/geopriv

---

From: "Roger Marshall" <[email-masked]>
Date: Wed, 7 Mar 2007 17:25:25 -0800

This updated version of the lbyr requirements, much to my chagrin, has a
fair bit of roughness compared to what I had intended (mostly the Intro,
which is full of borrowed text!). I hope to do another update to an -02
soon, so if you take a look, ignore the Introduction altogether, and
focus on the requirements list itself, and the included diagrams, which
were based on list comments and contributions.

* Please ignore the borrowed geopriv-sip-conveyance text for reference,
in the Intro - will be culled and the Intro revamped

* I've pared down the list of requirements

-- still mulling over the target of lbyr requirements - seems like they
might apply only to the dereferencing protocol - (i.e., it seemed
awkward to place requirements onto what a conveyance protocol, a
location server, or a configuration protocol would do, so I attempted to
keep only those req's that targeted the dereference protocol)

-- jettisoned requirements that targeted what a 'conveyance' protocol
would do

-- deleted requirements that dictated the behaviour of what a 'location
server' would do

* aligned actor terminology with what is already in RFC3693 (for the
most part)

* replaced original SIP example diagram with four new diagrams - these
are for discussion, and are based on contributions from R. Barnes & M.
Thompson.

regards,
 
Roger Marshall.

________________________________

	From: Andrew Newton [mailto:[email-masked]] 
	Sent: Wednesday, March 07, 2007 5:11 PM
	To: GEOPRIV WG
	Subject: [Geopriv] Fwd:
I-DACTION:draft-marshall-geopriv-lbyr-requirements-01.txt 

	FYI

	Begin forwarded message:

		Subject: I-D
ACTION:draft-marshall-geopriv-lbyr-requirements-01.txt 

		A New Internet-Draft is available from the on-line
Internet-Drafts 
		directories.

		Title : Requirements for a Location-by-Reference
Mechanism used in Location Configuration and Conveyance
		Author(s) : R. Marshall
		Filename :
draft-marshall-geopriv-lbyr-requirements-01.txt
		Pages : 21
		Date : 2007-3-7

		This document defines terminology and enumerates
requirements for a
		   location-by-reference approach to location
configuration and
		   conveyance interactions useful for emergency call
routing for voice-
		   over-IP (VoIP) and general Internet multimedia
systems, where
		   Internet protocols are used end-to-end.

http://www.ietf.org/internet-drafts/draft-marshall-geopriv-lbyr-requirem
ents-01.txt

		To remove yourself from the I-D Announcement list, send
a message to 
		[email-masked] with the word unsubscribe
in the body of 
		the message. 
		You can also visit
https://www1.ietf.org/mailman/listinfo/I-D-announce 
		to change your subscription settings.

		Internet-Drafts are also available by anonymous FTP.
Login with the 
		username "anonymous" and a password of your e-mail
address. After 
		logging in, type "cd internet-drafts" and then 
		"get draft-marshall-geopriv-lbyr-requirements-01.txt".

		Send a message to:
		[email-masked].
		In the body type:
		"FILE
/internet-drafts/draft-marshall-geopriv-lbyr-requirements-01.txt".

		NOTE: The mail server at ietf.org can return the
document in
		MIME-encoded form by using the "mpack" utility.  To use
this
		feature, insert the command "ENCODING mime" before the
"FILE"
		command.  To decode the response(s), you will need
"munpack" or
		a MIME-compliant mail reader.  Different MIME-compliant
mail readers
		exhibit different behavior, especially when dealing with
		"multipart" MIME messages (i.e. documents which have
been split
		up into multiple messages), so check your local
documentation on
		how to manipulate these messages.

		Below is the data which will enable a MIME compliant
mail reader
		implementation to automatically retrieve the ASCII
version of the
		Internet-Draft.
		Content-Type: text/plain
		Content-ID: <[email-masked]>

The information contained in this message may be privileged and/or confidential. If you are not the intended recipient, or responsible for delivering this message to the intended recipient, any review, forwarding, dissemination, distribution or copying of this communication or any attachment(s) is strictly prohibited. If you have received this message in error, please so notify the sender immediately, and delete it and all attachments from your computer and network.