Subject: [Geopriv] singh-geopriv-pdif-lo-dynamic difference between bearing and directionOfObject

From: Klaus Darilion <[email-masked]>
Date: Tue, 07 Aug 2007 15:22:46 +0200

Hi!

Could someone please describe the difference between bearing and 
directionOfObject?

thanks
Klaus

_______________________________________________
Geopriv mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/geopriv

---

From: "Hannes Tschofenig" <[email-masked]>
Date: Wed, 08 Aug 2007 14:45:00 +0200

Hi Klaus 

I took a look at the GMLv3 specification again and noticed that I did not get the term from there. Good question where it came from given that it was not in the -00 version of the document. 

I guess I need to chat with my co-authors.

Ciao
Hannes

---

From: "Carl Reed OGC Account" <[email-masked]>
Date: Wed, 8 Aug 2007 09:35:58 -0600

Just a thought.

A bearing tends to be used in surveying to define absolute location from a fixed point to a given object (such as from a geodetic monument to the corner of a property or to define a new point location relative to a known point location (such as from the corner of a property to the next point defining the boundary of a property. This case is always done as a distance and bearing). In aeronautics, a bearing is simply the direction of travel with no target location being defined. So, in terms of PIDF-LO dynamic, a bearing could be the simple case of a dynamic object moving at a known bearing or a bearing from a known location off into infinity. My reading of the document is that there is no "distance" property" Please correct me if I am wrong. In all cases, there is a strong suggestion of "static" as opposed to "dynamic" - even if a bearing is used to describe the direction an object is moving.

Now, with a slight change of definition of directionOfObject, you could handle describing the location a truly dynamic object in 4 space (x,y,z,t). The change of concept would be from looking at this element as a property of an object to one of a measurement related to the object. The OGC has done considerable work in defining a model and related standards for describing both static and dynamic systems (typically one or more sensors). Below my signature is a short paragraph on the concept of a "measurement" in OGC/ISO/IEEE land. This paragraph was extracted from the recently approved OGC Standard titled SensorML (Sensor Markup Language). Note should be given that coordinate reference systems can become quite interesting when dealing with some sensor systems :-)

The reason that I mention the concept of a dynamic object is that more and more location information is going to be measured using mobile assets, such as the next generation sensor enable vehicle and the national roadside sensor network. There are a variety of application - and payload - implications related to the availability 

>From this perspective, I think that the pidf-lo-dynamic activity is highly important. 

Regards

Carl

Measurement (verb)
An instance of a procedure to estimate the value of a natural phenomenon, typically involving an instrument or sensor. This is implemented as a dynamic feature type, which has a property containing the result of the measurement. The measurement feature also has a location, time, and reference to the method used to determine the value. A measurement feature effectively binds a value to a location and to a method or instrument.

---

From: Henning Schulzrinne <[email-masked]>
Date: Fri, 10 Aug 2007 12:00:21 -0400

I think the term was added after the initial discussion of the  
document, but I suspect that further analysis of use cases is needed.  
Our focus has been on representing relatively large moving objects,  
such as cars and ships that have both an instantaneous orientation  
and a general direction of travel. This would imply a bearing in the  
aeronautical sense. What I'm not clear about is the time scale. Does  
this change each instant that I turn the steering wheel a bit to  
change lanes or is this averaged, so that it says "heading west" when  
I'm leaving NYC on I-80?

Henning

On Aug 8, 2007, at 11:35 AM, Carl Reed OGC Account wrote:

> Just a thought.
>
> A bearing tends to be used in surveying to define absolute location  
> from a fixed point to a given object (such as from a geodetic  
> monument to the corner of a property or to define a new point  
> location relative to a known point location (such as from the  
> corner of a property to the next point defining the boundary of a  
> property. This case is always done as a distance and bearing). In  
> aeronautics, a bearing is simply the direction of travel with no  
> target location being defined. So, in terms of PIDF-LO dynamic, a  
> bearing could be the simple case of a dynamic object moving at a  
> known bearing or a bearing from a known location off into infinity.  
> My reading of the document is that there is no "distance" property"  
> Please correct me if I am wrong. In all cases, there is a strong  
> suggestion of "static" as opposed to "dynamic" - even if a bearing  
> is used to describe the direction an object is moving.
>
> Now, with a slight change of definition of directionOfObject, you  
> could handle describing the location a truly dynamic object in 4  
> space (x,y,z,t). The change of concept would be from looking at  
> this element as a property of an object to one of a measurement  
> related to the object. The OGC has done considerable work in  
> defining a model and related standards for describing both static  
> and dynamic systems (typically one or more sensors). Below my  
> signature is a short paragraph on the concept of a "measurement" in  
> OGC/ISO/IEEE land. This paragraph was extracted from the recently  
> approved OGC Standard titled SensorML (Sensor Markup Language).  
> Note should be given that coordinate reference systems can become  
> quite interesting when dealing with some sensor systems :-)
>
> The reason that I mention the concept of a dynamic object is that  
> more and more location information is going to be measured using  
> mobile assets, such as the next generation sensor enable vehicle  
> and the national roadside sensor network. There are a variety of  
> application - and payload - implications related to the availability
>
> An instance of a procedure to estimate the value of a natural  
> phenomenon, typically involving an instrument or sensor. This is  
> implemented as a dynamic feature type, which has a property  
> containing the result of the measurement. The measurement feature  
> also has a location, time, and reference to the method used to  
> determine the value. A measurement feature effectively binds a  
> value to a location and to a method or instrument.
>
> > I took a look at the GMLv3 specification again and noticed that I  
> did not get the term from there. Good question where it came from  
> given that it was not in the -00 version of the document.
> >