Subject: [Geopriv] LIS vs. LCP Terminology: Summary

From: Hannes Tschofenig <[email-masked]>
Date: Mon, 20 Aug 2007 17:46:05 +0200

I went through the responses to my mail:

* "I don't like LCP": James Winterbottom & Martin Dawson

* "I don't care":  Most folks in the group

* "Other terms:" Guy Caron also suggested new terms, namely Location 
Acquisition Protocol (LAP) or Location Delivery Protocol (LDP)

Roger argues that the term has to be clearly defined since there was 
some confusion already in the past with fuzzy LIS terminology used in NENA.

Brian mentioned that NENA is currently cleaning up to clarify their 
terminology. Any outcome already?

I guess I will change the term to LIS and we are all happy. Right?

Ciao
Hannes

Hannes Tschofenig wrote:
> I would like to complete the work on 
> http://www.ietf.org/internet-drafts/draft-ietf-geopriv-l7-lcp-ps-03.txt
>
> I noticed that some people are still unhappy with the terminology.
>
> So, could those people please indicate what terms should be changed.
>
> Ciao
> Hannes
>
>
> _______________________________________________
> Geopriv mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/geopriv

_______________________________________________
Geopriv mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/geopriv

---

From: "Brian Rosen" <[email-masked]>
Date: Mon, 20 Aug 2007 11:54:05 -0400

NENA has agreed on the following definition of a LIS:
A Location Information Server (LIS) is a functional entity that provides
locations of endpoints.  A LIS can provide Location-by-Reference, or
Location-by-Value, and, if the latter, in geo or civic forms.  A LIS can be
queried by an endpoint for its own location, or by another entity for the
location of an endpoint.  In either case, the LIS receives a unique
identifier that represents the endpoint, for example an IP address,
circuit-ID or MAC address, and returns the location (value or reference)
associated with that identifier.  The LIS is also the entity that provides
the dereferencing service, exchanging a location reference for a location
value.

> -----Original Message-----
> From: Hannes Tschofenig [mailto:[email-masked]]
> Sent: Monday, August 20, 2007 11:46 AM
> To: GEOPRIV
> Subject: [Geopriv] LIS vs. LCP Terminology: Summary
>

---

From: "Roger Marshall" <[email-masked]>
Date: Mon, 20 Aug 2007 09:13:15 -0700

I've got no problems with this definition.

-roger marshall. 

> From: Brian Rosen [mailto:[email-masked]] 
> Sent: Monday, August 20, 2007 8:54 AM
> To: 'Hannes Tschofenig'; 'GEOPRIV'
> Subject: RE: [Geopriv] LIS vs. LCP Terminology: Summary
> 
> A Location Information Server (LIS) is a functional entity 
> that provides locations of endpoints.  A LIS can provide 
> Location-by-Reference, or Location-by-Value, and, if the 
> latter, in geo or civic forms.  A LIS can be queried by an 
> endpoint for its own location, or by another entity for the 
> location of an endpoint.  In either case, the LIS receives a 
> unique identifier that represents the endpoint, for example 
> an IP address, circuit-ID or MAC address, and returns the 
> location (value or reference) associated with that 
> identifier.  The LIS is also the entity that provides the 
> dereferencing service, exchanging a location reference for a 
> location value.
> 
> 
> > some confusion already in the past with fuzzy LIS 
> terminology used in 
> > NENA.
> > 

The information contained in this message may be privileged and/or confidential. If you are not the intended recipient, or responsible for delivering this message to the intended recipient, any review, forwarding, dissemination, distribution or copying of this communication or any attachment(s) is strictly prohibited. If you have received this message in error, please so notify the sender immediately, and delete it and all attachments from your computer and network.