Subject: [Geopriv] Updating the GEOPRIV milestones

From: Robert Sparks <[email-masked]>
Date: Thu, 27 Sep 2007 18:19:50 -0500

Folks -

GEOPRIVs chartered milestone list needs to be updated to reflect what  
we as a group believe we can achieve.
That's going to involve resetting or replacing all the milestones  
that are not marked "Done" on the current charter page.

Here's my proposal for the set of goals we set for ourselves  
initially, and the list of those I know about that might be good
goals to add as these complete. The dates and hence order here are  
only strawmen.

Oct 2007	Submit Additional Civic PIDF-LO types (updating 4119) to the  
IESG for publication as PS (see postscript below)
Oct 2007	Resubmit Conveying Location Objects in RADIUS and Diameter  
to the IESG for publication as PS
Nov 2007	Resubmit Geolocation Policy to the IESG for publication as PS
Dec 2007	Submit Layer 7 Location Conveyance Protocol Problem  
Statement and Requirements to the IESG for publication as Informational
Dec 2007	Submit Requirements for Location by Reference Protocols to  
the IESG for publication as Informational
Jan 2007	Submit PIDF-LO Usage Clarifications and Recommendations  
(updating 4119) to the IESG for publication as PS
Feb 2007	Submit minimal HTTP based protocol satisfying baseline  
requirements specified in the Layer 7 Location Conveyance Protocol  
Problem Statement and Requirements to the IESG for publication as PS

Once we start knocking those down, we could shift our focus to  
address (in no particular order)
* Location by Reference dereferencing mechanisms
* Carrying Location by Reference in DHCP
* Extending the HTTP location conveyance protocol
* Finishing the binary-lci/3825bis discussions (does this need to be  
earlier?)
* LIS Discovery
* Location Signing
* Finishing the Location Filters work

So, please respond on-list answering these questions:

1) What did I miss?

2) What should those milestone dates really be?

3) Is there anything here we should agree NOT to do?

Thanks,

RjS

_______________________________________________
Geopriv mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/geopriv

---

From: "Winterbottom, James" <[email-masked]>
Date: Thu, 27 Sep 2007 18:28:59 -0500

Hi Robert,

I think that we need to have LIS Discovery and HELD at about the same
time.

We also have:

HTTP/HELD dereference protocol and LIS to LIS requirements, or do you
see these as HELD extensions?

Cheers
James

PS LCP is location configuration protocol.. ;)

> -----Original Message-----
> From: Robert Sparks [mailto:[email-masked]]
> Sent: Friday, 28 September 2007 9:20 AM
> To: GEOPRIV
> Subject: [Geopriv] Updating the GEOPRIV milestones
> 
> Folks -
> 

------------------------------------------------------------------------------------------------
This message is for the designated recipient only and may
contain privileged, proprietary, or otherwise private information.  
If you have received it in error, please notify the sender
immediately and delete the original.  Any unauthorized use of
this email is prohibited.
------------------------------------------------------------------------------------------------
[mf2]

---

From: "Hannes Tschofenig" <[email-masked]>
Date: Fri, 28 Sep 2007 09:41:24 +0200

Hi Robert, 

I am fine with the proposed milestones (even though you drop some of the current items from the charter).

Only a few minor comments:

* Revised Civic: I thought that this document was sent the IESG a long time ago. In fact the tracker indicates that this document is already in IESG processing.

* LIS discovery: We cannot delay this item; This is extremely important for the document and should be sent to the IESG at the same time as the base HELD specification is sent to the IESG.

* draft-ietf-geopriv-loc-filters: I thought that this document reached a status in the working group so that it could be sent to the IESG immediately.

The list of items that can be done once the listed items are finished can obviously be extended. But that's probably not that important right now.

I believe the listed milestones are realistic. 

Ciao
Hannes

-------- Original-Nachricht --------
> Datum: Thu, 27 Sep 2007 18:19:50 -0500
> Von: Robert Sparks <[email-masked]>
> An: GEOPRIV <[email-masked]>
> Betreff: [Geopriv] Updating the GEOPRIV milestones

---

From: "Hannes Tschofenig" <[email-masked]>
Date: Fri, 28 Sep 2007 09:43:13 +0200

Hi James, Hi Robert, 

> see these as HELD extensions?

that's a good point. I believe we need to have the dereferencing part in place since otherwise the location-by-reference story is a bit questionable (at least for HTTP).

Ciao
Hannes

---

From: Salvatore Loreto <[email-masked]>
Date: Fri, 28 Sep 2007 14:37:36 +0300

I think Hannes is right, the draft-ietf-geopriv-loc-filters require a
very few effort to be finished, so I think it should worth to keep it.

Sal

---

From: "Hannes Tschofenig" <[email-masked]>
Date: Fri, 28 Sep 2007 14:45:30 +0200

I would even argue that there are no known open issues with the document.
Let's ship it. 

-------- Original-Nachricht --------
> Datum: Fri, 28 Sep 2007 14:37:36 +0300
> Von: Salvatore Loreto <[email-masked]>
> An: Hannes Tschofenig <[email-masked]>
> CC: Robert Sparks <[email-masked]>, [email-masked]
> Betreff: Re: [Geopriv] Updating the GEOPRIV milestones

> > * Revised Civic: I thought that this document was sent the IESG a long
> time ago. In fact the tracker indicates that this document is already in
> IESG processing.
> > 
> > * LIS discovery: We cannot delay this item; This is extremely important
> for the document and should be sent to the IESG at the same time as the
> base HELD specification is sent to the IESG.
> > 
> > * draft-ietf-geopriv-loc-filters: I thought that this document reached a
> status in the working group so that it could be sent to the IESG
> immediately.
> > 
> > The list of items that can be done once the listed items are finished
> can obviously be extended. But that's probably not that important right now.
> >

---

From: Salvatore Loreto <[email-masked]>
Date: Fri, 28 Sep 2007 15:58:11 +0300

for example, "speed" is not defined as PIDF-LO element 
(draft-singh-geopriv-pidf-lo-dynamic-01.txt suggests adding this, but it
is expired).

Maybe we can let this draft as it is, but we should define speed as
PIDF-LO element.

---

From: "Hannes Tschofenig" <[email-masked]>
Date: Fri, 28 Sep 2007 15:20:01 +0200

I am actually going to re-submit draft-singh-geopriv-pidf-lo-dynamic.

You are right. We might want to remove speed from draft-ietf-geopriv-loc-filters since it will take some time for draft-singh-geopriv-pidf-lo-dynamic to become RFC.

Ciao
Hannes

-------- Original-Nachricht --------
> Datum: Fri, 28 Sep 2007 15:58:11 +0300
> CC: [email-masked], [email-masked]

> > > > I am fine with the proposed milestones (even though you drop some of
> the
> > > current items from the charter).
> > > >

---

From: Robert Sparks <[email-masked]>
Date: Fri, 28 Sep 2007 08:58:20 -0500

On Sep 28, 2007, at 2:41 AM, Hannes Tschofenig wrote:

> * Revised Civic: I thought that this document was sent the IESG a  
> long time ago. In fact the tracker indicates that this document is  
> already in IESG processing.

Well - I intended to explain that in the first message, but I see I  
didn't attach the postscript I called out next to this item.
It should have said:

ps: revised-civic-lo is mostly already submitted - I'll be putting  
together a PROTO writeup around it for the group to double-check,  
then this milestone will be complete.

RjS

---

From: "Hannes Tschofenig" <[email-masked]>
Date: Fri, 28 Sep 2007 16:26:48 +0200

> then this milestone will be complete.

... and that's something I am curious about. Typically, the PROTO writeup is attached to the draft that leaves the working group after a successful WGLC. So, that should have been done already a long time ago.

What went wrong?

---

From: Robert Sparks <[email-masked]>
Date: Fri, 28 Sep 2007 09:35:57 -0500

On Sep 28, 2007, at 9:26 AM, Hannes Tschofenig wrote:

> ... and that's something I am curious about. Typically, the PROTO  
> writeup is attached to the draft that leaves the working group  
> after a successful WGLC. So, that should have been done already a  
> long time ago.
>
> What went wrong?
>

Agreed it should have been around, but its not. This is an isolated  
incident and is fairly straightforward to correct.

RjS