Subject: Fw: [Geopriv] DISCUSS on draft-ietf-geopriv-policy (Russ Housley)

From: "Carl Reed OGC Account" <[email-masked]>
Date: Wed, 26 Sep 2007 10:18:31 -0600

Sent this yesterday but the mail was too large. Trying again without the diagram. If anyone wishes to see the UML diagram for GM_Polygon, let me know and I can email separately.

Regards

Carl

----- Original Message ----- 
From: Carl Reed OGC Account 
To: Thomson, Martin ; Hannes Tschofenig ; GEOPRIV 
Cc: Russ Housley 
Sent: Tuesday, September 25, 2007 7:16 PM
Subject: Re: [Geopriv] DISCUSS on draft-ietf-geopriv-policy (Russ Housley)

Martin -

This is good guidance.

Just to put things in context, the GML Polygon element is fairly comprehensive. The abstract definition is documented in ISO 19107. To wit:
6.4.36 GM_Polygon

6.4.36.1 Semantics

A GM_Polygon (Figure 21) is a surface patch that is defined by a set of boundary curves and an underlying surface to which these curves adhere. The default is that the curves are coplanar and the polygon uses planar interpolation in its interior.

This definition is so comprehensive because there are many, many ways to define a polygonal surface (both 2d and 3d). Simple coordinate lists are the most elemental and primitive method of defining a polygon. This method is what is used in the GML PIDF-LO application schema. I guess that it should be noted that if we ever need to add additional methods for defining a polygon, additional GML elements are available!

And if one considers the UML diagram for GM_Polygon (below), it is definitely best to be very clear what semantics we are using for polygon in PIDF-LO :-)

Cheers

Carl

----- Original Message ----- 
From: "Thomson, Martin" <[email-masked]>
To: "Hannes Tschofenig" <[email-masked]>; "GEOPRIV" <[email-masked]>
Cc: "Russ Housley" <[email-masked]>
Sent: Tuesday, September 25, 2007 5:57 PM
Subject: RE: [Geopriv] DISCUSS on draft-ietf-geopriv-policy (Russ Housley)

> On the second comment only ('though I agree with the first)...
> 
>> "
>>   Consider a the four corners of Colorado.  (Colorado is a rectangle.)
>>   Call the northeast corner A.  Call the northwest corner B.  Call the
>>   southwest corner C.  Call the southeast corner D.  It is pretty clear
>>   that ABCDA is a valid polygon.  Is ACBDA a valid polygon?  I do not
>>   see text that would tell me that such a polygon is not allowed, but
>>   such text could be in EPSG 4326 or EPSG 4979.  I did not go look.  I
>>   have writen algorithms to find a polygon that includes all of the
>>   provided coordinates, but that does not seem like the right thing
>>   to do here.
>> 
> <snip formula (first comment?)>
>> "
> 
> Good pick-up.
> 
> I think that it would be a good idea to reference pidf-lo-profile for rules on polygon construction.  I believe that the text here is cloned to avoid a dependency problem.  A reference would avoid this problem.
> 
> Here is what pdif-lo-profile (sic) says:
> 
> "
>   A connecting line SHALL NOT cross another connecting line of the same
>   Polygon.
> 
>   Polygons SHOULD be defined with the upward normal pointing up, this
>   is accomplished by defining the vertices in counter-clockwise
>   direction.
> 
>   Points specified in a polygon MUST be coplanar, and it is RECOMMENDED
>   that where points are specified in 3 dimensions that all points
>   maintain the same altitude.
> "
> 
> Making the same altitude restriction mandatory is the only difference I can see here.
> 
> Regards,
> Martin
> 
> p.s. By pdif-lo-profile, ADCBA isn't recommended either because it is in clockwise order.
> 
> 
> ------------------------------------------------------------------------------------------------
> This message is for the designated recipient only and may
> contain privileged, proprietary, or otherwise private information.  
> If you have received it in error, please notify the sender
> immediately and delete the original.  Any unauthorized use of
> this email is prohibited.
> ------------------------------------------------------------------------------------------------
> [mf2]
> 

--------------------------------------------------------------------------------

> _______________________________________________
> Geopriv mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/geopriv
> 

_______________________________________________
Geopriv mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/geopriv

---

From: "Hannes Tschofenig" <[email-masked]>
Date: Wed, 26 Sep 2007 18:45:14 +0200

http://www.tschofenig.priv.at/TEMP/GM_Polygon.JPG

-------- Original-Nachricht --------
> Datum: Wed, 26 Sep 2007 10:18:31 -0600
> Von: "Carl Reed OGC Account" <[email-masked]>
> An: [email-masked]
> Betreff: Fw: [Geopriv] DISCUSS on draft-ietf-geopriv-policy (Russ Housley)

> Sent this yesterday but the mail was too large. Trying again without the
> diagram. If anyone wishes to see the UML diagram for GM_Polygon, let me know
> and I can email separately.
> 
> Regards
> 
> Carl
> 
> 
> Just to put things in context, the GML Polygon element is fairly
> comprehensive. The abstract definition is documented in ISO 19107. To wit:
> 6.4.36 GM_Polygon
> 
> 6.4.36.1 Semantics
> 
> A GM_Polygon (Figure 21) is a surface patch that is defined by a set of
> boundary curves and an underlying surface to which these curves adhere. The
> default is that the curves are coplanar and the polygon uses planar
> interpolation in its interior.
> 
> This definition is so comprehensive because there are many, many ways to
> define a polygonal surface (both 2d and 3d). Simple coordinate lists are the
> most elemental and primitive method of defining a polygon. This method is
> what is used in the GML PIDF-LO application schema. I guess that it should
> be noted that if we ever need to add additional methods for defining a
> polygon, additional GML elements are available!
> 
> And if one considers the UML diagram for GM_Polygon (below), it is
> definitely best to be very clear what semantics we are using for polygon in
> PIDF-LO :-)
> 
> Cheers
> 
> Carl
> 
> 
> 
> > I think that it would be a good idea to reference pidf-lo-profile for
> rules on polygon construction.  I believe that the text here is cloned to
> avoid a dependency problem.  A reference would avoid this problem.
> >