Subject: [Geopriv] Review of draft-ietf-geopriv-http-location-delivery-03.txt

From: Hannes Tschofenig <[email-masked]>
Date: Sat, 24 Nov 2007 12:21:19 +0100

I read through 
http://tools.ietf.org/id/draft-ietf-geopriv-http-location-delivery-03.txt

The document looks good!

A few minor issues below:

* I would use complete XML examples rather than snippets. It is fine to 
omit the HTTP part.

* What is the resolution regarding the RFC 3205 and the need to
  -- define a new URI scheme, and
 -- use a different port number
for HELD?

I believe we have to use a held: URI scheme at least for the 
dereferencing protocol. See
http://tools.ietf.org/wg/geopriv/draft-winterbottom-geopriv-deref-protocol-00.txt

The definition of it would, however, go into the main HELD document 
since the LbyRs are created by HELD.

Ciao
Hannes

_______________________________________________
Geopriv mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/geopriv

---

From: "Thomson, Martin" <[email-masked]>
Date: Sun, 25 Nov 2007 16:50:03 -0600

Hi Hannes,

Those ARE complete examples.  The XML prolog is not shown, but it is not required either.

Based on Lisa's comments, it would seem that a held: URI would be of some use.  I don't see the need to define a well known port.  You can see a codification of my opinion in the held-beep draft.

Cheers,
Martin

> -----Original Message-----
> From: Hannes Tschofenig [mailto:[email-masked]]
> Sent: Saturday, 24 November 2007 10:21 PM
> To: GEOPRIV
> Cc: Mary Barnes
> Subject: [Geopriv] Review of draft-ietf-geopriv-http-location-delivery-
> 03.txt
> 
> I read through

------------------------------------------------------------------------------------------------
This message is for the designated recipient only and may
contain privileged, proprietary, or otherwise private information.  
If you have received it in error, please notify the sender
immediately and delete the original.  Any unauthorized use of
this email is prohibited.
------------------------------------------------------------------------------------------------
[mf2]
_______________________________________________
Geopriv mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/geopriv

---

From: Hannes Tschofenig <[email-masked]>
Date: Mon, 26 Nov 2007 10:23:54 +0100

Hi Martin,

> Those ARE complete examples.  The XML prolog is not shown, but it is not required either.
Some of the examples have the XML prolog in the front and others don't.

> Based on Lisa's comments, it would seem that a held: URI would be of some use.
Fine.

>   I don't see the need to define a well known port.
Also fine for me.

>   You can see a codification of my opinion in the held-beep draft
>   

Haven't reached that part of my reading list yet.

Ciao
Hannes