Subject: [Geopriv] Why these OBO Discussions?

From: Hannes Tschofenig <[email-masked]>
Date: Tue, 27 Nov 2007 23:26:57 +0100

Hi all,

I really wonder why we have these discussions.
We have introduced the OBO concept already a long
time ago with SIP Location Conveyance. There is no
reason to be surprised that it is there (unless you have
not followed the work in the group for some time).

Is it possible to stop rehashing past decisions?

Ciao
Hannes

_______________________________________________
Geopriv mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/geopriv

---

From: "Dawson, Martin" <[email-masked]>
Date: Tue, 27 Nov 2007 16:32:08 -0600

I echo the sentiment that OBO is well-established, there are some
well-understood use-cases and there is a genuine need to formalize the
support for it.

Marc L appears to be insisting on some sort of formalization of the
imperative. So how do we satisfy Marc's desire so we can proceed with
the work constructively?

Cheers,
Martin

-----Original Message-----
From: Hannes Tschofenig [mailto:[email-masked]] 
Sent: Wednesday, 28 November 2007 9:27 AM
To: GEOPRIV
Subject: [Geopriv] Why these OBO Discussions? 

Hi all,

Ciao
Hannes

------------------------------------------------------------------------------------------------
This message is for the designated recipient only and may
contain privileged, proprietary, or otherwise private information.  
If you have received it in error, please notify the sender
immediately and delete the original.  Any unauthorized use of
this email is prohibited.
------------------------------------------------------------------------------------------------
[mf2]

---

From: "Marc Linsner" <[email-masked]>
Date: Tue, 27 Nov 2007 17:56:30 -0500

Hannes, 

> Is it possible to stop rehashing past decisions?

When was it decided how the proxy was going to discover the location OBO the
client?  What mechanism was choosen?

-Marc-

---

From: Hannes Tschofenig <[email-masked]>
Date: Wed, 28 Nov 2007 00:02:09 +0100

The specific mechanism was not decided. The fact that the proxy adds 
location was decided  a long time ago

---

From: "Brian Rosen" <[email-masked]>
Date: Tue, 27 Nov 2007 18:05:33 -0500

Why send the IP address of the client to the right LIS of course!
Works fine in the lab.

Also works in a mobile IMS system.

Brian

> From: Marc Linsner [mailto:[email-masked]]
> Sent: Tuesday, November 27, 2007 5:57 PM
> To: 'Hannes Tschofenig'; 'GEOPRIV'
> Subject: RE: [Geopriv] Why these OBO Discussions?
> 
> Hannes,
> 
>

---

From: Hannes Tschofenig <[email-masked]>
Date: Wed, 28 Nov 2007 00:06:34 +0100

This is essentially what the HELD Identity Extension does.

---

From: "Brian Rosen" <[email-masked]>
Date: Tue, 27 Nov 2007 18:17:53 -0500

Yes of course.  And I'm sure it works very well in a lab, and in a mobile
IMS environment (although they don't plan to use it in mobile IMS, they plan
to use SLP and MLP).

Brian

> Sent: Tuesday, November 27, 2007 6:07 PM
> To: Brian Rosen
> Cc: 'Marc Linsner'; 'GEOPRIV'
> Subject: Re: [Geopriv] Why these OBO Discussions?
> 
> >> When was it decided how the proxy was going to discover the location
> OBO
> >> the

---

From: Hannes Tschofenig <[email-masked]>
Date: Wed, 28 Nov 2007 00:43:19 +0100

What about an enterprise and DSL environment?

---

From: "Dawson, Martin" <[email-masked]>
Date: Tue, 27 Nov 2007 18:20:55 -0600

I don't get the "lab" comment. We could make the same comment about most
of the protocols and architectures we discuss.

As far as I know, though, you recognize the need for the OBO construct
and support a formalization of it?

Do we actually have a barrier to proceeding with the development?

Cheers,
Martin

-----Original Message-----
From: Brian Rosen [mailto:[email-masked]] 
Sent: Wednesday, 28 November 2007 10:18 AM
To: 'Hannes Tschofenig'
Cc: 'GEOPRIV'; 'Marc Linsner'
Subject: RE: [Geopriv] Why these OBO Discussions?

Yes of course.  And I'm sure it works very well in a lab, and in a
mobile
IMS environment (although they don't plan to use it in mobile IMS, they
plan
to use SLP and MLP).

Brian

---

From: "Brian Rosen" <[email-masked]>
Date: Tue, 27 Nov 2007 20:10:58 -0500

It definitely won't work in a DSL environment unless the proxy bans
nomading.  

I could work in an enterprise, but the deployment considerations are worse
than the HELD issues. Instead of just worrying about VPNs and NATs between
the access network and the LIS, it has to worry about them between the
access network and the proxy, which could be much more difficult.

OBO is a terrible idea made necessary for conversion.  I'd like it to be
possible, so we don't need an upgrade of endpoints before we can do
anything.  It fails badly (bad location instead of no location), just like
HELD.  We should say NOT RECOMMENDED and then talk about upgrades issues.

> Sent: Tuesday, November 27, 2007 6:43 PM
> To: Brian Rosen

---

From: "Winterbottom, James" <[email-masked]>
Date: Tue, 27 Nov 2007 20:11:02 -0600

But you agree that in the 95% case, where the SIP proxy knows that IP
address belongs to its ISP pool that it will work just fine?

> Sent: Wednesday, 28 November 2007 12:11 PM
> To: 'Hannes Tschofenig'