Subject: [Geopriv] New Version Notification for draft-busin-geopriv-location-qos-req-01

From: Salvatore Loreto <[email-masked]>
Date: Tue, 20 Nov 2007 11:08:47 +0200

Hi there,

we have released a new version of the location-qos-req draft.
http://tools.ietf.org/wg/geopriv/draft-busin-geopriv-location-qos-req-01.txt

thanks for all the comments.
we have tried to address all your doubts and suggestions, clarifying the
scope of the draft, the reason for it and the goals we want achieve.

To summarize the idea behind this draft and what we want to achieve :

- we think that should be useful to have the possibility to insert a
Location QoS in a LPC or LDP request.

- The purpose of Location QoS Information is "for expressing the
  required level of Location QoS":
  In this way:
  - The recipient will not receive Location Information
    that it is useless to him.
  - The presence of QoS in a request allows Location Server to decide which source (or technique)
    for location/position determination to use.

- we don't think there is the need to expand the PIDF-LO to include the transport of the Location QoS achieved.
Moreover the achieved QoS is already implied in the PIDF-LO - accuracy with size of the shape, age with the 
timestamp element, the response time can be calculated on the client/recipient. 

Feedback and comments are welcome on list or privately to the authors.

best regards
Sal

-------- Forwarded Message --------

A new version of I-D, draft-busin-geopriv-location-qos-req-01.txt has been successfuly submitted by Salvatore Loreto and posted to the IETF repository.

Filename:	 draft-busin-geopriv-location-qos-req
Revision:	 01
Title:		 Requirements for a Location Quality of Service (QoS) Information Object
Creation_date:	 2007-11-19
WG ID:		 Independent Submission
Number_of_pages: 11

Abstract:
This document describes requirements for Location Quality of Service
(QoS) Information that may be carried both in the Geopriv Layer 7
Location Configuration Protocol (L7 LPC) and in the Location
Dereference Protocol (LDP) requests.  The Location QoS Information is
used for expressing the required or desired level of quality,
accuracy, response time, and age of requested Location Information.
The resulting Location Information is conveyed in existing location
formats wrapped in GEOPRIV privacy extensions to the Presence
Information Document Format (PIDF-LO) [RFC4119].

The IETF Secretariat.

_______________________________________________
Geopriv mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/geopriv

---

From: Salvatore Loreto <[email-masked]>
Date: Wed, 21 Nov 2007 22:14:51 +0200

Hi there,

I fully understand that there is no time to discuss all the drafts
during the f2f meeting, and that this draft needs to be discuss more in
deep

However I want highlight the fact that the Location QoS draft foresee
the necessity to insert in both LPC and LDP requests. 
So as in the agenda there is the "GEOPRIV Layer 7 Location Configuration
Protocol; Problem Statement and Requirements" draft,

I do believe it should be useful discuss about the opportunity to insert
some Location QoS also directly in the LPC requirements draft.

thank
Sal