Subject: [Geopriv] Draft about "Specifying a Circular Uncertainty Area Using DHCP"

From: Hannes Tschofenig <[email-masked]>
Date: Mon, 18 Feb 2008 18:15:42 +0200

Hi all,

as mentioned last week I saw some value in investigating an approach for 
specifying a circular uncertainty area using DHCP. Here is the document:
http://www.ietf.org/internet-drafts/draft-tschofenig-geopriv-dhcp-circle-00.txt

I hope that such a document does not turn the group into chaos again and 
folks instead use it as a (more detailed) contribution about what I call 
"a good way forward".

Nevertheless, I believe that we should run a survey among implementers 
and operators to learn
* what they implemented
* how they use it.
I said that already and I believe that this would be the ideal way 
forward. It would obviously be quite time consuming and would have to be 
done by a bunch of people working together. My early investigations gave 
me the impression that practical usages in WLAN environments would 
benefit from the ability to return a point with an uncertainty circle.

Ciao
Hannes

PS: James helped me a lot with the document. Thanks to him!

_______________________________________________
Geopriv mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/geopriv

---

From: "Marc Linsner" <[email-masked]>
Date: Mon, 18 Feb 2008 13:29:29 -0500

Hannes/James,

WRT to your opening statement in this draft:

"
   Location provided by GPS device and like generally provide location
   information as a point with a degree of uncertainty.  This
   uncertainty is more often than not expressed as an offset in metres
   from the central point, with the resulting location being a circle
   when expressed in 2 dimensions, and a sphere when expressed in 3
   dimensions.
"

Below are the NMEA 0183 v 3.01 protocol statements.  Which statements are
used by the GPS to convey the uncertainty you claim in the above statement?
In what form is this uncertainty data?

    * AAM - Waypoint Arrival Alarm
    * ALM - Almanac data
    * APA - Auto Pilot A sentence
    * APB - Auto Pilot B sentence
    * BOD - Bearing Origin to Destination
    * BWC - Bearing using Great Circle route
    * DTM - Datum being used.
    * GGA - Fix information
    * GLL - Lat/Lon data
    * GRS - GPS Range Residuals
    * GSA - Overall Satellite data
    * GST - GPS Pseudorange Noise Statistics
    * GSV - Detailed Satellite data
    * MSK - send control for a beacon receiver
    * MSS - Beacon receiver status information.
    * RMA - recommended Loran data
    * RMB - recommended navigation data for gps
    * RMC - recommended minimum data for gps
    * RTE - route message
    * TRF - Transit Fix Data
    * STN - Multiple Data ID
    * VBW - dual Ground / Water Spped
    * VTG - Vector track an Speed over the Ground
    * WCV - Waypoint closure velocity (Velocity Made Good)
    * WPL - Waypoint Location information
    * XTC - cross track error
    * XTE - measured cross track error
    * ZTG - Zulu (UTC) time and time to go (to destination)
    * ZDA - Date and Time

-Marc-