Subject: [Geopriv] SIP Location Conveyance ??

From: Hannes Tschofenig <[email-masked]>
Date: Sun, 30 Mar 2008 10:57:20 +0300

When are we going to see a new version of SIP Location Conveyance that 
addresses the issues raised in 
http://tools.ietf.org/id/draft-peterson-geopriv-retransmission-00.txt?

There is a dependency from ECRIT Framework/Phone BCP on SIP Location 
Conveyance and hence it would be nice to get things going already now; 
no reason to wait for the next draft submission deadline.

Ciao
Hannes

_______________________________________________
Geopriv mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/geopriv

---

From: "James M. Polk" <[email-masked]>
Date: Sun, 30 Mar 2008 04:20:20 -0500

>http://tools.ietf.org/id/draft-peterson-geopriv-retransmission-00.txt?

has there been any consensus call for this?

answer -> no

This is still an individual submission. Is this going to progress (at 
all), as an individual, or as a Geopriv WG item?

For that matter, has there been an effective summary of what was 
discussed in the hallway in Philly as a proposed solution -> that the 
WG has agreed upon <-

no, I have not seen that on any list

Conveyance cannot move until Geopriv agrees what should happen

Once this agreement is reached in Geopriv, the SIP WG gets their say 
in the matter *because* what the peterson ID suggests (that needs to 
be changed at least a little bit) is to modify a SIP header parameter 
-- which the SIP WG needs to agree to...

---

From: Hannes Tschofenig <[email-masked]>
Date: Sun, 30 Mar 2008 16:03:44 +0300

Hi James,

I don't want to get things stalled just because nobody knows who is 
going todo the next step.
I also don't want to stall things because there is this interaction 
between 2 working groups. Given that only a small number of people 
really care about the content and those are the same people that 
participate in SIP and in GEOPRIV I don't see a need to make this more 
complicated than it is.

So, who is responsible for doing a writeup on the discussed issue? Then, 
Robert can determine whether there is consensus in the group.

Ciao
Hannes

PS: During the GEOPRIV meeting I got the impression that there was some 
interest in addressing the issue as proposed by Jon.

---

From: "Brian Rosen" <[email-masked]>
Date: Sun, 30 Mar 2008 15:02:23 -0400

But there was indeed a subsequent hallway conversation, which did move the
concepts forward.  I think James is correct that the hallway conversation
has to be turned into text, and the text confirmed as working group
consensus.  I suspect that is a sip consensus with geopriv having some say.

It wouldn't bother me if -conveyance was the mechanism for text proposals.
I think we might put revised -conveyance text on the list for comment (not a
new version yet).  That would be as opposed to a new version of Jon's draft.
I'd like someone else to summarize the hallway conversation, and then James
and I can write up some new -conveyance text and put just that text on the
list, and then call for consensus on that.  Barring any complications, we
can include that in the next -conveyence rev.

Brian

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Hannes Tschofenig
Sent: Sunday, March 30, 2008 9:04 AM
To: James M. Polk
Cc: GEOPRIV
Subject: Re: [Geopriv] SIP Location Conveyance ??

Hi James,

Ciao
Hannes

---

From: Hannes Tschofenig <[email-masked]>
Date: Sun, 30 Mar 2008 23:01:24 +0300

So, who can summarize the hallway conversation?

---

From: "DRAGE, Keith \(Keith\)" <[email-masked]>
Date: Mon, 31 Mar 2008 00:09:28 +0200

The responsibility is that of the GEOPRIV group.

This is what we agreed in SIP:

"Impact of draft-peterson-geopriv-retransmission-00.txt
We expect a set of requirements relating to "routeing handling" from the
GEOPRIV WG representing consensus of that WG on this issue
If and when we receive those requirements the editor's of
draft-ietf-sip-location-conveyance will change our document
If there is informational material in the above draft that people
consider would be usefully represented in
draft-ietf-sip-location-conveyance, then make a comment against the
document to the SIP WG list in the normal manner" 

i.e. GEOPRIV must make a consensus decision on what the requirement is.

We don't yet have that, so SIP waits.

I believe you can get the rest of the story from the GEOPRIV group.

Regards

Keith

> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Hannes Tschofenig
> Sent: Sunday, March 30, 2008 2:04 PM
> To: James M. Polk
> Cc: GEOPRIV
> I don't want to get things stalled just because nobody knows 
> who is going todo the next step.
> I also don't want to stall things because there is this 
> interaction between 2 working groups. Given that only a small 
> number of people really care about the content and those are 
> the same people that participate in SIP and in GEOPRIV I 
> don't see a need to make this more complicated than it is.
> 
> So, who is responsible for doing a writeup on the discussed 
> issue? Then, Robert can determine whether there is consensus 
> in the group.
> 
> Ciao
> Hannes
> 
> PS: During the GEOPRIV meeting I got the impression that 
> there was some interest in addressing the issue as proposed by Jon.
> 
> 
> James M. Polk wrote:

---

From: "DRAGE, Keith \(Keith\)" <[email-masked]>
Date: Mon, 31 Mar 2008 01:07:50 +0200

This has gone round in circles often enough that I want GEOPRIV to make,
and document, a consensus call on the way forward.

That can either be via a WG draft with consensus support, or a call on
the GEOPRIV mailing list, but it has got to happen.

We do not touch it in SIP until that occurs. 

The text in conveyance already represents a prior SIP WG decision. 

Regards

Keith

> [mailto:[email-masked]] On Behalf Of Brian Rosen
> Sent: Sunday, March 30, 2008 8:02 PM
> To: 'Hannes Tschofenig'; 'James M. Polk'
> Cc: 'GEOPRIV'
> But there was indeed a subsequent hallway conversation, which 
> did move the concepts forward.  I think James is correct that 
> the hallway conversation has to be turned into text, and the 
> text confirmed as working group consensus.  I suspect that is 
> a sip consensus with geopriv having some say.
> 
> I think we might put revised -conveyance text on the list for 
> comment (not a new version yet).  That would be as opposed to 
> a new version of Jon's draft.
> I'd like someone else to summarize the hallway conversation, 
> and then James and I can write up some new -conveyance text 
> and put just that text on the list, and then call for 
> consensus on that.  Barring any complications, we can include 
> that in the next -conveyence rev.
> 
> Brian
>