Subject: Re: [Geopriv] building GML in PIDF

From: "Marc Berryman" <[email-masked]>
Date: Sun, 2 Mar 2008 16:17:40 -0600

3825 is conveying a point not an area nor an arc defined by ebdpoints

I don't think fat points will go over too well and I am sticking with significant digits do matter

Seem we are at an impass unless we go with Brians ideal of sending what we have

Regards,

Marc Berryman

Sent from my BlackBerry

----- Original Message -----
From: [email-masked] <[email-masked]>
To: Hannes Tschofenig <[email-masked]>; Brian Rosen <[email-masked]>
Cc: GEOPRIV <[email-masked]>; Robert Sparks <[email-masked]>
Sent: Sun Mar 02 08:15:50 2008
Subject: Re: [Geopriv] building GML in PIDF

I believe that the correct interpretation on receipt of a point is that
it is an indicative location. There definitely is uncertainty, but the
uncertainty has not been communicated.

All other shapes actually communicate a quantified value of uncertainty.

You can see from my discussion with Cullen on the lci-binary thread that
I think 3825 was only designed for communicating a point; he feels it
was designed for communicating specific rectangular areas of uncertainty
albeit in a somewhat limited way. I want 3825 to be explicit about what
it's communicating so that there is no miscommunication once it's
encoded in GML.

Cheers,
Martin

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Hannes Tschofenig
Sent: Sunday, 2 March 2008 6:37 AM
To: Brian Rosen
Cc: 'GEOPRIV'; 'Robert Sparks'
Subject: Re: [Geopriv] building GML in PIDF

Brian,

I would appreciate if we are more specific in this discussion.

I receive a PIDF-LO with geodetic location of a point. I have no idea 
how the Target got that information.
So, what does it mean?

Here is a practical example. I receive the following PIDF-LO:

    <?xml version="1.0" encoding="UTF-8"?>
     <presence xmlns="urn:ietf:params:xml:ns:pidf"
         xmlns:dm="urn:ietf:params:xml:ns:pidf:data-model"
         xmlns:gp="urn:ietf:params:xml:ns:pidf:geopriv10"
         xmlns:gml="http://www.opengis.net/gml"
         xmlns:cl="urn:ietf:params:xml:ns:pidf:geopriv10:civicAddr"
         entity="pres:[email-masked]">
       <dm:device id="mikepc">
         <status>
           <gp:geopriv>
             <gp:location-info>
               <gml:Point srsName="urn:ogc:def:crs:EPSG::4326">
                 <gml:pos>38.8986 -77.037</gml:pos>
               </gml:Point>
             </gp:location-info>
             <gp:usage-rules/>
             <method>Wiremap</method>
           </gp:geopriv>
         </status>
         <timestamp>2007-06-22T20:57:29Z</timestamp>
         <dm:deviceID>mac:8asd7d7d70cf</dm:deviceID>
       </dm:device>
     </presence>

What does it mean?

Ciao
Hannes

Brian Rosen wrote:
> I see the res data in 3825 as a method to express significant digits
in the
> coordinates of a point.  I do NOT think they are meta data.
>
> I understand your reservation, but when dealing with reality, it's
best to
> go with the flow.  Marc has pointed out a basic truism: despite the
> geodist's preference for expressing precision/error with confidence
and
> uncertainty, many devices only report a coordinate pair.  Some of them
use
> significant digits, others don't.  Our protocol does not define
location
> determination, and it doesn't define location use.  It's only a
mechanism to
> move the location from the LIS to the endpoint.  I think it should be
> transparent - transport whatever the determination mechanism came up
with.
>
> We always make choices, and thus we don't usually achieve the ideal.
In
> this case, the original choice (ignore confidence and uncertainty,
only send
> significant digits) was, I think, too limiting.  I think we should add
the
> ability to send confidence and uncertainty.  
>
> Actually, I'm kind of unhappy with just that, but I do think it's
right
> anyway.  My unhappiness is that many devices give you an error which,
I
> believe, really is close to Gaussian error distribution.  Confidence
and
> uncertainty don't let you express that: the actual location is equally
> likely anywhere in the uncertainty region.  Of course equal
probability
> distribution encompasses Gaussian, but I do regret not being able to
express
> Gaussian (which is, after all, the way most error is expressed).
Henning
> has pointed that out several times, and my understanding of actual GPS
error
> sources seems to indicate that the reality is that GPS error is fairly
close
> to Gaussian: the center point IS more likely to be right than the
edges of
> the uncertainty region.
>
> But then the mobile guys come along, and for various reasons, even if
they
> use GPS, their actual measured results are NOT Gaussian distributed;
they
> really are happy with equal probability.  If you look at the
literature, it
> really does seem to say equal probability distribution is the expected
way
> to express error.  
>
> So, I think we should carry confidence and uncertainty in all the
LCPs.
>
> Brian
>
>
>   
>> -----Original Message-----
>> From: Cullen Jennings [mailto:[email-masked]]
>> Sent: Saturday, March 01, 2008 1:05 PM
>> To: Brian Rosen
>> Cc: Winterbottom, James; GEOPRIV; Robert Sparks
>> Subject: Re: [Geopriv] building GML in PIDF
>>
>>
>> On Mar 1, 2008, at 7:13 AM, Brian Rosen wrote:
>>
>>     
>>> I think we should not be implying anything with significant digits,
>>> and I
>>> don't think we should be ignoring them.
>>>
>>>       
>> I have to tease you a little about this. I worried about an
>> interoperable standard that says where we say, hey these bits are
>> important, don't ignore them, but I refuse to tell you what they mean
>> or what you might do with them.
>>
>> But on a more serious note, do you see the res parameters in 3825 as
>> meta data about the point or do you think of the meta data as
>> something else?
>>
>>
>> Cullen <with my individual contributor hat on>
>>     
>
>
> _______________________________________________
> Geopriv mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/geopriv
>   

_______________________________________________
Geopriv mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/geopriv

------------------------------------------------------------------------------------------------
This message is for the designated recipient only and may
contain privileged, proprietary, or otherwise private information.  
If you have received it in error, please notify the sender
immediately and delete the original.  Any unauthorized use of
this email is prohibited.
------------------------------------------------------------------------------------------------
[mf2]

_______________________________________________
Geopriv mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/geopriv

_______________________________________________
Geopriv mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/geopriv

---

From: "Winterbottom, James" <[email-masked]>
Date: Sun, 2 Mar 2008 16:36:11 -0600

Allow me to ask a question then Marc.

What do significant digits actually mean then, and what are they useful
for?

Cheers
James

> From: [email-masked] [mailto:[email-masked]] On
Behalf
> Of Marc Berryman
> Sent: Monday, 3 March 2008 9:18 AM
> To: Dawson, Martin; [email-masked]; [email-masked]
> Cc: [email-masked]; [email-masked]
> Seem we are at an impass unless we go with Brians ideal of sending
what we
> have
------------------------------------------------------------------------
--
> ----------------------
------------------------------------------------------------------------
--
> ----------------------

---

From: "Marc Berryman" <[email-masked]>
Date: Mon, 3 Mar 2008 07:18:56 -0600

James,
 I will start with my previous answer being that the last significant
digit "implies" a level of precession. From the e-mail dated 25 February
2008:

1 degree equals 69 statute miles 
1 degree equals 69 * 5280 = 364,320 feet 
0.1 degree equals 6.9 * 5280 = 36,432 feet 
0.01 degree equals 		3,643.2 feet 
0.001 degree equals 	364.32 feet 
0.0001 degree equals 	36.432 feet 
0.00001 degree equals 	3.6432 feet 
Accuracy is +/- 1 of the last significant digit so we can build the
following table 

Decimal degree accuracy 
1 +/- 	364,320 feet 
0.1 		36,420 feet 
0.01 	3,642 feet 
0.001 	364.2 feet 
0.0001 	36.42 feet 
0.00001 	3.6432 feet

Now let me carry this line of reasoning a bit further.

Significant digits are the minimum number of digits required to report a
value without loss of accuracy. Significant figures are used when
recording a measurement so that it does not appear to be more accurate
than the equipment is capable of determining. While it is possible to
calculate a location with a great amount of apparent precision, the
actual precision is dependent of the equipment being used to make the
determination. 0.700 has three significant figures so it has an apparent
precision of +/- 364.2 feet if we are considering decimal degrees. To
get down to the millimeter level of precision you would need at least 7
significant digits.

This same concept is used by the US Federal Geographic Data Committee,
which publishes the US National Standards Spatial Data Infrastructure.

Getting back to the real issues is the value of geodetic coordinates
should only be given to the number of significant figures which is
indicative of the positional accuracy and is not more than the location
determination equipment is capable of providing.

Marc Berryman, ENP
Geographic Information Systems
Greater Harris County 9-1-1 Emergency Network
Houston, Texas  (713) 407-2254
[email-masked]

-----Original Message-----
From: Winterbottom, James [mailto:[email-masked]] 
Sent: Sunday, March 02, 2008 4:36 PM
To: Marc Berryman; Dawson, Martin; [email-masked];
[email-masked]
Cc: [email-masked]; [email-masked]
Subject: RE: [Geopriv] building GML in PIDF

Cheers
James

Behalf
what we

------------------------
------------------------
[mf2]

---

From: "Brian Rosen" <[email-masked]>
Date: Mon, 3 Mar 2008 14:45:24 -0500

Why do we have to define what they mean?

Why can't we just carry them along from the originating measuring device to
the consumer?

Brian

> Sent: Sunday, March 02, 2008 5:36 PM