Subject: Re: [Geopriv] GEOPRIV Experiment at IETF 71

From: "Karl Heinz Wolf" <[email-masked]>
Date: Fri, 4 Apr 2008 14:52:36 +0200

Hi Richard,

since I haven't been at the meeting, could you please tell me more
about the outcome of the GEOPRIV experiment?
I think it would be interesting to the list to know your experience
with the location determination.
I'll post a few questions that came to my mind and it would be great
to get an answer.
Any problems with the setup? Is NetDisco suitable? What about the SNMP
traffic caused by your setup? How often did you do the SNMP querries?
Did you collect data in advance or did you do the location
determination on demand? How many switches/access points did you
query? How many clients were in your database? How did you detect
changes/new clients in the network? How long did a location request
last?

Thanks in advance.

karl heinz

On Tue, Mar 11, 2008 at 5:26 AM, Richard Barnes <[email-masked]> wrote:
> Hi all,
>
>  Wanted to let folks know about an experiment that some participants from
>  the GEOPRIV working group have put together for this IETF.  Using the
>  IETF network infrastructure as a location source, we've set up a
>  location server [1] that offers location information over the HTTP-based
>  HELD protocol [2].  It works like this:
>
>  +--------+           +-----+           +---------------------+
>  | Client |---HELD----| LIS |-----------| IETF (NetDisco [3]) |
>  +--------+           +-----+           +---------------------+
>
>  1. Client submits HELD request
>  2. LIS queries NetDisco (over an ad-hoc interface) for location of an IP
>  3. NetDisco returns civicAddress XML for the AP to which the requested
>  IP is connected, e.g.:
>  <civicAddress
>     xmlns="urn:params:xml:ns:pidf:geopriv10:civicAddr">
>     <country>US</country>
>     <A1>Pennsylvania</A1>
>     <A3>Philadelphia</A3>
>     <A6>Market</A6>
>     <STS>Street</STS>
>     <HNO>1201</HNO>
>     <PC>19107</PC>
>     <ROOM>Franknlin 1/2</ROOM>
>  </civicAddress>
>  4. LIS inserts civicAddress into PIDF-LO into locationResponse and
>  returns to Client
>
>  The HELD server is written in PHP, and is based on the open-source HELD
>  LIS written by Andrew Co. [4].
>
>  We have two clients for you to try out:
>
>  1. I wrote a small Java application [5] that pulls location from the
>  HELD server and posts it as the status of a Jabber account.  For
>  instance, while I was in SIPPING this afternoon, my status was:
>  "
>  Current location:
>  Civic Address:
>  Franklin 1/2
>  1201 Market Street
>  Philadelphia, PA 19107
>  "
>  Note: This app runs *alongside* your usual Jabber client, as a separate
>  client, so you don't need to change anything about how you use Jabber.
>  Requires Java 1.6.
>
>  2. Along with the open-source LIS from Andrew Co, there's Java client
>  library and GUI that shows most of the features in
>  draft-ietf-geopriv-http-location-delivery-05, including the creation and
>  management of location references (URIs that refer to location).  You
>  can download it at [6] (Note: (1) you need to download both the client
>  library and the GUI; (2) requires Windows and Java 1.6.)
>
>  3. Karl Heinz Wolf from Nic.at has enhanced the Zap! SIP client so that
>  it will access location and send it out in SIP messages [7]
>
>  If you do give these tools a try, please send feedback to me and to the
>  GEOPRIV working group list, <[email-masked]>.
>
>  Thanks a lot,
>  --Richard
>
>  [1] <http://lis.ietf71.ietf.org/>
>  [2] draft-ietf-geopriv-http-location-delivery-05
>  [3] <http://www.netdisco.org/>
>  [4] <http://held-location.sourceforge.net/>
>  [5] <http://lis.ietf71.ietf.org/downloads/geojabber-1.0.zip>
>  [6] <http://lis.ietf71.ietf.org/downloads/HELD_Client-Executable.zip>
>      <http://lis.ietf71.ietf.org/downloads/HELD-Client-GUI-test-app.zip>
>  [7] <http://ecrit.labs.nic.at/>
>  _______________________________________________
>  Geopriv mailing list
>  [email-masked]
>  https://www.ietf.org/mailman/listinfo/geopriv
>
_______________________________________________
Geopriv mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/geopriv

---

From: Richard Barnes <[email-masked]>
Date: Fri, 04 Apr 2008 10:08:43 -0400

Hi Karl Heinz,

> traffic caused by your setup? How often did you do the SNMP querries?

This was actually something that we the experimenters (James, Hannes, 
and I), didn't have access to.  Bill Fenner from the NOC reconfigured 
NetDisco to offer an XML/HTTP interface, and we just used that 
interface.  The way it worked was that the LIS would send a GET to a URL 
of the following form ...

<http://peter/netdisco/public_locate_user.xml?ip=130.129.5.6>

... and the result would be an XML structure of the following form ...

<civicAddress>
   <country>US</country>
   <A1>Pennsylvania</A1>
   <A3>Philadelphia</A3>
   <A6>Market</A6>
   <STS>Street</STS>
   <HNO>1201</HNO>
   <LOC>NE</LOC>
   <FLR>4</FLR>
   <PC>19107</PC>
   <ROOM>Franklin 6/7</ROOM>
</civicAddress>

The LIS simple re-packaged that civicAddress structure into a PIDF-LO 
document in a HELD locationResponse and returned it to the client.

> query? 

The location we returned was just the location of the AP that the client 
IP was connected to.  The locations of the APs were entered into the 
NetDisco database manually, as they were being installed.  I don't know 
the precise number, but I think that Bill said they had 100-200 APs.

> How many clients were in your database? 

Again, the LIS wasn't maintaining the database, just querying NetDisco 
for locations in the manner described above.  So the LIS had access to 
the positions of all the hosts connected to the IETF network (>1K, I 
think?).  On the other hand, we only had 5 or 6 users of the experiment 
(because the client software I wrote didn't run very well), so the LIS 
only ever queried for location on a few hosts.

> How did you detect changes/new clients in the network? 

This was a NetDisco internal function, but I think that NetDisco was 
querying access points for updates at around a 5 minute interval.

> How long did a location request last?

I don't have precise numbers (that would have been a good idea!), but it 
was reasonably fast, no more than, say, 5 seconds.

I'll send more details off-list,
--Richard

---

From: "Winterbottom, James" <[email-masked]>
Date: Fri, 4 Apr 2008 17:10:57 -0500

Alas a lot of the traffic stats, at least from a LIS query perspective we don't have.
We are working on adding these to the LIS so that we will at least have daily stats when we run it again in July.
As for SNMP from the LIS there wasn't any, NetDisco collected all the information, and we simply got it from netdisco.

Cheers
James

-----Original Message-----
From: [email-masked] on behalf of Karl Heinz Wolf
Sent: Fri 4/4/2008 7:52 AM
To: Richard Barnes
Cc: GEOPRIV
Subject: Re: [Geopriv] GEOPRIV Experiment at IETF 71
 
Hi Richard,

Thanks in advance.

karl heinz

------------------------------------------------------------------------------------------------
This message is for the designated recipient only and may
contain privileged, proprietary, or otherwise private information.  
If you have received it in error, please notify the sender
immediately and delete the original.  Any unauthorized use of
this email is prohibited.
------------------------------------------------------------------------------------------------
[mf2]

---

From: "Karl Heinz Wolf" <[email-masked]>
Date: Mon, 7 Apr 2008 13:04:17 +0200

James and Richard, thank you for sharing your LIS experience!

cheers,
karl heinz

---

From: "Alberto Ballauri" <[email-masked]>
Date: Fri, 11 Apr 2008 10:58:30 +0200

Hi James,
We have some philosophical questions about the LIS and the HELD client,
First, we would like to know if we could use the LIS 2.0 without the SNMP
part, the part that we are really interested in is the HELD interface and
the DB. In fact we would like to populate database manually and don't be
binded to a specific localization approach such as SNMP.
Could it be achieved isolating some part of the code? So that the LIS
continue to work properly on HELD interface but independently from physical
interface.
Second, we noticed that the HELD client work as a Windows service, it suits
well when it work on the target, and could be considered as a service
enabler, but if we would like to use it on a different logical entity could
we wrap it in a jar file and use it as an isolated program? Is there
available some more doc about the building of the Java Client?
Last but not least, we are interested in using the client also on the LDP
interface, so is it able to take a uri and resolve it to gain the location
of a different target? This is the role in wich we would like to use it now,
and possibly as a program and not a service.

Thanks a lot

Alberto&Tommaso

---

From: "Winterbottom, James" <[email-masked]>
Date: Fri, 11 Apr 2008 06:35:05 -0500

Hi Alberto,

In answer to the first question.
The LIS uses things called location determination functions (LDFs), which are configured through the config.inc file.
There are instructions in that file describing how to change the LDF, the basic LIS from source forge comes with 3 options.
The first two options are SNMP variants, as you will have seen. The third option is a static mapping option, that allows you statically map an IP address to a location.
I think you can do what you are trying to do using this last option, and that will reduce the amount of code you need to write to isolate the HELD component from the LDF.

Secondly the HELD client.
The HELD client is actually more versatile than you give it credit for.
It does have DHCP discovery capability, but you can also set it to always point to a well known LIS by changing the HELDClient.properties file. This is what we did at the IETF meeting.
Next, the HELD client does provide a "raw" API function, which will take a raw XML request and simply pump it over to the LIS. In this way you can use the HELD client to make On-Behalf-Of (OBO) requests by including the IP address of the Target you want to learn the location of. This works very well and we have tested and used it extensively. I think that this is the function you wanted in your third question below.

Note that LIS 2.0 is a little less forgiving that LIS 1.0 in this mode, there is now a OBO whitelist permissions list. Any device that wants to make an OBO location request MUST have its IP address added to the list. Access to this page is available from the ..<LIS PATH>/entry web page.

As for more information on the Client we have produced quite an extensive design document that I may be able to provide to you, but not until next week, and not until I have had a few discussions with a couple of people.

If this didn't answer some of your questions I could be available for a call sometime next week.

Cheers
James

-----Original Message-----
From: Alberto Ballauri [mailto:[email-masked]]
Sent: Fri 4/11/2008 3:58 AM
To: Winterbottom, James
Cc: Richard Barnes; GEOPRIV; [email-masked]
Subject: Re: [Geopriv] GEOPRIV Experiment at IETF 71
 
Hi James,

Thanks a lot

Alberto&Tommaso

---

From: "Winterbottom, James" <[email-masked]>
Date: Mon, 14 Apr 2008 16:46:12 -0500

Alberto,

As I have now said 3 times, please take these questions to the source forge HELD forum.
I will not be answering emails sent to this list regarding this topic.

Cheers
James

-----Original Message-----
From: [email-masked] on behalf of Alberto Ballauri
Sent: Fri 4/11/2008 3:58 AM
To: Winterbottom, James
Cc: GEOPRIV; Richard Barnes; [email-masked]
Subject: Re: [71attendees] [Geopriv] GEOPRIV Experiment at IETF 71
 
Hi James,

Thanks a lot

Alberto&Tommaso