Subject: Re: [Geopriv] The 's' in HELD

From: Tim Thome <[email-masked]>
Date: Wed, 30 Apr 2008 11:26:39 -0700

Richard raises a good point, as devices may have requirements for 
emergency contexts... including support for devices that do not have a 
business relationship with the network access and/or service provider.

Should this context be handled separately?

Thanks!

Tim

Richard Barnes wrote:
> Is TLS really used for every HELD transaction, as opposed to being 
> available for every transaction?  This seems to be a deviation from the 
> normal pattern for Internet protocols to have a base protocol without 
> TLS and an (mandatory) option to use TLS as desired.  More importantly, 
> it seems like TLS might be undesirable in some circumstances, e.g., 
> emergency calling.
>
> Is there a reason for this extra-strong requirement?
>
> --RB
>
>
>
> Thomson, Martin wrote:
>   
>> I missed this in the changes for -06.  Please forgive my ignorance, but
>> I wasn't there at -71 and it appears that only the conclusion was
>> captured, not the rationale.  The minutes focus on whether there should
>> be a URI scheme or not, but make what seems (to me) to be a logical
>> leap:
>>
>>           Question: Does this HELD: scheme require TLS? Ans: Yes. Then
>> it needs
>>           to be a HELDS: scheme.
>>
>> I don't believe that the letter 's' addresses "concerns over referential
>> integrity" as stated by the held-06 change-log.  So can anyone justify
>> the above statement?  Is there some IETF guideline I don't know of that
>> states that URI schemes for protocols that use TLS have an extra 's'? 
>>
>> Cheers,
>> Martin 
>>
>> ------------------------------------------------------------------------------------------------
>> This message is for the designated recipient only and may
>> contain privileged, proprietary, or otherwise private information.  
>> If you have received it in error, please notify the sender
>> immediately and delete the original.  Any unauthorized use of
>> this email is prohibited.
>> ------------------------------------------------------------------------------------------------
>> [mf2]
>>
>>
>>     

-- 
Tim Thome - <mailto:[email-masked]>
Senior Staff Engineer
Technology Development
Kyocera Wireless Corp.
San Diego, CA

_______________________________________________
Geopriv mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/geopriv

---

From: "Winterbottom, James" <[email-masked]>
Date: Mon, 5 May 2008 16:40:07 -0500

Hi Tim,

I am not sure what you mean by a business relationship with the access
provider. The Target device must have had a sufficient enough
relationship with the access provider that they were able to connect to
the network in the first place. Could you elaborate on your concerns
please?

Cheers
James

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
Behalf
> Of Tim Thome
> Sent: Thursday, 1 May 2008 4:27 AM
> To: Richard Barnes
> Cc: GEOPRIV; Mary Barnes; Thomson, Martin
> Subject: Re: [Geopriv] The 's' in HELD
> 
-----------------------------------------------------------------------
> -------------------------
-----------------------------------------------------------------------
> -------------------------
> >> [mf2]
> >>
> >>
> >>
> 
> --