Subject: [Geopriv] RFC 4776/5139 and xAL

From: Richard Barnes <[email-masked]>
Date: Sat, 22 Nov 2008 20:18:36 -0500

Hi all,

Looking at the civic location API in Android[1], I noticed that they're 
claiming/aiming to be compatible with the OASIS standard for addressing, 
which they call xAL [2].

Is anyone familiar with this format, or in particular, does anyone know 
how this format relates the the CAtype formalism (in binary and XML) 
that GEOPRIV has defined?

Thanks,
--Richard

[1] <http://code.google.com/android/reference/android/location/Address.html>
[2] <http://www.oasis-open.org/committees/ciq/ciq.html>
_______________________________________________
Geopriv mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/geopriv

---

From: "Carl Reed" <[email-masked]>
Date: Sat, 22 Nov 2008 19:52:12 -0700

Yes, I helped on the latest revision of CIQ/xAL. I specifically helped on 
extended the geo elements to be consistent with GeoRSS/GML. FYI, KML 2.2 
(now an OGC standard) uses xAL.

I will check into your questions.

Regards

Carl

----- Original Message ----- 
From: "Richard Barnes" <[email-masked]>
To: "'GEOPRIV'" <[email-masked]>
Sent: Saturday, November 22, 2008 6:18 PM
Subject: [Geopriv] RFC 4776/5139 and xAL

> how this format relates the the CAtype formalism (in binary and XML) that 
> GEOPRIV has defined?
>
> Thanks,
> --Richard
>
>
> [1] 
> <http://code.google.com/android/reference/android/location/Address.html>